Desktop corrupted(?) after updates.

Just had a bunch of updates (hundreds, if I remember correctly…), done a reboot, and it has totally borked my desktop.
Desktop is 2560x1080, wallpaper is now about 1" square in top-left corner. Right-clicking on that square gives me the standard right-click desktop menu, but only operating on that square. All my desktop icons have disappeared, except for a Trash Can that was never there before. Desktop folder still fine in file manager. See image.https://drive.google.com/file/d/1Qo2Q1go6PDWXgsdf9Ai85MvhsZNt1VA5/view?usp=sharing
Everything else seems to be working OK; ie panel is fine, menu ok, and apps working ok.

Thanks.
https://drive.google.com/file/d/1Qo2Q1go6PDWXgsdf9Ai85MvhsZNt1VA5/view?usp=sharing

Better explain first what desktop when you tell something about it. Now we have to read your whole post while wondering what you talk about, until at the very end, even after the description, oh yes, there it is!

When you just had hundreds of updates then there are two possibilities IMO. Either you never updated since installation from the install medium. Or you have borked your repos (with e.g. adding a Tumbleweed one).

When you think the first is not the case, then please show your repos:

zypper lr -d

And some extras.

Better post images on https://susepaste.org/ Not everybody likes Google to execute scripts on their system (which is what that site requires before you see anything).

You say you had updates, but did not report how you applied them.

Sorry, thought I had replied to my own post, but forgot to press Submit…
After a couple of reboots, it all came good.
But to reply to your post:
Repos never changed, Regularly update (at least weekly…, and yes, there were still ‘hundreds’ of updates - not sure…)
But thanks for the reply!

Better check your repos.

zypper lr -d

There was a large update to KDE. They had to recompile everything to make the debug info files available. But it did not cause any problems here. As far as I know, there were many files updated but no important changes to them.

Thanks for that information. I was “assuming” that there would not be more then 10-20 updates for Leap when you patch about once a week. I was wrong :frowning:

The only change made, was to recompile to include the hooks needed for the Debug Info – needed to report crashes to the KDE Plasma folks …

The related Debug Info packages are located in the “openSUSE_Backports_SLE-15-SP3_Update_debug” repository – <http://download.opensuse.org/update/leap/15.3/backports_debug/&gt;.
[HR][/HR]One issue – KGlobalAccel:

The patch “openSUSE-SLE-15.3-2021-1802” repaired the ‘/usr/bin/kglobalaccel5’ crash when the KDE Plasma user logs out but, the patched package was placed in the “SLE” repository, rather than the “Backports” repository.
[HR][/HR]This Forums thread gives some more background to the “reasons why” – <https://forums.opensuse.org/showthread.php/558956-Cannot-install-debuginfo-for-some-packages-(e-g-KDE)&gt;. >:)

As I said, all good after a couple of reboots.
Settled down and is now working like a well-oiled machine!
Thanks.

This morning I had exactly the same phenomenon, NOT right after any update (although I always install updates immediately). I was quietly working on the computer and, suddenly, my cursor was blocked and only worked vertically (I have a corded mouse, so it was NOT a question of low battery power). I rebooted … and I came to the situation you described: desktop had disappeared, except a small rectangle in the upper left corner. I decided to reboot into an earlier pre-update version, and there was my entire desktop again. I then tried to do “sudo snapper rollback” but that did NOT work because “the ambit is not defined” (?) - which is not normal, because normally snapper works well. So I simply rebooted again, and this time everything is OK again with my desktop. Very strange …