Desktop capture


I’m trying to capture my desktop screen and audio , before I used xvidcap but after upgrading my system I can not use it and also recordmydesktop anymore these APPs hanged when I try to use them.Now I try to use recorditnow via ffmpeg recorder interface , it work properly in recording the desktop but it does not record the sound , so I tried to add below options to its command
-f alsa -ac 2 -i hw:0,0
but it just record sound at the beginning and just for 1 second. anybody can help me???
Also when I try to capture my desktop with ffmpeg directly from command line with below command I face with same problem!!!
ffmpeg -f x11grab -s 1024X768 -r 30 -i :0.0 -f alsa -ac 2 -i hw:0,0 ~/out.mpg

it’s so important for me!


Read from here
xvidcap not working after update to 11.4


Thanks for reply , I read it before but it did not work for me . I face with below ERROE:
[alsa @ 0x64ec40] cannot open audio device hw:1,0 (No such file or directory)
hw:1,0: Input/output error
Also I just can find hw:0,0 in my system. :frowning:
do you have any idea???

Thnaks in advace :slight_smile:

So use hw:0,0 instead

You can tell what your hw:x,y setting should be by running:

arecord -l 

and pay close attention to the card# (x) and the subdevice # (y).


linux-2jfi:~ # arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

So I guess I have hw:0,0 only , also as I told when I use hw:0,0 it just record sound at the beginning and just for 1 or 2 second.


OK, so " hw:0,0 " it is.

Is this a openSUSE-11.4 installation ? If so, do you have pulse audio enabled ? If so, you can also likely use ‘pulse’ instead of ‘hw:0,0’. ie from your post:

Instead if openSUSE-11.4 with pulse enabled you could try:

ffmpeg -f x11grab -s 1024X768 -r 30 -i :0.0 -f alsa -ac 2 -i pulse ~/out.mpg 

The command that you have originally used, I have only tested on openSUSE-11.3 PC with out pulse being present, so its possible for openSUSE-11.4 one needs to specify the audio codec which you have not done … ie try the following command which works for me on openSUSE-11.4 :

ffmpeg -f alsa -ac 2 -i hw:0,0 -f x11grab -r 30 -s 1024x768 -i :0.0 -acodec pcm_s16le -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.avi 

where you can see I have specified ‘pcm_s16le’ as the audio codec.

OK - so I gave you a couple of different ffmpeg possibilities to try. Let us know how they work out.

If a frame rate of ‘30’ does not work, try something slower, such as ‘15’.

Also, provide us the output of:

rpm -qa '*ffmpeg*' 

so we can see what you have installed for ffmpeg.


When I try to use pulse I face with below massage :

dara@linux-2jfi:~> ffmpeg -f alsa -ac 2 -i pulse -f x11grab -r 45 -s 1024*768 -i :0.0 -acodec pcm_s16le -vcodec libx264 -vpre lossless_ultrafast -threads 0 output.avi
FFmpeg version SVN-r201104161305, Copyright (c) 2000-2011 the FFmpeg developers
built on Apr 16 2011 11:36:21 with gcc 4.5.1 20101208 [gcc-4_5-branch revision 167585]
configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-postproc --enable-gpl --enable-x11grab --extra-cflags=’-fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm’ --enable-debug --disable-stripping --enable-libgsm --enable-libschroedinger --enable-libdirac --enable-avfilter --enable-libvpx --enable-version3 --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libx264 --enable-libdc1394 --enable-pthreads --enable-librtmp
libavutil 50. 40. 1 / 50. 40. 1
libavcodec 52.119. 1 / 52.119. 1
libavformat 52.108. 0 / 52.108. 0
libavdevice 52. 4. 0 / 52. 4. 0
libavfilter 1. 79. 0 / 1. 79. 0
libswscale 0. 13. 0 / 0. 13. 0
libpostproc 51. 2. 0 / 51. 2. 0
[alsa @ 0x63f8b0] capture with some ALSA plugins, especially dsnoop, may hang.

Also I’m using opensuse 11.4 X64 .

Also :

dara@linux-2jfi:~> rpm -qa ‘ffmpeg

Also I tried to use the code that you send for me but I face with same problem .

Thanks for you help

Oh boy. That IMHO ‘could’ be the problem. Too many conflicting ffmpeg packages. Why so many ? In GNU/Linux IMHO typically more is WORSE, and not better.

On my 32-bit openSUSE-11.4 with LXDE I get:


Only 2 packages. Just 2 !! You have 2 dozen !

I have no idea why you installed so many ffmpeg apps. I know they are NOT all installed by default. Do you know why you installed so many ? Again, in GNU/Linux more is NOT better and it is often worse.

I have the same as @oldcpu but _64


Now what I have to do??? It seems my Sound card driver has problem , how could I reconfigure it??? And should I remove all packages that did not install by default?? Actually i thought its so good if I install all packages!!!


Also before I install all these packages I faced with my problem , and according to the feedback from xvidcap or recordmydesktop and even many Apps that just record the sound I guess my sound card driver has problem.


AND I can not figure out why it record sound at the beginning for few seconds and the suddenly stop recording the sound???

dara-hr, with so many apps (of dubious utility - you have not explained to us EXACTLY why each of them is needed, with references proving why your view is correct), its very difficult to know what the problem might be. It could be your alsa driver or it could be the many apps you have installed. What you have in place is such a mess, I would not know where to start. I would never do this to myself. Sorry, but I have no advice.

Someone else will need to help you on this thread as the MASSIVE unncessary apps you have installed has put this problem out of my experience and out of my willingness to spend my volunteer time on. Sorry.

oldcpu, anyway thanks for your help and your time, it seems i should manage my apps from the beginning!

Good luck!

If you use GNOME3, just press: CTRL+ALT+SHIFT+R :wink:

TNX , I use KDE 4


As what posters spoke on the above thread here, there are many problems about why you can’t record desktop audio. You may need to check your desktop sound card, hard drive.

As far as I know, if you could hear sound on your desktop, you could use a desktop audio recorder to record audio. I am not sure this will satisfy you or not.

Maybe someone can help me out with this one. here is my script for screencasting.

My ffmpeg Desktop capture is working fine. Records desktop and audio separate (two xterm terminals, one for screen (Beeld) and one for Audio) and combines it to an mp4 and then puts automatically an intro in front of it. All great.
One problem: when I quit the sceencast by hitting q in the xterm screen (Beeld) xterm quites only the screen (Beeld) not the Audio xterm.
Have tried with killall xterm but then the audio stops a few seconds to early.
I would like to quit the Audio terminal automatically a few seconds later as the screen.

Hope someone has an idee
Greatings Karel

Hi All,

I has been a while since I have tried to capture my desktop’s activity and audio. In the past I used RecordMyDesktop with good effects to generate .ogg/Vorbis output, then converted the file to .avi using a script that I have. At the time I was making videos of the early Beryl / Compiz 3D desktop effects and posting to YouTube.

I recently compiled / installed the latest XBMC Media Center 11.0 (Eden) from source code and want to record it running on my desktop. This is one cool app!

Anyway, RecordMyDesktop seems to no longer function. I have tried others, but also no success. So, let’s try this in Terminal. I am running a notebook with openSuSE 12.1, KDE 4.0 desktop, internal recorder and the speakers are a standard peripheral external set-up just plugged into my audio output plug on my machine. I have been Googling around resulting in outdated threads, and would like some assistance here.

Thanks in advance for any replies.