Desktop application not starting after login, returning to login screen

Good afternoon,

When I boot, the login screen appears, when I enter my login credentials the screen goes black with a flikkering cursor in the upper left corner, and after a approx 5 seconds it returns to the login screen.

I’m using:
Open Suse tumbleweed 6.9.1-1 default
On a Dell laptop.
The problem started after updating.

It appears that the desktop environment is not starting.
When I press CTRL+ALT+F1 or CTRL+ALT+F6 I can login as root and as user and I can reach all my files and folders etcetera. But I would love to get the desktop environment running again.

When I login in the terminal environment using CTRL+ALT+F1 and I check for updates or patches using zypper, I get the message that everyting is up to date,

When I enter zypper update I get the message that there is nothing to do and the following packages will not be installed:

  • libOSMesa8-32bit
  • librist4
  • Mesa
  • Mesa-32bit
  • Mesa-dri
  • MEsa-dri-32bit
  • Mesa-gallium
  • Mesa-gallium-32bit
  • Mesa-libEGL1
  • MesaLibGL1
  • Mesa-LibGL132bit
  • Mesa-libapi0-32bit
  • vlc-codec-fluidsynth

I assume something went wrong during updating but searching the internet didn’t provide a solution. So here I am. Hoepfully somebody has an idea.

Thanks in advance.

Welcome to the openSUSE forums.

I can not help directly with your problem, but Tumbleweed should ONLY be updated with

zypper dup
1 Like

Linux newbie here. Don’t really have an answer to the problem, but I’m running into very similar issues, want to help shed light into this for anyone willing to troubleshot, and figured it’d be best to reply here rather than create a new post.
I tried running a tumbleweed liveCD iso (KDE environment) to try out the system before installing, and after only a few seconds the screen would freeze, go black, then return to the log in screen. Yes, I’ve seen the warning on the download page stating that the liveCD version isn’t the best experience, but I’ve also run into the very same symptoms running two other rolling release distros (one based on manjaro and other on arch), with different DEs as well, both liveCD and installed ones. They all do the same thing. Boot, log in, stay alive for a few seconds, then return to the log in screen. Doesn’t seem to be an issue with any particular DE or distro, so I’m not even sure this is the right place to report such a thing…
That said, I have a error log I managed to extract with journalctl from one of the other distros I tried, if anyone think it could help. If provided with direction (I am a newbie to linux, even more newbie to Opensuse), I could try extracting logs from suse as well. Sincerely invested in this issue, as I do wish to migrate from ubuntu to tumbleweed, but can’t really migrate to a system I can’t use. Nor can I make head or tails of what’s happening

Forgot to mention, one of the other distros I mentioned above has an ISO from January available, and that version works without issue for me (until it installs and, of course, updates all packages in the process), so it would seem something that updated between January and May has broken compatibility with some system, and seems to follow what OP described as well

1 Like

Small update, when I am in the login screen, on the bottom left corner I can choose “Desktop session”. When I choose Plasma Wayland, I have this problem. When I choose Plasma (X11) I have no problem.

Sorry I haven’t found this out earlier. It looks like Wayland gives me this problem.

Hi,

Fwiw. Ran into a similar poblem yesterday. Found that if iceWM or X11 selected at the login screan all worked normally. Only isue if plasma selected.

1 Like

Looking at the workarounds present here, as well as some tests I’ve been trying myself, I now believe my problem may be unrelated. I have now narrowed the problem to mouse clicks causing the GPU to crash. I’ve been doing this in a live version, however, and can’t figure out how to export the logs from the terminal. I guess I’ll install it and just start a new topic once I gather everything

Good luck. Hopefully you’ll find a solution.

1 Like