desesperate ati on 1600x900 resolution

Well, nowdays linux on a laptop become a privilege. I have here an Aspire 7250, Radeon HD 6320. I discouraged the owner to buy anything from ATI, but AMD don’t uses anymore this brand (very tricky), and I can guess why, calling suddenly the graphic card “embedded AMD graphic card”. The word ATI seams to be no longer in use, however they still offer on the own page the trashy linux drivers with no comment. Before I let the laptop owner send back the machine, he has the right during 2 weeks, I am checking for some install possibility.
Only opensuse 11.4 provides a GUI instead a black screen with no console.
Now, Xorg loads fbdev instead radeon and the 1600x900 screen has a wrong resolution (VESA).
If I modprobe radeon and force the X start, I get a black screen with backlights on, no kbd and mouse loaded.
Xorg -configure generates a xorg.conf with fbdev, changing entries leads to fallback.
The distribution installed driver seams to be radeonhd.
I am not an xorg.conf specialist and I didn’t be able to get something of useful.
Of course I tried all variations also including a start with nomodeset.
Has somebody some idea?
thanks in advance.

If you manage to get a terminal and a network connection, install atiupgrade and run it.

  • If you’re installing 11.4, use the 11.4 repo:
zypper ar  PTA

Thanks, Flux !
What I am using right now is a second “new fresh” install. I found your information and I tried to run the script in the past fresh install. The script output sad that the optimal driver is already installed. If I am missing something I will let it run again. Should I ?

Humm … On a fresh install, it’s weird… unless you did already install the driver from ATI website. Does the script tell you which version is installed: 12.1?
What happens if you pass the version as an argument to the script:

atiupgrade 12-1

If you know that you didn’t install the driver before (this driver is NOT installed with openSUSE), you can say “y” when atiupgrade asks you if you want to continue.
Make sure you have the latest version (from repo). Don’t copy/paste and use an older version from the forum.

You are right Flux! In effect by the first install I had installed and uninstalled (using the bundle) the proprietary driver. The actual install is original and untouched from ati drivers, I made just the suse updates and there are no further repos. Now I have to go, but tonight I will reinstall the script and run it. Thanks a lot indeed.

Impressive! Now I installed 12.1 64 bit. Perfect, in this case the 3d acc. is irrelevant! Es soon I have time I’ll study that script. Thanks a lot, you made an austrian lady happy (and me too). Concerning the other post, please let me first finish this one laptop,

Hi Flux,
I can keep this laptop a few days longer, so I try still to get read of bugs. Among other things I made a ridiculous discovery which could be perhaps of interest for you:
after installing a vanilla kernel in a fresh installed suse 12.1, no atiupgrade, the system starts immediately with the right resolution, no black screens and seams to be quite faster.

Do you mean a fresh install or a new kernel? If it’s a fresh install, you’re not using the ATI proprietary driver at all. If you only installed a new kernel (on a system that already has the ATI driver installed), the script /etc/init.d/boot.fglrxrebuild will detect that the fglrx module for the new kernel is missing and rebuild it. You don’t need to update the driver.

No, I mean a really fresh install, just the updates and the desktop kernel changed in vanilla. Of course fglrx is absent, the driver could be a radeon but is not worse (3d is always absent). The relevant point is that the X server finds this time the screen natively and also the metric. By kernel.desktop and 1600x900 that is impossible, at least on the mentioned laptop. I think laptops with this resolution will spride up quickly: the average price is €500 when I didn’t find on the net 1680x1050 models for less as €800. I refer to a 42-44 cm monitor diagonal.
Anyway I left the distro kernel + atupgrade. By the way, have you an idea about booting with the proper resolution? The laptop boots with 1024x768, by initrd switches to some intermediate vesa resolution and only finally riches 1600x900.

OK. Sometimes it gets the right resolution and sometimes it does not. It depends on the EDID sent by the monitor/display and on the ability of the driver to read this info. It also depends on the gfx card.

It depends, with kms, the vesa resolution (the one you can set with vga= in the kernel options) will be replaced after a couple seconds at boot. Are you talking about the resolution in console mode or under X? To set the resolution under X, just set

Modes   "1600x900" 

in the screen section of /etc/X11/xorg.conf

and if it still doesn’t work:

Option        "PreferredMode" "1600x900"

in the monitor section.

It suffices in most cases. But there are exceptions of course.

yes, it is like poker. Modes or “PreferredMode” does not work for me. :slight_smile: anyway I got at least a 3d acc. with 4300 frames. I did it simply using the post in this forum:
I found a and made the symlinks.
After reflecting on your remarks I think the problem on that laptop is just the wrong bitmap on boot. 1024x768 instead 1600x900, because the image is horizontally stretched. mkinitrd didn’t help, the script puts in the wrong bitmap again. resolutions as 0x34b in the kernel boot options are rejected. any idea?

That’s what I said. With kernel mode settings, they have no effect. When you install the proprietary driver, kms gets disabled in the initial ramdisk.