Dependency resolution failed

I’m currently running Suse 11.1.
Updates to my system are done automatically.
However, of late I have had an endless set of messages like this:

patch:libfreebl3-3241.noarch conflicts with mozilla-nspr.x86_64 < 4.8.6-1.1.1 provided by

I haven’t changed anything on my computer lately, so don’t understand why I am getting this all of a sudden.

Can anybody help me correct this problem?

Many thanks.

What repos do you have?

zypper lr -d

I think that works in 11.1

BTW 11.1 is getting close to not being supported. You may want to upgrade.

You have a mixture from packman and updates. Any reason to have the
packman version of mozilla-nspr?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1:45, 2 users, load average: 0.23, 0.15, 0.09
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21

Hi Malcolm,
I very much regret that I know very little indeed about solving any of the problems that occassionally affect my Suse OS. I have had to rely on help from the forums to solve several irritating problems. Changes made to my OS were all made to get round conflicts that apparently cropped up. If you search my posts on this forum, you might be able to understand why I have the combination that I have better than I could ever explain.
The last time I had a conflict was discussed here:
Unable to update security patch
If you read through this, it may well become apparent why I have what I have!!
If you can help at all, I would be very grateful.

Ahh OK, so it you run YaST (The qt version) and then select repositories then scroll the list to the packman repository. If you scroll through the list do you see ‘blue’ items?

Hi Malcolm,
Not sure exactly what you mean by “qt” version.
However, Packman is on the list, at the bottom.
What I see is: 115/enabled/autofresh/packman
Index of /suse/11.1
It has the highest mark (115)
Hope that makes sense!