I tried upgrading my system today, but there is a dependency issue.
Repositories I have enabled now: system, packman, repo-debug, repo-non-oss, repo-oss and repo-update.
(I did install some multimedia codecs when the install was brand new, and then removed the repositories.)
Warning: You are in the process of upgrading the distribution with all active package wells. Make sure they are all compatible before proceeding. Run "man zypper" for more information about this command. Calculates distribution upgrade… 12 problems: Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64 Problem: problem with the installed package libavdevice58_10-4.3.2-4.3.x86_64 Problem: problem with the installed package libavfilter7_85-4.3.2-4.3.x86_64 Problem: problem with the installed package libavformat58_45-4.3.2-4.3.x86_64 Problem: problem with the installed package libavutil56_51-4.3.2-4.3.x86_64 Problem: problem with the installed package libpostproc55_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswresample3_7-4.3.2-4.3.x86_64 Problem: problem with the installed package libswscale5_7-4.3.2-4.3.x86_64 Problem: libavfilter7_85-4.3.2-4.3.x86_64 requires libavresample4_0 = 4.3.2-4.3, but this required file does not exist Problem: libavfilter7_85-4.3.2-1.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: libavfilter7_110-4.4-4.1.x86_64 requires libavresample.so.4.0 () (64bit), but this required file does not exist Problem: problem with the installed package libavcodec58_91-4.3.2-4.3.x86_64 Solution 1: Install libavcodec58_91-4.3.2-1.1.x86_64 (with manufacturer change) http://packman.links2linux.de -> openSUSE Solution 2: Keep the obsolete package libavcodec58_91-4.3.2-4.3.x86_64 Well from the solutions above with numbers, or skip, repeat or cancel [1/2 / s / r / c / d /?] (C):
Today’s update of ffmpeg-4-4.4-4.1 on Packman and related packages caused a bit of a mess.
I accepted option 1, ending up with both libavcodec58_134 (from Packman) and libavcodec58_91 (from openSUSE OSS), and similarly for related packages.
Everything seems to work well, at least so far.
Hopefully the situation will be cleaned up with the next few snapshots…
See also https://forums.opensuse.org/showthread.php/552948-zypper-thinks-a-newer-release-is-obsolete
Have this same issue this morning in TW . . . ran a zypper, shows “534 packages to upgrade” and then “11 questions to answer on choice of dependencies” . . . looks like the same questions given to the OP of this thread.
I then tried to run it through package updater and it errored out . . . showing the 11 dependency issues–seems like a lot of questions . . . .
You may run ’ zypper dup --no-allow-vendor-change’ and select option ‘keep obsolete …’. This will update sucessfully packages in the main repositories and postpone update of those depending on packman.
Thanks a lot. I selected hold obsolete, and was able to install some 250 packages. When the installation finished, I still had the same dependency issue as below. Having searched some more, I stumbled across an official statement slandering the FSF as racist and sexist, and therefore discontinuing sponsorship.
I am still here . . . ran the “no-allow-vendor-change” flag and it seemed like the 534 packages went through, except for the 11 packages with dependency issues. The test kept getting more complex as it went on, the answers weren’t always #2 . . . took a lot of concentration, focused concentration to complete the . . . I guess 11 questions is more like a “quiz” ???
My other question is, what does it take to get the focused attention of a global moderator??? I’ve had a few posts on the ubuntu forums flagged by the “minor observers” apparently because I used “sarcasm” . . . which I guess they figured could damage the psyche’s of small dogs and children . . . had to argue my case in the “jail section” to get my “out of jail card after promising to never never use sarcasm . . . on the forum.”
So far here on the forum I haven’t had any those kind of issues, but still, it would lighten my day if something of what I posted required global moderation . . . help me out guys, what’s the technique??? Openly complain about having to deal with dependency issues for every upgrade in a rolling distro??? Why, why is that happening to us?? >:(;):sarcastic:
Let us help here to get problems solved without any personal “sarcasm” or asking how to save the world.
Therefore are the subforums I mentioned above.
Back to the problem
This was today on the Packman mailinglist:
It looks like there needs to be an A_Tumbleweed_ffmpeg-4 package.
Since last week there has been a lot of activity in
multimedia:libs/ffmpeg-4 and this has resulted in
“zypper dup --no-allow-vendor-change” conflicts. The only way to avoid
being forced to change vendor of ffmpeg-4 libs to openSUSE is to keep
“obsolete package” which vlc and friends are built against, this
wouldn’t happen if the package was linked to Factory. Of course when
ffmpeg-4 is finally accepted this problem will go away after all the
affected packages rebuild.
Indeed it does seem like sarcasm is underappreciated around the world of linux forums . . . and I would agree it is entirely a fruitless task to try to “save the world.” I tried to delete the “humorous” aspects out of my post to streamline the flow of traffic, but it was after the 10 minutes . . . .
But, my point about running into “dependency issues” with increasing frequency in OpenSUSE/TW is valid, and this is relatively “new” problem, IMHO based on a few years of playing around with SUSE flavors. Previously to let’s say the last 6 months, running a zypper was relatively uncomplicated affair and didn’t require a “quiz” the get the job done, etc.
So, what does that mean? Here in SoCal yesterday was 4/20 . . . but I ran a zypper this morning and had the 11 dependencies. So, How do we access this “snapshot”?? Does that mean fresh install, or in a day or so zypper will be accessing the updated snapshot packages and there will be no “quiz” questions to answer???
I’m still updating. But it looks as if Tumbleweed is going to a newer version the libav packages. And apparently “packman” updated to those ahead of time. So you were having problems because the newer “packman” versions didn’t match the slightly older versions in Tumbleweed. Now that Tumbleweed main repo has also updated, hopefully everything will match again.
I’m confirming that with my system. Yesterday (version 2021-04-20, IIRC) offered a variety of downgrade versus breakage options, with Vendor changes. On todays’ ‘zypper dup’, it can all be recovered to use Pacman as the primary source for the dependencies of ffmpeg-4, and upgrade completed without error.
(Except for pulling in 1500 ‘texlive’ packages which I don’t want and never use, but that’s a different topic. The curse of building too many things with ‘Recommends’.) >:(
Yep. Good times. Between yesterday’s upgrades using “keep obsolete” and today’s upgrades that was “1571 packages” upgraded, and on reboot, all is well.
But, for such a large upgrade I first tried to drop into a TTY and root, and it said, “Packagekit is blocking the highway, please close Packagekit, or use an alternate route”??? I don’t have the skilz to do that via console, so I quit the TTY and launched the GUI terminal and . . . and ran the zypper . . . zypper then found no complaints from Packagekit . . . . 45 minutes later the thousand plus packages were installed!!! Tumbleweed lives!!!