"Dependency failed for Cryptography Setup" at boot

Hi all,

I saw this pop up in other threads, but didn’t find anything I could apply, or at least that I knew how to apply. So here is another thread…

I get this on boot:

    **] A start job is running for dev-disk-by\x2duuid-d0129dc8\x2d17f1\x2d4393\x2d92b1\x2d993288330b06.device (1min 30s / 1min 30s TIME ] Timed out waiting for device dev-disk-by\x2duuid-d0129dc8\x2d17f1\x2d4393\x2d92b1\x2d993288330b06.device.
[DEPEND] Dependency failed for Cryptography Setup for cr_sda1.
[DEPEND] Dependency failed for Local Encrypted Volumes.

so the thing waits 90 seconds, and then everything seems to boot fine.

# cat /etc/crypttab 
cr_sda1  UUID=d0129dc8-17f1-4393-92b1-993288330b06

Also, on a side note, I’m mounting an NFS partition, this is what’s in fstab:     /mnt/nashome    nfs4    defaults 0 0 

and I get this at boot:

[FAILED] Failed to mount /mnt/nashome.
See 'systemctl status mnt-nashome.mount' for details.
[DEPEND] Dependency failed for Remote File Systems.

Once the system is up and I can log in I ran:

# systemctl status mnt-nashome.mount

● mnt-nashome.mount - /mnt/nashome
   Loaded: loaded (/etc/fstab; generated)
   Active: active (mounted) (Result: exit-code) since Sun 2018-04-08 11:22:17 BST; 19min ago
    Where: /mnt/nashome
     Docs: man:fstab(5)
  Process: 1276 ExecMount=/usr/bin/mount /mnt/nashome -t nfs4 (code=exited, status=32)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

So, waiting a little time, also the NFS partition seems to be mounted… So why does it take so long to mount both?

Thanks a lot!

Probably the network isn’t up yet when the system tries to mount it during boot.
Try to add “_netdev” to the mount options…

See “man mount”:

              The filesystem resides on a device that requires network  access
              (used  to  prevent  the  system  from  attempting to mount these
              filesystems until the network has been enabled on the system).

No idea about the other problem though.

Totally guessing here.

My guess is that something is slow to start up.

Is this encrypted file system on a different device? Maybe it takes time to spin up, and is not recognized until after that time. And, incidentally, this could be a hint that the disk is failing.

As for your NFS problems – I suggest you look into using “autofs”. That way the NFS file system is not mounted until needed, and by then everything necessary is probably running.

that shouldn’t be the case, it’s on a fast SSD… anyway, I ended up doing a clean installation, so that now the drive is not encrypted and everything seems fine.

Thanks! I looked into that and set it up, really nice. I tried with _netdev but that didn’t seem to make a difference. I read somewhere that netfs has to be installed and up, I looked it up in yast and didn’t find it, so gave up and went with autofs, and seems to be working fine… for now!