Hey everyone. I’ve used opensuse since 10.2 and had been very loyal. However, lately I did a new install with opensuse 11.1 64 bit from the dvd (had done it before from the live-cd too) and ran into an annoyance. Without installing any software other than the updates, I tried to do the upgrade to kde 4.2 (ships with kde 4.1.3 I believe) and ran into dependency hell – btw, one click install. The live cd install is no different. I cannot install much since I keep getting the dependency error. I feel like giving up since the system wasn’t changed since the initial install other than updates; surely it must be something within opensuse. I reformatted and tried it again to no avail. Am I the only one seeing this?

KDE4.2.* (How To Add) Guide. - openSUSE Forums

The key to the solution is in the priority of the Update repo!

Some kde4 apps installed will be using a different naming policy to those in the new 42’ repo’s. So you actually have to delete some apps, eg; kde4-amarok is now just amarok
And the kde prefix has been given to kde3 eg; kde3-amarok

There is a live cd spin which will install 4.2 if you prefer.
“KDE Four Live” CD](