Dependancy issues with GOG version of Baldurs Gate 2 EE: missing

I am having problems getting the GOG version of baldur’s gate 2 EE to run. I have OpenSUSE 13.2 64bit with Plasma 5 installed. The game seems to install fine but when I try to run the game nothing happens. When run in the terminal I get the message:

Running Baldur’s Gate 2 Enhanced Edition
./BaldursGateII: error while loading shared libraries: cannot open shared object file: No such file or directory

Does anyone know how to fix this so I can get the game to run?

Pure guess is that the game may be 32 bit and you run 64.bit OS so you need the 32 bit version of the library mentioned in the error

Thanks for your response :). I tried installing the “mesa-32bit” package but that didn’t help. Is there something else I can try?

Still get the same error?
There may be other libs needed in 32 bit

Still the same. Do you have any idea which libraries I should look for?

A quick look at the GOG website for this product should tell you which additional libraries are required. It mentions 32bit binary only, required packages, and works on “Ubuntu 14.04 / Mint 17”.

Was an .rpm package provided, or how did you install it?

It was installed through a installer packaged as a shell script. That is how all GOG games are installed nowadays :).

I partly managed to fix this problem by searching for “libGL” in the package manager and install some of the 32bit packages that seemed relevant. Probably should have realised that was a good idea earlier. Sometimes my thinking fails me. After this I got the game to start, though it failed to render backgrounds and menus, so it still isn’t playable unfortunately. I have decided not to spend more time trying to fix this though, and I really have no idea where to go from here. It is probably easier to install it in a Linux mint or Ubuntu partition instead.

But thank you consused and gogalthorp for helping me. It is appreciated :slight_smile: