Dell XPS M1730 - RAID 0 ICH8M-E Controller

I have a shiney new Vista based Dell M1730 XPS laptop with all the bells and whistles…including dual NVidia 8700’s with SLI (which I presume will be a problem later) and dual 320GB SATA drives in RAID 0 using the built in Intel ICH8M-E RAID Controller.

Is there a way to get the drives recognized during the installation process? All I get is the following message:

The partitioning on disk /dev/sda is not readable by the partitioning tool parted, which is used to change the partition table…

Bottom line, I can create the partitions manually prior to the install and it works, but I cannot install on a clean array. Not a huge issue as it works and recognizes the drives once installed. I am just trying to learn how to make it work from the start.


I’m not sure I follow what you mean here by a “clean array” - isn’t that the same thing as having creating the partitions manually in advance? I suspect the issue may be a matter of when the necessary kernel module gets loaded, but I’m unclear from your description.

Sorry about being unclear. Let me state up front that this is more a “I want to learn how to use it the right way” kind of question - not a “Ya, I can fall back, cheat and do it this way” kind of thing - if that makes any sense.

What I would like to be able to do is initialize the RAID array (no partitions at all) and do whatever it takes so that I can create partitions during the initial installation. Again, I know I can use Partition Magic or a dozen other tools from BartsPE to set up the partitions ahead of time (and have done so). Just trying to learn “How the masters do it” kind of thing. If you can just point me to an faq or man page I will gladly to the research…just too new to know where ot begin.


Guys - My Bad.

I use Partition Star and Boot Star(from Welcome to the homepage of Star-Tools) to create a dozen partitions on my RAID array. That way I can multi-boot to numerous OSes and have a password protected boot screen etc. - long story, but I like options. Bottom line here is that it does some funkyness to teh MBR and PARTED didn’t like it. When I reinitialized the array it worked just fine. I foudn some posts where you can create partitions with Partition Magic and get teh same weird issues.


Glad you got it sorted out!

Does your Intel RAID controller not have a BIOS to allow you to create the RAID?

I can tell you that I tried installing using adaptec 29320 RAID1. It shows up as a DM RAID during the install. GRUB and Lilo would neither one install in this configuration. They said they didn’t recognize the format of the partition.

Both of these types of RAID are not true hardware RAIDS. Novell even refers to them as fake raids.

You may not have an option.