Dell XPS m1330 - Multimedia


I installed openSUSE 11.1 on my Dell xps m1330. Everything works fine instead of the multimedia buttons on the top right side. I can open CD/DVD drive but I can not control any music/video player.

Does anyone have any experience with these multimedia buttons?


User Ram88 just recently spent some time updating the wiki with information the “Keytouch” software. Maybe it can help you:
Keytouch - openSUSE

One can find keytouch (and also the keytouch editor) packaged by the packman packagers:
PackMan :: Informationen zum Paket keytouch

Unfortunately my Dell xps m1330 is not in the list. Does anyone have experience with it?

I find most DELL hardware the same. They just have a different Chasis but have the same parts under the hood.

Just give it a try and see if it works.


I have m1330, do you have all the latest updates?

What desktop are you using?

I can confirm my 11.1 / KDE4 setup works with the multimedia buttons (I rarely use them, only volume and eject button).

I don’t know if you found a solution but it might be helpful for other users.

I had the same problem on my xps m1530 and the solution, at least for me, was very easy.

  1. make sure that ‘front’ is set as master channel (right click on kmixer icon in the tray)

  2. open kmixer - click settings - configure shortcuts

  3. now, even though the media buttons were already assigned I simply reassigned them with the ‘custom’ option.

  1. click ‘volume down’ under ‘global’ list
  2. click ‘custom’ then ‘none’ and press the media button you want to assign to it
  1. I just had to reconfigure one button and all the others worked without having to reassigne them…it might work the same for you…if not try all.

that’s all, hope it may help.


To use the other keys, you can simply use them as global shortcuts.

For amarok(v2.x):
settings -> configure shortcuts -> search and assign

For kaffeine (These are not global)
settings -> configure shortcuts

For the “media direct key”:
“alt-f2” -> systemsettings -> input actions -> (create a folder if you want) -> (right-click folder) new-> shortcut/command -> fill in the form.

use command ‘amarok’ for amarok , ‘kaffeine’ for kaffeine e.t.c

Tip: Check “alt-f2” -> systemsettings -> keyboard & mouse -> global shortcuts for other uses.

Edit: Volume works out-of the box once kmix is configured (i.e default channel is chosen)