Dell Wireless driver 1520

Hi,

I just installed OpenSUSE 11.2 64 bit on my new Dell Studio 1557 laptop (with i7), which has a Dell 1520 wireless card.

I checked Dell’s site, they only have Windows drivers.

So how can I get appropriate driver for Linux ?

There is that comment regarding wireless on Dell Studio:
“Wireless modules (b43 and wl) did not install automatically. Installed using Yast”.
Is that relevant ?
I tried to search packages with b43 and wl, it showed lots and lots of them, many with Broadcom 43xx series, some - with others.
Can someone help how to resolve it ?
I can only use wireless LAN at my workplace.
New to Linux.

Please help !

TIA,
Oleg.

On 01/08/2010 11:06 PM, olegkon wrote:
>
> Hi,
>
> I just installed OpenSUSE 11.2 64 bit on my new Dell Studio 1557 laptop
> (with i7), which has a Dell 1520 wireless card.
>
> I checked Dell’s site, they only have Windows drivers.
>
> So how can I get appropriate driver for Linux ?
>
> There is that comment regarding wireless on Dell Studio:
> “Wireless modules (b43 and wl) did not install automatically. Installed
> using Yast”.
> Is that relevant ?
> I tried to search packages with b43 and wl, it showed lots and lots of
> them, many with Broadcom 43xx series, some - with others.
> Can someone help how to resolve it ?
> I can only use wireless LAN at my workplace.
> New to Linux.

You need to provide the PCI IDs of your device.

Go to the wireless forum and read the stickies. That will tell you how to report
what is needed. The vendor and model do not tell anything. In fact, some vendors
change the chip that they use without changing the model.