Dell Vostro 360: Native monitor resolution is not recognized and unable to use two monitors

Hi

I got to install OpenSUSE 12.1 in my Dell Vostro 360 with “nomodeset”. However, OpenSUSE is not able to detect monitor resolution (1920 x 1080) and works at 1024x768 os something similar, not the monitor native resolution. Moreover, is not able to detect my two monitors. Dell Vostro is a “all in one” computer, so in the monitor are all hardware (hd, mb, DVD reader, etc), and have a VGA conector to connect an external monitor. With Win 7, I can use the “native” monitor plus an external monitor, but in Linux there is a problem. OpenSUSE does’nt recognize the integrated monitor resolution and even is not able to detect more than that monitor (the external monitor is not detected).

Any idea?

Thank you :wink:

You’ll need to supply details about your graphics card. Use this command

/sbin/lspci -nnk

Just post the output relating to the graphics chipset and driver in use.

The next thing to look at is the contents of /var/log/Xorg.0.log for any messages relating to the detected display device(s). If you want to share that info, upload it to SUSE Paste
and post the link to it here.

I got to install OpenSUSE 12.1 in my Dell Vostro 360 with “nomodeset”.

Does openSUSE boot okay without this parameter?

In this threadI asked about that and was solved (I don’t know how to change the subject mistake about OpenSUSE version).

I posted the lspci output in this link.
Will we need something more?

Thank you

Your graphics chipset:

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09)
	Subsystem: Dell Device [1028:0512]

No driver is reported, and as you are using nomodeset, it is likely that a framebuffer driver is in use. That will provide only limited performance and display resolution. You’re going to have to follow my advice in the last post regarding examining Xorg.0.log…

Hello again

Well, I put “nomedeset” the first time to get a sucessfull instalation, but really I don’tknow if after the installation that parameter is automatically established by OpenSUSE. In this link is the Xorg.log content, but I see no errors or something I could understand as it.

I don’t know how to follow at this point :frowning:

Thank you

The Xorg.0.log confirms that the fbdev (framebuffer) driver is in use, rather than the intel driver. It also shows that 1280x1024 is set (using a built-in mode)

    17.997] (II) FBDEV(0): checking modes against monitor...
    17.997] (--) FBDEV(0): Virtual size is 1280x1024 (pitch 1280)
    17.997] (**) FBDEV(0):  Built-in mode "current": 131.1 MHz, 80.3 kHz, 76.6 Hz
    17.997] (II) FBDEV(0): Modeline "current"x0.0  131.09  1280 1312 1472 1632  1024 1028 1032 1048 -hsync -vsync -csync (80.3 kHz)
    17.997] (==) FBDEV(0): DPI set to (96, 96)
    17.997] (II) Loading sub module "fb"

Your ‘nomodeset’ parameter is almost certainly still present in the relevant boot entry within /boot/grub/menu.lst, so start by looking at that. This is a system file, so you’ll need to take care when editing (with root privileges)

If using KDE, you can edit like this

kdesu kwrite /boot/grub/menu.lst

For Gnome

gnomesu gedit /boot/grub/menu.lst

Now if removing ‘nomodeset’ causes the X-server to fall over, then reboot in ‘failsafe’ mode, and reinstate again.

These guides may be a useful to you

SDB:Configuring graphics cards - openSUSE

http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/advanced-how-faq-read-only/438705-opensuse-graphic-card-practical-theory-guide-users.html#post2165620

Hello

I supress “nomodeset” from grub launcher for OpenSUSE and I rebooted the PC. The Grub menu appeared as it should do, but from here, these is what happened:

  • Image only appeared in the external monitor, nothing in the integrated monitor (as when trying to install without “nomodeset”)
  • While terminating of loading KDE , before appearing the desktop, it takes more than 5 minutes before show the “K” with blue background that appear always when initializing KDE.

After that, was impossible to work fine with KDE. Mouse was moving so slow that was impossible to work. Even to access to the menu button was a headache.

Accesing to console with Ctrl+Shift+F1 a got to copy the Xorg in this situation.

What to do now??

Thank you

  • While terminating of loading KDE , before appearing the desktop, it takes more than 5 minutes before show the “K” with blue background that appear always when initializing KDE.

With the standard openSUSE flavoured KDE desktop, I’m not familiar with the ‘K’ and blue background - I’m assuming this must be unique to your configuration.

Your Xorg.0.log shows that two displays are detected, and EDID read in successfully

    23.841] (II) intel(0): EDID for output eDP1
    23.841] (II) intel(0): Manufacturer: CHR  Model: 608  Serial#: 880
    23.841] (II) intel(0): Year: 2011  Week: 21
    23.841] (II) intel(0): EDID Version: 1.4
.
.
.
    26.767] (II) intel(0): Output eDP1 connected
    26.767] (II) intel(0): Output VGA1 connected

but it then sets the resolution incorrectly

    26.767] (II) intel(0): Using fuzzy aspect match for initial modes
    26.767] (II) intel(0): Output eDP1 using initial mode 1024x768
    26.767] (II) intel(0): Output VGA1 using initial mode 1024x768

Now, it is possible to override this ‘automatic’ configuration, and set the desired resolution manually, but you have more major issues going on with the desktop behaviour/performance. You might want to try disabling the ‘Desktop Effects’ via

System Settings >> Enable desktop effects at startup

However, that won’t fix the resolution issue, and may not be enough to provide a usable desktop either. As this chipset is relatively new, it is likely that the intel graphics driver will continue to improve with respect to its support and performance with this chipset. Therefore, I suggest you may want to try testing with a recent 12.2 milestone release.

Hi Deano_ferrari

I’m sure my explication was terrible, so maybe this screenshot get to make understand what I’m talking when referring to “K with blue background”. In that screenshot, it’s possible to see how that “K” is fading in, after the “Desktop” icon is loaded completely. Well, so from that moment to the moment in wich begin to appear the “KDE” with blue background logo, it takes more , much more than 5 minutes.

Following your suggestions, I will try, in text mode, to deactivate “Desktop effects” and will report here.

If that doesn’t work, will try with 12.2 milestones.

Thank you for all your help.

I’m having a similar problem with two 1920 x 1080 monitors attached to a nVidia GeForce 7300 SE graphics card using the nouveau driver. The monitor attached to the VGA output works, the other one on the DVI connector is blank.

When I ran “xrandr --output DVI-I-1 --right-of VGA-1” it gave me no errors but the DVI screen stayed blank. Even the cursor did not appear on the DVI screen.

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 4096 x 4096
VGA-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.0*+
1600x1200 60.0
1680x1050 60.0
1280x1024 75.0 60.0
1440x900 75.0 59.9
1280x960 60.0
1152x864 75.0
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
DVI-I-1 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 521mm x 293mm
1920x1080 60.0*+
1600x1200 60.0
1680x1050 60.0
1280x1024 75.0 60.0
1440x900 75.0 59.9
1280x960 60.0
1152x864 75.0
1024x768 75.1 70.1 60.0
832x624 74.6
800x600 72.2 75.0 60.3 56.2
640x480 72.8 75.0 66.7 60.0
720x400 70.1
TV-1 disconnected (normal left inverted right x axis y axis)

Configure Desktop -> Display and Monitor -> Size & Orientation did the same.

It works properly with openSUSE 12.1

@shaggyman: You problem is not related to the OP’s, and you should really start a new thread on this, with a descriptive title, so that it gets the specific attention it requires.

OK, since it is a problem with openSUSE 12.2 milestone 3, I submitted bug #762682](https://bugzilla.novell.com/show_bug.cgi?id=762682)

Hello again

Finally, I tried 12.2 milestone build 0318 x64, live CD with KDE. In first place, it booted like OpenSUSE 12.1, but have been some diferences. In first place, it preloaded KDE fluently. Mouse is more responsive, but far away normal. However, it continue showing desktop only on external monitor. Internal monitor show desktop only half of a second randomly, impossible to work on it. On the external monitor, I accessed to monitor configuration and it show perfectly clear that two monitors are recognized, but internal monitor is at 1024x768 by default, despite in this menu appear “1920x1050 auto”. I selected it and applied changes, but the response of internal monitor was the same: Only show desktop from time to time and half of a second.

It’s a pity, but I think there is nothing more to do, despite try to make OpenSUSE work on my Dell Vostro. I didn’t try any other distro, but maybe is a good idea to know about the problem.

I expect any suggestion, of course.

THANK YOU

  1. So, clearly this is a graphics driver issue, and it may be work in progress for the support of this chipset. You should probably file a bug report (especially as 12.2 is in beta), although any fix will have to come from upstream. This is the only way any anomalies will be corrected.

Consider checking /filing here:

Intel Linux Graphics: Bug Report How To

  1. From what I understand (from reading this review), it appears that it is possible to add a discrete graphics card (eg NVIDIA), that can then be used to provide superior performance under Linux (using the proprietary NVIDIA driver). It I was in your position, I’d consider this as an option.