DELL Studio 1535 compiz problem

Hi guyz. I have a brand new dell studio 1535, a really great machine. The first thing I did on it was to install openSUSE 11.1 which I also use as a Desktop and Workstation platform. I had problems with the wireless and with the audio, which I’ve fixed by googling and searching this forum. I have two problems remaining, the first one is running compiz-fusion on my KDE 4.1, and the other is my bluetooth, which seems to be on but doesn’t respond anyhow. However, I think that I could live without bluetooth for now, so I would like to ask for help from you guyz about the compiz. My video is ATI Mobility Radeon 3450 running on radeonhd driver very nicely, but I can’t start either compiz or emerald anyhow. Here are some outputs and configs that could orientate you:

ivan@linux-4fk1:~> compiz --replace
compiz (core) - Fatal: glXCreateContext failed
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

ivan@linux-4fk1:~> glxinfo
name of display: :0.0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  14
  Current serial number in output stream:  14
ivan@linux-4fk1:~> sudo glxinfo
root's password:
Error: unable to open display (null)
ivan@linux-4fk1:~> ./compiz-check

Gathering information about your system...

 Distribution:          openSUSE 11.1 (i586)
 Desktop environment:   KDE4
 Graphics chip:         ATI Technologies Inc Mobility Radeon HD 3400 Series
 Driver in use:         radeonhd
 Rendering method:      AIGLX

Checking if it's possible to run Compiz on your system...

 Checking for texture_from_pixmap...               [FAIL]
 Checking for non power of two support...          [FAIL]
 Checking for composite extension...                OK ]
 Checking for FBConfig...                          [FAIL]
 Checking for hardware/setup problems...           [SKIP]

At least one check had to be skipped:
 Error: Unable to detect maximum 3D texture size

ivan@linux-4fk1:~> cat /etc/X11/xorg.conf

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"        

Section "Module"
  Load         "glx"
  Load         "dbe"
  Load         "extmod"
  Load         "dri"   
  Load         "freetype"

Section "Monitor"
  DisplaySize  331 207
  HorizSync    30-62  
  Identifier   "Monitor[0]"
  ModelName    "MT102 154AT LCD MONITOR"
  Option       "DPMS"                   
  Option       "PreferredMode" "1280x800"
  VendorName   "SEC"                     
  VertRefresh  43-60                     
  UseModes     "Modes[0]"                

Section "Modes"
  Identifier   "Modes[0]"

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15     
    Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                                    
    Virtual    3840 1200                                                                
  SubSection "Display"                                                                   
    Depth      16                                                                        
    Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                                    
    Virtual    3840 1200                                                                 
  SubSection "Display"                                                                   
    Depth      24                                                                        
    Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                                    
    Virtual    3840 1200                                                                 
  SubSection "Display"                                                                   
    Depth      8                                                                         
    Modes      "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"                                                                    
    Virtual    3840 1200                                                                 
  Device       "Device[0]"                                                               
  Identifier   "Screen[0]"                                                               
  Monitor      "Monitor[0]"                                                              

Section "Device"
  BoardName    "Mobility Radeon HD 3400 Series (M82)"
  Driver       "radeonhd"                            
  Identifier   "Device[0]"                           
  Option       "SaXDualHead"                         
  Option       "AllowGLXWithComposite" "true"        
  Option       "monitor-PANEL" "Monitor[0]"          
  Option       "SaXDualMonitorVendor" "--> VESA"     
  Option       "SaXDualOrientation" "LeftOf"         
  Option       "SaXDualResolution" "1024x768"
  Option       "SaXDualMode" "Clone"
  Option       "SaXDualHSync" "31-50"
  Option       "SaXDualMonitorModel" "1024X768@60HZ"
  Option       "SaXDualVSync" "50-60"
  Option       "SaXExternal" "Identifier&EXT+DisplaySize&331 207+VendorName&--> VESA+PreferredMode&1024x768+HorizSync&31-50+ModelName&1024X768@60HZ+VertRefresh&50-60"
  Screen       0
  VendorName   "ATI"

Section "Monitor"
  DisplaySize  331 207
  HorizSync    31-50
  Identifier   "EXT"
  ModelName    "1024X768@60HZ"
  Option       "PreferredMode" "1024x768"
  VendorName   "--> VESA"
  VertRefresh  50-60

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  InputDevice  "Mouse[3]" "SendCoreEvents"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"

Section "DRI"
    Group      "video"
    Mode       0660

Section "Extensions"
  Option       "Composite" "Enable"

The last section was added by me, everything else is default. I’ve cutted the begining comments and files and mouse section due to forum restrictions.

ivan@linux-4fk1:~> fusion-icon
 * Detected Session: kde
 * Searching for installed applications...
 * No GLX_EXT_texture_from_pixmap with direct rendering context
 ... nor with indirect rendering, this isn't going to work!
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 57, in <module>
    from FusionIcon.interface import choose_interface
  File "/usr/lib/python2.6/site-packages/FusionIcon/", line 23, in <module>
    import start
  File "/usr/lib/python2.6/site-packages/FusionIcon/", line 64, in <module>
  File "/usr/lib/python2.6/site-packages/FusionIcon/", line 140, in set
    if not self.Xgl and self.glx_vendor == 'NVIDIA Corporation':
AttributeError: Environment instance has no attribute 'glx_vendor'

So, this is all I have. :slight_smile:

Any ideas? :frowning:

This is a complete monologue, but however, I’ve managed to make some progress, by removing from yast ati-fglrxG01-kmp-pae and x11-video-fglrxG01 packages. Now compiz doesn’t throw errors but I get the white screen of death on compiz --replace. Any suggestions?:X