Dell studio 15 sound problems

I just bought a studio 15. All well and good until yesterday when I plugged in my usual external speakers to watch a movie. When I unplugged them sound no longer came through the laptop itself. I plugged the speakers back in and it came through the speakers fine. Then later it stopped coming through the speakers too. Now there is no sound from anywhere. I have checked the levels - nothing is on mute. I can see the sound level is coming into the mixer but nothing is coming out anywhere. I have tried both the jack sockets and headphones don’t work either. This applies whatever program/site I am using - whether its media player or you tube etc…

When I look at payback devices I am given three options:

  1. Digital Output Device (HDMI)
  2. Speakers/Headphones IDT High Definition Audio CODEC
  3. Independent RTC Headphones IDT High Definition Audio CODEC

I have it set on the first one at the moment but have tried the others to no avail.

Has anyone else had this problem or can anyone think of something I can try?



I also have a dell studio 15.I am also facinf the same kind of problem.atleast in mine when i resinstall it works did you find any soln.pls reply

You may wish to take a look at this laptop review by a Dell Studio 17 user. They noted a kernel update helped significantly in solve their problems with the IDT 92HD73C1X5 hardware audio codec.

Hence it is possible openSUSE-11.1 (which comes with 2.6.27 kernel) may have the pre-requisite kernel update.

My Dell Studio 15 laptop arrived earlier today. I booted to an openSUSE-11.1 beta5 live CD (with KDE4) and tested audio. I am not used to KDE4 so I was on unfamiliar territory.

Initially no audio with the speaker test I normally apply:speaker-test -Dplug:front -c2 -l5 -twavThe speaker test kept freezing despite my trying various mixer settings. No sound.

I then ran alsaconf. Tested the audio (with the above speaker test). Again, the test kept freezing despite my trying various mixer settings. No sound.

I then applied the line “options snd-hda-intel model=dell-m6” to the end of the /etc/modprobe.d/sound file. No sound, and again the test kept freezing.

I then went into YaST > Hardware > Sound and selected the advanced option to test the sound. I applied through YaST the “dell-m6” in the gui area to specify the model. I tested the sound under yast. There was sound !!

I then closed yast and tried the above sound test, … no sound as a regular user nor as root. Bizzare !! Then it occured to me, … maybe the Dell doesn’t like my sound test. Duuuuhhhhhh :slight_smile:

So I tried this as a sound test:speaker-test -c2 -l5 -twavsound worked as a regular user with the modifed test !!!

So now I am thinking of users who reported this problem, asked me for help, and I could not help them, until I encountered this myself. Sigh. Do we just get slower and dumber with age? :shame:

So I plugged in a headset in one of the two headset output jacks. Speaker sound was muted (good) BUT there was no headset sound! (bad).

So I plugged the headset in the second headset output jack. Speaker sound was not muted (bad) but headset sound worked ! (good). But headset volume was not independant and was tied into the speaker volume (bad).

Which means both headsets are unusable.

So I looked at the /cat/etc/modprobe.d/sound file and noted the line I prevous put as an option “options snd-hda-intel model=dell-m6” was put as the first line in the file by YaST. So I changed it to the last line, restarted alsa, and it made no difference.

Hmmm… this could be a KDE4 glitch, but I don’t think so. I think this is an alsa glitch. I may have to write a bug report on this. I noted my tsalsa was this:
tsalsa.txt - (beta)

and my installed apps in openSUSE-11.1 beta5:

linux@linux:~> rpm -qa | grep alsa
linux@linux:~> rpm -q libasound2

linux@linux:~> rpm -qa | grep pulse

linux@linux:~> uname -a
Linux linux #1 SMP 2008-11-11 15:15:33 +0100 i686 i686 i386 GNU/Linux  

linux@linux:~> cat /etc/modprobe.d/sound
options snd slots=snd-hda-intel
# u1Nb.ifylLOqC327:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel
options snd-hda-intel model=dell-m6 

Anyway, this is a live CD install. We will need to see how a real 11.1 beta5 install works.

I note a fair number of Ubuntu users are reporting the same problem with their headsets on the Dell Studio 15:
[ubuntu] Headphones not working in Intrepid - Page 2 - Ubuntu Forums](

Another Ubuntu user expresses the view this headphone problem will be fixed in alsa-1.0.19, but references no bug report.
Ubuntu Forums - View Single Post - [ubuntu] Dell Studio 15 No Sound

It looks like I may have to dive into the alsa bug reporting tool to see if this has been reported.

I discovered this bug report by a mandriva user:

I don’t agree with the assessment that it is minor.

I wrote a bug report on openSUSE-11.1 beta5 here:

However this appears to be an upstream problem (ie a problem with alsa) so it is quite possible the openSUSE beta5 bug report will be quickly closed, referencing the upstream bug report.

One of the alsa dev’s has been helping, and the had me try different things to see if we can get the headphones functioning. The URL (bug report) I quote above documents the efforts made to date.

Thus far there is a partial work around, where with the alsa-driver-snapshot alsa custom install, and with the correct combination of kmix selections, one can mute the speaker sound and get the frontmost of the side headphone jacks to work. So while it is still not functioning completely properly (according to the mixer) some progress has been made.

Takashi Iwai has fixed the muting bug with the Dell Studio 15 headphone jacks. Hopefully this will appear in an upstream release of alsa (I do not know if it will make the openSUSE 11.1 gold release).

I have not tested the mic yet.

I tested the external mic-in jack, with this alsa-driver-snapshot (noted in the now resolved bug report) and the mic-in jack works.

I need to setup my web cam before I test the remaining two integrated mics.

Reference the mic setting, below is a screen capture of my kmix setting in openSUSE-11.1 RC1 on KDE-3.5.10. Those settings were essential for the mic. ie Mic Mixer, Capture, Amp and Digital Input Source all controlled the mic capture level. I had to find a good balance on them in order to ensure I did not get too much noise nor distortion in the mic recording. The headphone switch/levels (which is muted on this image) have absolutely no effect on my sound. I don’t think the driver has that modelled perfectly yet.](
I setup the headphone and mic and webcam (which is functioning under the uvc driver) under aMSN program and it appears to be working, although I have not tested it yet in a conversation with anyone. This is my first webcam that uses a uvc driver, and I confess thus far, I prefer webcams that have gspca driver support.

I finally got around to testing the HDMI output on the Dell Studio 15 laptop. I could not do this earlier, because our old digital TV did not have an HDMI input. But today we purchased a new TV with an HDMI input, so we decided to give it a try.

Our new TV connects to our TV receiver via HDMI, and it works great for both audio and video. We connected the TV to the Dell Studio 15 and booted to Windows Vista, and the HDMI on the Dell Studio 15 laptop works for both audio and video under Vista.

We then rebooted to openSUSE-11.1 (KDE-3.5.10) and tested the HDMI. It works GREAT for video, but the audio out does not work for HDMI for openSUSE-11.1 and alsa-1.0.18a. We played around with the mixer, but the mixer settings for HDMI are primitive under 11.1/KDE-3.5.10’s kmix (on/off and a volume control). We then rebooted to Vista, and confirmed the audio still works.

So its great that the HDMI works under Linux, but it appears more work is needed to get the HDMI functioning. … I may write a bug report on this when I come back from vacation (I’m going away for a few weeks fairly soon).

I don’t suppose anyone else has HDMI (both audio and video) working under a Dell Studio 15 or Dell Studio 17 ?