Dell Optiplex 745 no keyboard, DVD, X

I’ve been trying to install SuSE 11.0 on my Dell Optiplex 745.

If I try to install the x86_64 DVD, the install gets a certain distance and then loses contact with the DVD. It then drops back to a character screen with an “Insert CD 1” dialog box. After this the DVD can’t be found, although it’s listed in the System Information. Trying to do a media check produces similar results.

If I try to boot up the LiveCD (both x86_64 or i386 versions) it seems to boot up alright, but then X doesn’t start and I’m presented with a “(none) #~” prompt. At this point, the keyboard doesn’t work, even though it was working at the boot screen and I can see it being detected during the boot process.

In all cases, I’ve tried running with acpi=off and full failsafe mode, but that doesn’t seem to do any good.

I don’t think that this is a hardware problem; the system is currently running Fedora 8 without any problems.

I’ve now run out of ideas. Any suggestions most welcome.


It does sound like a hardware issue to me.
I have experienced similar issues in the past, though not with suse 11.
Having 2 dvd drives one sata and one pata/ide, I found different results with each and a way thru. In fact F7 had a keyboard issue with me, tried a different keyboard (my normal is a usb one), used text mode install I think.
Suse 10.2 was a problem for I seem to remember, but I just kept working at it, again text mode.

I have tried to run the Opensuse 11 x86 KDE Live CD on a Dell Optiplex 745 and get the same issue. You see the loading screen with progress bar, the kernel messages get as far as ‘Creating X Config’ then the screen looks like it goes blank, but it actually has a tiny 'None:/" prompt in the top left-hand corner and the keyboard does not work.

I have tried booting from the Live and Live-Failsafe Grub options.

Any ideas for startup options to try?