Dell M3800: HD4600 + Nvidia Quadro K1100M

Hi everyone!

Two days ago I installed OpenSUSE 13.1 (Gnome 3.10) on my new Dell M3800 laptop, which is a new model with Intel Core i7-4702HQ with integrated Intel Graphics (HD4600) and a Nvidia Quadro K1100M GPU. I’ve had some issues getting any of these to play along nicely, and hoping for some help that steers me into the right direction. I want to point out I’m a newbie, so I might have overlooked the obvious here, but let me start by explain what the problem is.

On installation, the Intel GPU works out of the box. Well sort of. I do get an image, and all looks well, but everything is somewhat sluggish and laggy. Scrolling in Firefox/Chrome gives you a feeling you’re running on some really old hardware, and all Gnome effects feel the same. Compared to my Samsung Ultrabook, which runs Xubuntu on MUCH less powerfull hardware, it’s a clear win for the Samsung.

I’ve been trying to find some information regarding the HD4600, and the only thing I’ve found is a recommendation to try to upgrade the Kernel which I’ve done (3.13) but the results are basically the same. I also tried getting the Nvidia GPU working (Quadro K1100M), but it seems it’s not yet support by Nvidia except for a beta which didn’t work for me. I’m fine with waiting until a proper driver exists for the Nvidia, but it would be nice to have at least the HD4600 running smoothly. :slight_smile: I also need to point out the M3800 has a very high def screen, 3200x1800, so there is a lot of pixels for it to move around. I would ever assume it has enough power to run Gnome 3.10?

Any help is much appreciated, and thank you in advance!


First: you need bumblebee to get the NVIDIA working anyway, if the driver supports it. Here’s a good howto
But … the Intel should work anyway. It might even be your attempts to get the NVIDIA working have an effect on the intel.

All in all I suspect there’s no 3D support.

Please show output of

glxinfo | grep direct

This is a fresh install, I’ve tried some distros the last couple of days to see how they handled the hardware + HiDPI display and decided on OpenSUSE. Thanks for the link, great stuff! Will install bumblebee, guess it’s needed anyway to keep the Nvidia GPU in check.

Here is the output:

patrick@linux-chfh:~> glxinfo |grep direct
direct rendering: Yes

Did a fresh install just in case, installed bumblebee which seems to be working in regard of shutting down the Nidia GPU (power consumption went down from 28 W to around 17 W). Still having issues with the Intel gpu performance though. When running the browser (both Firefox and Chrome) in windowed mode that covers around 2/3 scrolling actually runs smooth, anything above that lags. All GUI elements seem sluggish also, so something is not right.

Any ideas?

The output of “glxinfo |grep direct” by itself is insufficient to diagnosis a 3d problem … it will still say yes in the case of cpu/software driven dri.

In any regard, its still not clear what the actual slow down may be a result of (though a 3d issue is at the top of the list). What output do you have for:

/sbin/lspci -nnk | grep VGA -A2
glxinfo | grep -e version -e " render"

And what does the content of your xorg log say? (you could post it to susepaste and then provide us a link)

Thanks for helping, much appreciated! Here is the output and link to the Xorg log.

linux-81mm:/var/log # glxinfo |grep -e version -e " render"
direct rendering: Yes
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.3
OpenGL core profile shading language version string: 1.40
OpenGL version string: 3.0 Mesa 9.2.3
OpenGL shading language version string: 1.30

linux-81mm:/var/log # /sbin/lspci -nnk | grep VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
    Subsystem: Dell Device [1028:060d]
    Kernel driver in use: i915

Link to Xorg.0.log:

On casual glance, all the output looks good/as expected. So, my quick suggestions and thoughts are:

  • try UXA acceleration, as opposed to the now default SNA … this is 2D accel … looking back, you mentioned scrolling problems in the browser – that is the domain of 2D accel.

  • how much mem do you have allocated to the iGPU … you have a really large screen and this is impactful

  • try disabling optimus in bios/uefi and running with only the iGPU active … also try that with the Bumbles uninstalled

Sorry for the late reply, I’m currently relocating to a different part of the world so had to put this aside for a while. I’ve tried switching to UXA, made no visible difference. Unfortunately there are no Optimus settings in BIOS, same goes for GPU memory allocation (which I’m guessing is also set in BIOS?).

I’ve noticed a few more things, not sure they are related by thought I’d bring them up anyway:

  1. In firefox/chrome, I can see some graphical corruption - small black cluster of blocks that appear/disappear during scrolling. Not always, but now and then.
  2. Grub startup screen is extremely slow. It gets drawn bottom up, takes around 1.5 seconds.