Dell Latitude E6440 - Sound burst when initiating KDE Plasma 5

Hi all, I’m experiencing some kind of sound burst when initiating Plasma 5 desktop, it appears to be happening when the initial “greeting” sound should be played, this is just an speculation.

  • Logging into IceWM does not trigger the issue.
  • The audio works fine on Plasma 5.
  • I’ve tried disabling Plasma 5 sound notifications with no results.

Also, no error related to this on dmesg.
Any Idea?

This happens when PulseAudio starts, on some systems at least.
I see that here on my 13.2 system too, even in KDE4, even with no “greeting sound” configured.

Unfortunately I don’t know a workaround, except turning off PulseAudio completely (in YaST->Hardware->Sound->Other->PulseAudio Configuration) and using plain ALSA.
Or turn the volume real low.

Aparrently yast messes up with my sound configuration when triyng to configure it… awesome.

So I turned off PulseAudio, rebooted (I don’t know which service I have to restart) and I 've got no sound, alsa package is instaled.
Is there any configuration I’m missing?

Does YaST recognize your sound card?
Did you configure it in YaST? (although that shouldn’t be necessary normally)

As you say YaST apparently messes up your sound configuration (what exactly do you mean with that?), try to delete /etc/modprobe.d/50-sound.conf. That’s where YaST saves the config.

Also try on a fresh user account, and check that the volume is not 0.

Yes, YaST recognized mi sound card wich is Intel, but it shows me two devices:

8 Series/C220 Series Chipset High Definition Audio Controller
Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller

I guess this would be one for my speakers/mic and the other for the HDMI port.

I said that YaST broke my sound config because:
1 - I got no more sound
2 - If I go to the KDE configuration -> Multimedia -> Audio and Video, It shows me a Dummy device instead the Built-in device (Rebooting fixes this)

This happens when I choose any of the initial sound setups in YaST (Quick, Normal, Advanced) also selecting the device and clicking “Reset All” has the same effect.

So, summarizing:
Changing sound settings in YaST -> no sound (reboot fixes this)
Disabling PulseAudio in YaST + reboot -> no sound
Enabling back PulseAudio + reboot -> sound is back

Yes, likely.
So check that the correct one is set as default. Try to set the other, maybe this fixes the sound?

The only other option I see is to file a bug report against PulseAudio. (same username/password as here)
I do remember one not too long ago, where this was fixed for that particular sound card IIRC.