Dell Latitude D531 touchpad not working

I have a Dell Latitude D531 that I’ve been playing around with OpenSUSE 12.3 on, and everything works great on it, except for the touchpad. I get no reaction from it, and I can’t figure it out.

Hardware Information in the Yast Control Center detects the touchpad as “AlpsPS/2 ALPS DualPoint Touchpad” however, I can’t figure out how to get it to work.


If you open up YaST / Software / Software Management and search for the package “xf86-input-synaptics” see if it is installed. The application is configured by the file /etc/X11/xorg.conf.d/50-synaptics.conf which must edited by root. m I have a bash script you can use for this purpose you can find here:

SYSEdit - System File Editor - Version 1.50 - Blogs - openSUSE Forums

I did not see where you said what desktop you are using. KDE is selected by default and your selection could make a difference with any such problem. I would like to suggest as another thing to try is a newer kernel, where much hardware support begins. Have a look at my blog on the subject here:

openSUSE and Installing New Linux Kernel Versions - Blogs - openSUSE Forums

Thank You,

Sorry, I should have mentioned that I am using KDE.

Yes, xf86-input-synaptics is installed.

While doing some more searching regarding this problem, I came across a previous thread ( that dealt with a similar setup, and I tried some of the commands listed there. Typing “xinput enable 14” fixed it, although I haven’t tried restarting the laptop to see if it stays enabled yet.

I’ll probably try installing a newer kernel this evening when I have access to a wired Internet connection. I tried it once before, forgetting about the wireless driver, and disabled the wireless without even thinking about it.

Thank you for the help.


Yes, tell us which desktop environment you’re using. Maybe you just need to enable the deivce.

For Gnome, you may want to check the ‘Mouse and Touchpad’ configuration.

This approach might work for you too:

Slackware Linux Blog by İsmail: Disable or Enable Touchpad by synclient

Well, after a restart, the touchpad stopped working as soon as I logged into KDE. Same problem as in the thread I found. I’ll use the same fix from there.

Thanks for the help, everybody.


So it sounds like you need to run the command: “xinput enable 14” on each startup. Do you run this as root or a normal user? For root, you can look at my article on getting the after.local bash script working in openSUSE 12.3 where this command could then be placed.

systemd and using the after.local script in openSUSE 12.1 - Blogs - openSUSE Forums

Else, if a normal user, one could write a bash script using my New Script File bash script which places it in $HOME/bin. The script is here:

N.S.F. - New Script File, Bash Script File Header Creator - Version 2.6 - Blogs - openSUSE Forums

Then you go to Menu / Configure Desktop / System Administration / Startup and Shutdown / Autostart (on Left) / Add Script (On Right) / browse to your bash script with this one command and select OK I think and it will run on each startup. While there, I normally suggest you also select Session Management (On Left) / under On Login select the bullet for “Start with an Empty Session”. If you don’t select this, some stuff can be there more than once though a one shot script should not have that effect.

Thank You,