Dell Latitude 7490 Has Too Many Missing Drivers

I don’t know why I’m having difficulties with hardware support on my Latitude 7490. It has a touchscreen which doesn’t seem to work or be detected on TW. It’s fingerprint driver is out of question. I wonder if there are others who have used and had such issues and how they solved them. It makes most special features of my hardware use rather useless.

Check this:

Is the hardware in question supported by open source or proprietary Linux drivers?

If the drivers are open source, then they could conceivably be included in the distribution and a request would just need to be made.

If they are proprietary, then things become a bit stickier, as the openSUSE Project typically doesn’t include binary “blobs” in the main distribution (the “open” part of “openSUSE” is based on the idea that all the code in the base distribution is freely available, and not released as binary-only blobs). There may be additional packages needed from other repos like Packman, or you may need to do other things in order to get it working, if there is Linux support at all.

The i7-8650U was released Q3’17, so that laptop should include nothing that is unsupported by any current or recent or not-all-that-recent Linux distro.

If you read the thread I provided, you would read this by “larryr”:

I wonder if your TW USB has a problem.
I have installed over 50 7490’s - some had the GPU issue.

Well, I wouldn’t have expected a touch screen support to be related to the CPU, and the OP specifically mentioned that…

As I noted to mrmazda, there’s no mention of touch screen support in that thread, and that’s what I mostly latched on, but the OP also mentioned the fingerprint reader, and larryr also made no mention of that particular hardware device.

But perhaps I missed something about both of those items that the OP specifically called out in that thread.

That would have been the case if Dell provided drivers for Linux. They claim Ubuntu support but when I researched even Ubuntu has the same problems with the fingerprint.
I never actually found anything about the touchscreen though. It was like it was a me specific problem or people just didn’t care.

I actually had a very smooth installation though.

They actually claim to support Ubuntu. And yet there’s a thread on askubuntu complaining about it. I found one libfprint extra driver though some people claimed it worked, that thread was filled with users of similar latitudes.

I just wanted to find out how any other openSUSE user managed to deal with these problems if they had a similar device.