Dell laptop and external monitor resolution problem.

Hi all. I have Dell laptop with GeForce 8600M GT graphic card. And I have Acer AL1916W monitor connected to the notebook. I want to have the same resolution on both displays - 1280x800 and cloned picture. I switched to openSUSE 11.2 from Debian about a month ago. And in Debian resolutions were the same, I used nvidia driver from nvidia site. In openSUSE first I tried to set resolution from Configure desktop menu, but didn’t find any of this ratio resolutions except 1440x900. I installed nvidia driver from recommended repository, but in nvidia-settings I still don’t see anything but 1440x900 and some wrong resolutions with ratio 4/3. So now, my laptop display shows me only a left upper corner of desktop, because it’s resolution is 1280x800 and Acer’s resolution is 1440x900. When I boot with external monitor disconnected, everything is ok on laptop. And it wouldn’t be a problem for me, but the letters are so small with 1440x900. I read some threads about related problem, but still couldn’t find a solution.
My xorg.conf, created by nvidia-settings:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder75)  Tue Dec  8 21:07:34 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"    
    Option         "Xinerama" "0"            

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0" 
    Driver         "mouse"  
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"  

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"      

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer AL1916W"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600M GT"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "CRT: 1440x900 +0+0, DFP: 1280x800_63 +0+0"
    SubSection     "Display"
        Depth       24

Have you tried using “xrandr” at all ?

Please see this thread:
Laptop external (cloned) projector support in KDE - openSUSE Forums

I wrote the above for ATI and Intel, but its possible something similar works for nVidia ?

Thanks for reply. I’ll try it in the evening.

Here’s the output of xrandr -q:

happy@osshp:~$ xrandr -q
Screen 0: minimum 1440 x 900, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
   1440x900       50.0*

and no windows opened. Only console output.

You need to try “xrandr -q” with the external monitor connected.

oldcpu, here’s what I did after your post.
I disconnected the external monitor and restarted X (Alt+Ctrl+Backspace twice). Here’s the output of xrandr -q:

Screen 0: minimum 320 x 175, current 1280 x 800, maximum 1280 x 800
default connected 1280x800+0+0 0mm x 0mm
   1280x800       50.0*
   1024x768       51.0     52.0     53.0
   832x624        54.0
   800x600        55.0     56.0     57.0     58.0     59.0
   720x400        60.0
   700x525        61.0
   640x512        62.0     63.0
   640x480        64.0     65.0     66.0     67.0     68.0     69.0
   640x400        70.0
   640x350        71.0
   576x432        72.0
   512x384        73.0     74.0     75.0     76.0     77.0
   416x312        78.0
   400x300        79.0     80.0     81.0     82.0     83.0
   360x200        84.0
   320x240        85.0     86.0     87.0     88.0
   320x200        89.0
   320x175        90.0

This are the modes of laptops own display, I guess.
Than I connected Acer monitor (it was dark, didn’t show me desktop) and used xrandr -q, same output. I restarted X and repeated this command. I got what I wrote in previous post:

Screen 0: minimum 1440 x 900, current 1440 x 900, maximum 1440 x 900
default connected 1440x900+0+0 0mm x 0mm
   1440x900       50.0*

It can’t be so that external monitor doesn’t have any other modes!! It has, it worked in Debian at 1280x800 and in Windows too.

It looks to me that the nvidia driver does not properly support xrandr. Hence my suggestion to try xrandr is unfortunately no good. My apologies for wasting your time on this wild goose chase.

Any help is appreciated, so thanks anyway :wink: