Dell Inspiron 1546 laptop / Windows 7 / openSUSE 11.2

If it won’t even boot to run level 3 then I can not help.

Are you certain everything is configured properly in your BIOS ?

Do you have any USB devices connected that you can remove prior to trying to boot?

I’ve had limited success with the latest 11.3 milestone - yast starts up to tell me that the GUI could not be configured and I end up with run level 3.

At this point I tried (with root permissions) the ‘sax2’ command but get a error message stating that the command is unrecognised… is there a different way to query the graphics card drivers in 11.3 or am I just doing something wrong?

Confirm the command is there in /usr/sbin. With root permissions type:

whereis sax2

I assume you ran sax2 with root permisisons?

Man I have the same problem. (Same dell)

I succeeded to install ubuntu 9.10 by selecting the installation line and then pressing F4 - select Safe graphic mode then press F6-“Additional options” folowed by Esc key , then write in the end of a line “nomodeset” without a quotes.

It started the gui and proceeded with the installation. However after installing I cannot change graphics , need proper driver I think , also cannot use internal wireless.

Here is the link with step by step instructions.
The same command “nomodeset” did not helped in opensuse or I just dont know whre to write it. I am absolutely new to a Linux.

I have the same laptop and the same problem.
I tried to install ubuntu 9.10 at first but failed. Only the 10.04 (some beta release) worked but after a while the system freezes. If i run several programs it lags a lot. I don’t know if i’ll get any results if i will install the final 10.04 ubuntu release or not.
With opensuse i get the same problem like nigeldourley.

Is there any way that i can make opensuse work?
Is there any hope that linux will work on my laptop?
If there is, how much time i have to wait so compatible drivers will be available for me?

The difficulty here is this is fairly new hardware, and Linux support is only “just” being introduced. I note the Dell Inspiron 1546 can have either a Radeon HD4330 or an Intel HD Graphics. Which does yours have.

Searching on the Intel Graphics I note this on the thinkwiki site, which is a good site for technical information:
Intel HD Graphics - ThinkWiki
where it notes:

A very recent Linux distribution with kernel 2.6.33 and Intel Xorg driver 2.10 or newer is recommended.

Note openSUSE-11.2 comes with the 2.6.31 kernel and 2.9 of the Intel Xorg driver.

Note openSUSE-11.3 will come with the 2.6.34 kernel and 2.11 of the Intel Xorg driver.

Hence you may be better off testing with openSUSE-11.3 Milestone-6 liveCD and if that boots, then possibly install it, or simply BETTER YET wait a few months until 11.3 is released.

Note, it would really help in future if you provided information on your laptop, such as the graphics. I almost did NOT reply to this thread again, because the users simply do not provide the specs and their hardware, which makes it a LOT more difficult for those trying to help.

Sorry for not posting my specs. The second mistake i made is that i do not have the same laptop rotfl!
I have 1564 and nigeldourley has 1546. My bad!

Here is what cpu-z says about my cpu:
At the graphics tab there is a memory section “size” and it says 1242 MBytes but there is no other info.

Here are some other specs(this information is from the shop where I bought my laptop) :

Procesor:Intel Core i3 
Cache (KB):3072

FSB (MHz):1066


Ram memory installed:3072
Ram modules :1 x 2048 + 1 x 1024
Maximum ram memory:4096

Display & VideoChipset :Intel HD Graphics
Diagonal LCD 15.6
Display type:HD
Optimal resolutin:1366 x 768

Video memory type:Shared

10/100 LAN

Wireless 1397 (802.11 b/g)


3 x USB 2.0
1 x VGA
1 x HDMI
1 x RJ45
1 x Headphones-out
1 x Mic-in

Audio:HD Audio

Hope this helps.

What is important here is: Intel HD Graphics

That is so general, its irritating when trying to give specific help. But best I can determine the same comment is true:

A very recent Linux distribution with kernel 2.6.33 and Intel Xorg driver 2.10 or newer is recommended.
One needs openSUSE-11.3 for that.

So, download the openSUSE-11.3 Milestone6 liveCD iso file. Do the md5sum check. Burn it to a high quality (but inexpensive) +R or -R (not to an RW) and then boot to that liveCD. Do NOT install because openSUSE-11.3 has NOT yet been released.

Does the liveCD boot ok ?

You can find 11.3 Milestone6 liveCDs here: - development CDs

Must be a Dell thing. I have a Dell Studio 1747. I have installed 11.2 64 and it goes through the boot process to end with a blank screen and I have to do a hard shut down. I’ve tried safe mode nada. tired of trying for now; off to bed. Maybe try the 11.3.

This could be an issue with the video card.

I’m sure it is, but Ubuntu 10.04 is OK with it; the previous Ubuntu wasn’t. Puppy has no problem at all.

So what video card?? There are known problems with ATI and some Intel chip sets.

Some Dell Studio 1747’s have a Radeon HD4650.

If that is the case for your laptop, its quite possible only the fbdev (and possibly Vesa) driver support that hardware in openSUSE-11.2 (and the radeon/radeonhd may not yet support it in 11.2), and one needs to then download and install the proprietary ATI Catalyst-10.4 driver which DOES support the ATI HD4650.

Here is some theory on openSUSE graphic drivers: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

ATI Radeon HD 4650 1024MB

OK, I some experience dealing with DELL laptops. The one thing though when some is purchasing a laptop they want for LINUX is try to avoid Intel video cards. You usually just get too much stress from dealing with them. LINUX has very good support for NVIDIA thanks to NVIDIA themselves, and less so for ATI. but Intel support kinda sucks for certain massed produced cards. So if you want graphics in linux go NVIDIA for less stress. A discrete card would be better in all cases than with Intel onboard. These new onboard cards are only now have support (somewhat) and I’ve found, in the case with the Intel 8245GL cards, I guess real support was not added in for it.

Well, anyway, that’s just my two cents.

I’ve also the exact same problem with Dell 1564. Maybe its because of the new type of screen (720p HD WLED) instead of a normal LCD?

Which graphic hardware do you have? My understanding is the Dell Inspiron 1564 can have either Intel or Radeon and that makes a BIG DIFFERENCE!

The Radeon graphics should work in openSUSE-11.2 with the proprietary ATI graphic driver. Did you try that? If so, HOW did you try it? How familiar are you with installing the proprietary ATI driver? Unfortunately new users to openSUSE often struggle here. Apologies, but I can not tell from your post.

The Intel graphics may require openSUSE-11.3.

And are we even talking of openSUSE-11.2 ? Again, apologies, its not clear from your post.

I’ve got Intel graphics.

I tried installing openSuSE 11.3 Milestone 7. It works ok, but there are a not of bugs in the Gnome environment (buttons disappear, windows scaling problems … that kind of thing). Then I tried Lucid Ubuntu and its working 100% fine since then :slight_smile:

There is guidance for raising bug reports here: Submitting Bug Reports - openSUSE

… in the case of gnome bugs: GNOME/Submitting Bugs - openSUSE

Glad to read its working. I believe Lucid has the 2.6.32 kernel, which is newer than the 2.6.31 on openSUSE-11.2. Plus Ubuntu are notorious for being slow for their bug fixes making it upstream, compared to Novell/SuSE-GmbH and compared to Red Hat/Fedora both of who are relatively VERY quick compared to Ubuntu for patches being sent/accepted upstream. Hence if the Ubuntu packagers have applied a fix, it may be a while before other distributions see an upstream fix. As a Linux fan, thats one of the things I do not like about Ubuntu. But I understand the need for you to go with something that works.