Dell Inspiron 1546 laptop / Windows 7 / openSUSE 11.2

Hi all, typical newbie problem here which I’m sure someone will have an answer for!?

I’ve just bought a Dell Inspiron 1564 (Intel Core i3-330M) with Windows 7 and the first thing I want to do is get rid of Windows and replace it with Linux - problem is that from the boot screen no matter which option I select (live cd or installation) the cd immediately stops spinning and the installer leaves me with a blank screen and not much else!

If anyone could help I really would appreciate it!

Did you check the download and the burnt media? This looks like the download or CD/DVD is not OK.

You could be right, I tried Ubuntu and got the same response

Which openSUSE 11.2 install medium did you use?

I downloaded the 64-bit Gnome LiveCD

OK, I burnt a new CD and the following happens:

Boot screen appears OK, I select ‘Install’, openSUSE splash screen and progress bar appear, when the progress bar reached the end the screen goes blank and nothing further happens.

I’ve tried disabling the ACPI and the safe install but the same thing happens.

Can anyone see where I’m going wrong?

nigeldourley wrote:
> Can anyone see where I’m going wrong?

did you md5sum check the iso before you burned it, and then did you do
this first, before actual install?

and, did you follow the other advice/guidance in


Yes, checked the installation media, all OK… I have experienced the same issue with installs using openSUSE, Ubuntu and Mint.

What happens if you press F3 and choose a text boot ? (do NOT install yet)

Can you tell us what Graphics your Dell Inspiron 1545 laptop has ?

Can you do ctrl+alt+f4 and see if that gives a hint?
what chip set do you have? there is a problem with intel video drivers (i915)

also there is a problem with compcache (ramzswap)

OK - I did the Text Install and everything seemed to work fine, resulting in a prompt for a Linux login

Graphics is Intel graphics media accelerator HD

Well, thats part way there. What is the output of running with root permissions:

sax2 -p

Also, do you have the file /etc/X11/xorg.conf.install ?

If so, what happens if you type with root permissions:

cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf

and then reboot?

Does that boot to a GUI ? Does it freeze ?

openSUSE-11.2 does not need an /etc/X11/xorg.conf file for most PCs, but it does for some PC hardware.

IF it does not boot go a GUI with the xorg.conf.install file, you can always boot to a text mode by typing a “3” when the very very 1st boot menu (to choose openSUSE-some-kernel, openSUSE-failsafe, Windows, … etc … ) appears. The “3” (no quotes) will go in the options line, and just press <enter> with the openSUSE Linux boot selected, and that will boot you back to a full screen text mode.

I tried to provide some Intel graphic card theory here: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums

of course ideally you would be using the “intel” driver, and NOT using my /etc/X11/xorg.conf.install suggestion.

result of sax2 -p is:
‘Chip: 0 is -> VESA Vesa-BIOS Graphics 00:02:0 0x8086 0x0046 PCI vesa’

the intel driver seemed to be listed in the drivers loaded during boot, how do I switch to a GUI from the text prompt?

Many thanks for your help !

The “GUI” desktop is often referred to as “run level 5” as opposed to the full screen text which is referred to as “run level 3”.

If the graphics is configured, and you are on a full screen text prompt in run level 3, and if there are no other X window sessions running (and there are not likely any to be running) then one can just type: startx

However the permissions one gets by typing “startx” are not as complete as those from a nominal boot direct to run level 5. it is just as simple to restart with “shutdown -r now” with root permissions.

I assume you read openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums and noted the intel driver can often be configured with:

sax2 -r -m 0=intel

… unfortunately with some Intel hardware, sax2 will freeze (the only way to find out is to try).

No progress here - as soon as i configure to the intel driver the screen goes blank.

If you type “man sax2” you will see the various options you can apply for the Intel driver.

You can go back to using the vesa driver by typing:

sax2 -r -m 0=vesa

you can also simply delete the /etc/X11/xorg.conf file, reboot and see if that works.

Another possibility is to try the xorg.conf.install file (if it exists).

You can do that by typing:

cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf

reboot and test.

Ah, progress… I gave up with the live CD and went for the full DVD installation - which installed perfectly with a graphical installation screen, although I still have the same problem after the boot screen.

Incidentally, in the boot options it reads: ‘vga=0317’ is this normal? Also, do I just type a space and ‘3’ after this in order to boot to run level 3 ?

If I can get that far I can try your suggestion of forcing the system to look for the intel driver

If you just press ‘3’ (no quotes) I think it will automatically insert a space after the “vga=0317”. If not, then put space there yourself.

I recommend you first check to see if there is an /etc/X11/xorg.conf file. If there is such a file, then I recommend you make a backup copy of that file first. Only after that backup copy is made, do I recommend you try the intel driver.

What sort of checks have you done now to see if the Intel driver is not already running?

It won’t even boot to runlevel 3 now, the screen goes blank just as it does when attempting to boot to the GUI. I’m stuck!