Dell D820 Thermal (?) Shutdown

I have an interesting problem that I need some suggestions on how to go further on diagnosing and solving.

My system is a Dell Latitude D820 (Intel Core 2 CPU T7400 @ 2.16GHz (x86_64) w/ 4GB RAM). I currently have the system set up to dual boot openSUSE 11.0 (with all updates) and Windoze XP. I very rarely boot directly into Linux as I’ve found it more useful for my work to boot Windoze and then run Linux on VMware Workstation. The two Linux installations (physical and virtual) share one physical disk partition for /home, but otherwise the physical installation has its own physical disk partitions and the virtual installation has its own virtual disk in the NTFS parition.

The problem that I have been chasing is with the direct boot physical installation. Since I rarely direct boot Linux anymore, this problem has become more of a recreational intellectual pursuit to solve.

What happens is this… On an intermittent basis, the system will simply power off. It appears to be acting like a thermal shutdown. I can hear the fan rev way up and then the system turns off. There are no log messages being generated. However, I find it hard to believe that this is a true thermal event. I’ve had times where the system has been turned off overnight and the shutdown can occur less than two minutes after powering up.

With openSUSE 11.0, this problem has been intermittent. It can happen very shortly after power up or it can happen an hour later.

I am in the process of updating my systems to openSUSE 11.1. I’ve found that this system’s problem is even worse with openSUSE 11.1. I boot up the installation DVD, select Installation from Grub, hit Esc to get a verbose boot, and before even getting to the first installation screen, the fan will rev up and the system powers down. I’ve done this several times now.

Just in case it was some chipset initialization crud being left behind from BIOS hardware initialization, I updated the system from the rev A07 BIOS to the latest rev A09. No change in the problem.

The other thing that I should add is that, if my memory is correct, this problem only began to happen after I went to openSUSE 11.0. I do not think I ever saw it with openSUSE 10.x.

I have been researching this problem on and off for a few months. From my Internet searching, I have been unable to find anyone with a similar problem or any good ideas on how to proceed further with solving this.

So, I am now at the point of reaching out to find out if anyone has any good ideas.

Advance thanx,

PS- This is not a “newbie” problem. I am an extremely experienced Unix person. I’ve been doing systems programming for over 30 years and first logged onto a Unix system in 1984. “Deep” suggestions are most welcome.

I hope my suggestion is “Deep” enough: check CPU usage.

What I’ve seen on a desktop computer was that plasma was eating 50 - 70 % of CPU which led to the computer overheating and doing a thermal stop (not even shutdown…)

Unfortunately, it is not Plasma CPU usage. With openSUSE 11.0, I’ve been using KDE 3.5. So, plasma is not running when the problem occurs. :frowning:

Also, when the problem occurs with openSUSE 11.1, it is during boot of the installation DVD. I hit escape during the splash screen and watch the verbose boot messages. I’ve gotten past loading part 6 of 6 of the installation images. So, there is no way that plasma is running yet then either.

I have been putting some thought into whether the Nvidia driver is involved after reading the recent thread regarding CPU fan rev’ing on a Dell D6xx. However, if it is that, I am not sure how I’ll ever update this system to 11.1 since it is crashing during the installation DVD boot. :frowning:


hmm as you have a dell: go to BIOS and disable

a) speedstepping
b) PLug’n’Play OS: No

then at boot time, when the boot screen appears, try the two switches: noapic acpi=off

It’ll have some side effects - but should let you install it.

Is your problem solved?

I may have the same problem with my d820.

Yes, I solved it. It turned out to be a hardware problem and not a software problem.

When I originally bought this D820, I got 2GB of RAM from Dell. (2 1GB DIMMs) When I upgraded it to 4GB, I had bought two 2GB DIMMs made by Centon. Apparently, they were running too hot and causing the thermal shutdown which I was experiencing. I also had access to a Dell D830 which had 4GB from the factory (I forget the brand). I swapped those DIMMs into my D820 and the problem went away.

Just by touching the center of the keyboard above the one DIMM and the bottom of the system under the other DIMM, I can tell that it runs cooler.

Since then, I have also had some Centon memory fail in my wife’s desktop system.

In both cases, I had bought the Centon memory because it was the cheapest cost. I think I’ve learned my lesson about trying to save a few bucks on memory.

Good luck with solving your thermal issue…