Dell 6400 Sound keys


Just wondering if anyone has this problem on Opensuse 11…

The keys at the front of the laptop to control sound volume etc… don’t seem to work. They were fine on 10.3…


Hi, i have Dell Latitude D620, sound hotkeys worked out of the box on 10.3, but not with 11 release, that very disapointed me. How can it be that on older releases hw works perfect, but on new release it does not. Because i using suse from 8.0, my conclusion, have a litle patient and use only versions x.3, that i notice from 9.0 release, best polished was 9.3, the same situation with 10v best 10.3, now 11 and bugs that cant be in this release, but …
Waitin 11.3…

I’ve got the same problem with my dell XPS notebook. From what I can see I’ve got two front audio channels listed in kmix (kde4) and xev shows that it doesn’t know about mappings like XF86AudioMute. I’ve grabbed a hotkey-setup rpm and tried it, it gives me the mappings, but I’m still unable to use the multimedia keys for anything.

I had the same problem: what I did to solve it it was to go to keyboard settings and remap the keys (multimedia keys). Everything is working fine from this point of view.
Please let me know if you need additional details.

My configurations:
Dell Inspiron 8200 / 512MB RAM, 2x40GB HDDs, Intel Mobile 2GHz, Nvidia Go440
Dell Inspiron 6400 / 2GB RAM, 120GB HDD, Intel 7200, Core 2 Duo 2Ghz, ATI x1400.

I have a Dell Precision M6300 running 10.3, thanks for information on getting the volume control buttons working.

Do you know how to make the volume more adjustable? What I am trying to say is that I get no volume until the selector is more than half way up, and therefore tops out very low. The volume control does not act like this in “Windoze”.

Any help would be greatly appreciated.



Seems like a similar problem here: On a Dell D630, I have Opensuse 11, KDE 3.5, KMix. Logged in as a user, the volume control buttons (up, down, mute) do not do anything. Controlling the volume through the slider of KMix does work, though.

Logged in as root, volume control both through buttons and through KMix work!

I did already add the user to the audio group which was necessary to actually get any sound (like system bell etc.) for a user.

How can I get the volume control buttons to work for a user?


Some additional observations: I had to adjust my keyboard layout (wrong default at system installation). Logged in as user, I started Yast which requires root password, of course, made the changes in Yast - Hardware - Keyboad Layout, and saved them before quitting Yast. Now the volume buttons worked!

Then I logged out as user, and logged back in. The volume buttons did not work anymore!

What is going on here, how to resolve the issue?

i have the some question!