DELL 1535 HCL report

About dell studio 1535 and openSUSE 11.1:

The bluetooth works out of the box… at least it seem to work hci_tool lists nearby devices, but no X interface works.

The card reader works! But only for SD/MMC cards. Yesterday I tried a Memorystick Pro and it didn’t worked. I had to reboot and go to WinXP to download my files. :expressionless:

Alsa has problems I guess… I’ve reported them in this thread Audio problem on DELL Studio 1535

Hibernation fails after 2-3 successful hibernations.

Multimedia keys are dead.

3D effects cannot be enabled on radeonhd driver. Reported with no success in this thread DELL Studio 1535 compiz problem

You can keep those tips in mind, or if you think I am wrong somewhere, I would be happy to discuss! :wink:

I have a Dell Studio 15 and I wrote up most of the Dell Studio 15 HCL you see on the openSUSE Dell laptop HCL page. HCL/Laptops/Dell - openSUSE

I use if for an SD card. I’ve never tried a Memorystick Pro card. I recommend you write a bug report on this.

I replied on that thread. The integrated Mics do not work with any Linux version (not even with the Ubuntu that comes with the Dell Studio 15). But the externel mic (input jack) does work on openSUSE-11.1 with the nominal alsa that comes with 11.1. My wife and I have successfully used a mic with that laptop a number of times.

I’ve only tried it a couple sucessive times in a row. Typically, I shut down the laptop completely when not in use.

My multimedia keys work on KDE-3.5.10 on openSUSE-11.1. I did not have to configure anything. They “just worked”.

I’m not into fancy graphics, so I have not tried this. But I’m not surprised. If you want special desktop effects and 3D, IMHO you need to try to get the proprietary ATI driver to work with the laptop. I believe the openGL driver (which is the radeonhd) does not provide sufficient performance.

I also tested the HDMI. The video worked for me. The HDMI audio did not work. Its difficult for me to test the HDMI, and hence I did not write a bug report (although one should be written). The difficulty with bug reports, is the alsa/openSUSE dev does not have the same hardware, so they need a lot of iterative support to solve any bug report. I can not provide that with HDMI.

I found the web cam video works with the uvc driver. There is speculation that the integrated mics are associated with the web cam in terms of functionality, but if so, alsa does not pick up the USB mics (if they are USB mics). I’ve also read many posts of Vista users who find the quality of those internal integrated mics to be absolutely pathetic, to the point of not being so useful. Hence I deemed it not worthwhile to pursue. Especially given an external mic works fine.

The headphones (the function to mute speaker when plugged in) initially did not work, and myself and another user (after my writing a bug report) liaised with the alsa/openSUSE dev, and he managed to get it working, and then sent the fixes upstream to both the kernel and to alsa.

I have the Intel 5300 AGN wireless. It works ok with openSUSE-11.1. The wired connection also works well. The USB ports all work ok. The touch pad also works.

I have a Dell Studio 15 and I wrote up most of the Dell Studio 15 HCL you see on the openSUSE Dell laptop HCL page. HCL/Laptops/Dell - openSUSE

Yes, I know that. From the begining of my DELL with openSUSE quest this HCL and the forum were my guidelines. But there seem to be differences that I can’t manage to fix. About the multimedia keys… I use kde4 :X Can you please paste me a bit of your xorg.conf I can’t believe that kde4 can let me down like that.

I use if for an SD card. I’ve never tried a Memorystick Pro card. I recommend you write a bug report on this.
I also use SD cards. But I accidentally had to download some images from a sony memorystick and I just found that opensuse doesn’t care that I want to do that. rotfl! No response at all. :shame: So, there is not much to report… its just not responding. I don’t know if it just can’t auto mount it or there is a driver problem… Im not that advanced in linux.

No progress with the bluetooth issue also.

I can “see” devices. But I’m not a console guru to make a file transfer via console commands. :\

Never mind the hibernation issue… It’s a whole miracle that it works at all. I also shutdown my machine most of the time.

About the HDMI… I’m not sure if I ever gonna need this thing.

advanced or not, it SHOULD “just work”. So I recommend you write a bug report.

If you wish to dive into it technically, you could check to see if the sony memory stick is “seen” when plugged in. You could do that, by pluggin it in, and type su -c ‘fdisk -l’ and enter root password when prompted, and then try to identify the memory stick in the text output of that command. If you can identify it, you may be able to manually mount it.

I believe I have read of Ubuntu users getting the bluetooth to work, so I suspect it will function. There are some good threads on this very bluetooth issue on our forum, explaining how to get bluetooth working.

Me too. We have a TV in a different room, that has an HDMI input. But its located inside a cabinet, accessing the HDMI connector is difficult, and the wife is using the TV all the time. So its simply not worth the domestic aggravation for me to try iteratively test and debug it. :slight_smile:

After one update of my system, kbluetooth was updates and now my bluetooth works very nice. My multimedia keys still don’t work at all. Any idea how can I make them work…?:\ I use openSUSE 11.1 latest updates and KDE 4.2.1.

I think you should start a new thread asking for help. … or you could also ask on the Dell Linux support mailing list … While predominantly Ubuntu, sometimes the Ubuntu solutions work on openSUSE. … I find that Dell Linux mailing list an eye opener as there are a fair number of Ubuntu users with basic problems on various Dell models, despite Ubuntu being provided as OEM on most of those models. Many of the problems come from Ubuntu users who decide to re-install their Ubuntu for what ever reason (but I diverge).

Did you ever write a bug report on the Sony memory stick not functioning? I ask because I am considering purchasing my first (ever) dedicated camcorder, and of the 3 models I am considering, one is a Sony, and of course it can use a Sony memory stick for its still pix transfer. Hence I’m wondering about laptop compatibility with this proprietary Sony technology.

Last I tried my external mic was not working. … I messed something up in the mixer, and I’ve been too busy researching High Definition Video, Non-Linear Editors, and various graphic cards associated with old desktop PCs to try sort that. … I also read of a Linux user who managed to get the internal mics working on their Dell Studio 15 (and I think I lost the reference) . … I need to dig that up sometime. …

Needless to say, you can see getting a mic to function on that Laptop is not a high priority of mine (but it might be of Mrs.Oldcpu, so I need to look into this).

I have a Sony Handycam, I have used an external reader to read the sony
4GB card ok, else I can connect direct via USB and have access to the
dvd or sd card?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 3:29, 3 users, load average: 1.15, 0.58, 0.33
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

OK, interesting … but did it work when connected to a Dell 1535 (ie Dell Studio 15)? … Sometimes a USB device (or a SD card or Sony memory stick) will work on one PC and not on another. Hence the note in this thread is really specific to the Dell Studio 1535.

… or did I misinterpret your post? (It won’t be the 1st (nor last) time I’ve jumped on the wrong train). :slight_smile:

Not a Dell, Asus and Toshiba notebooks… have also connected to the
desktop system which is an Asus MB but that runs SLED, but my assumption
was that as a USB device as long as the system recognizes the id’s all
should be ok.

Does that mean the Dell changes something in the udev rules or in how
usb is implemented at a hardware level?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 4:15, 1 user, load average: 0.18, 0.28, 0.24
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

udev rules? No.

Hardware? Yes. Every USB supplier’s hardware is a bit different.

udev rules? No.

Hardware? Yes. Every USB supplier’s hardware is a bit different. And its not just for a USB memory stick. Its also for the proprietary Sony image storage (I don’t know the term Sony use to describe their proprietary competitor to the SD card).

Correction to that. The Internal Mics do work on the Dell Studio 15 with openSUSE-11.1 and 1.0.19 of alsa. I documented my success with this here: openSUSE Forums - View Single Post - Dead microphone – Dell 1525

I will update the openSUSE HCL for the laptop.