deleteing folders and files

I am running Open Suse 11.4 using KDE4, and whenever I try to delete a file “move to trash” it gives me a popup saying “The trash has reached its maximum size! Cleanup the trash manually.” and when I go to the trash can it is empty…happens both on trying to delete files from Linux Partition or the Windows Partition, and I do have it set to allow me to have read and write access on Windows…what do I have to change to be able to delete files:\

You could set YaST to clear your temp folders and reboot to see if that might help.

Open /etc/sysconfig/cron, search for a line saying


…and edit “no” to “yes”. This could also be done via GUI: YaST → “Editor for /etc/sysconfig”.


Both examples do exactly the same thing, so you only need to do one of them. Just one thing you could try. Following is a warning from another user

Be careful with this setting. I had it too, just thought it is good system maintenance. …then …
I was working on a letter (OO) and we had an power blackout. restart…could not recover the file. I changed the setting MAX_DAYS_IN_TMP=2 for 2 (days) and left CLEAR_TMP_DIRS_AT_BOOTUP=no.

However, you can use this setting as yes, reboot to clear everything and then change it back to no and then use MAX_DAYS_IN_TMP=2 thereafter.

Thank You,

Made change to /etc/sysconfig/cron to yes and rebooted…no change, still getting the error msg…“The trash has reached its maximum size! Cleanup the trash manually.”…I do not have the problem if running GNOME only in KDE

Check the directory ‘~/.local/share/Trash/files.’ Do you have any files there?

Use Konqueror or Dolphin to change your Trash settings. In Dolphin, for example, you can find that under the menu Settings > Configure Dolphin … > Trash. I am not sure what exactly you need to set there, but I think your issue lies with limiting the trash to a maximum size.

When I ran the below I got following results of 0…if I did it right anyway
nitewalker@linux-w71t:~> cd ~/.local/share/Trash/files
nitewalker@linux-w71t:~/.local/share/Trash/files> ls -l
total 0

Did what “Lord Emsworth” suggested and cleared the check mark from “limit to maximum size” in Dolphin and all works as advertised, thanks to all of you for you assistance, really appreciate it, so this is now solved…thanks again

I’m using OpenSUSE 11,4 and that message pops me up when I was trying to delete a lot of files. My trash can was configurated with LIMIT TO A MAXIMUM SIZE checked… well, I’m unchecked it, clicked OK and it works fine. No problems until now!!

It sounds like you reached your max. Why don’t you raise that, if it’s a problem, or leave this unchecked?

It happens to me if I don’t have enough space on my home partition to store the file in trash. Can you check the output of :

df -h

to see if that is the case ?
You can use Shift+Del to permanently delete, which is what I use.