Deleted OpenSuse Partition, Can't Boot Windows

Hi guys, I’ll try to explain this simply and concisely.

From the beginning:

Installed Windows XP (for probably the 4th time on my laptop)

Got bored, installed OpenSUSE
Didn’t ever use OpenSUSE so decided to free up some
hard disk space, and deleted OpenSUSE partition.

Problem: Can’t boot XP

Attempted Fixes: Boot from Windows CD, tried FIXMBR and FIXBOOT commands on Windows repair console, (I did the same thing with an Ubuntu distro, deleted partition and if I remember correctly, FIXMBR worked last time) however neither worked, GRUB still loads, can’t boot anything.

Also tried to: boot (hd0,(0-8)) from within the GRUB bash screen, didnt work (I think i got like a Kernel not loaded error)

Current Partitions: 40GB C: - WINDOWS, 70GB D: - Music/Video/Shared Space, 50 or so GB of unpartitioned space (what once held the OpenSUSE partition.

I hope that’s a clear enough description, if its not, let me know what info I need to provide.

Thank you for any assistance you are able to give

Found the HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive
Gonna try some of these out.

Basically you need to do fixmbr with a windows cd. That link should help you. Or google fixmbr.

I tried that, still went to grub :confused:

Edit: did fixmbr in repair console, did NOT try fixmbr \Device\HardDisk0

Edit: FIXMBR does not solve the problem

Please try this:

• Windows 2000/XP on the computer: Boot from the XP/2000 installation disk and proceed to the final screen where you have the option to Repair Your Computer. Press “R” for Repair and log onto the Windows installation. When the command prompt appears, enter the command fixmbr. Confirm “yes” and you will receive confirmation of the reinstallation of Windows bootstrap code into the MBR. Enter exit and the computer will reboot.

copy d:\i386
tldr c:\
copy d:\i386 c:\

Just thought. You may need to set the boot flag back to the C drive
I always use Parted magic for that: Downloads - Parted Magic

I honestly have done exactly what you said step for step 4 times now. GRUB still comes up upon reboot and the command find/boot/grub/menu.lst returns file not found

EDIT: tried the two commands you have in the code boxes and it returns “access is denied”
I have no administrator pw if that makes a difference

Sorry for slow responses and typos. Im using my iPod to get online

Your trying to get windows working after deleting SUSE partitions are you not?

Didn’t ever use OpenSUSE so decided to free up some
hard disk space, and deleted OpenSUSE partition.

In this case there will no longer be any /boot/grub/menu.lst you just deleted it. I can’t see what you want to find that for.

You need a WINXP CD
A quick google will get all kind of results: How to fix MBR in Windows XP and Vista

Did you boot parted magic and switch the boot flag or at least check it’s on the winxp partition?

If other files like ntldr have been damaged then you have to copy those off the XP CD from the command prompt, I’m googling for you
NTLDR Is Missing - How To Repair ~ The Blade by Ron Schenone, MVP

Boot with the boot CD from XP, start the recovery console en try the following :


Also start FDISK alone and mark the windows systemdrive as active.

Thanks for all your help caf. I ended up destroying the partition table so I used parted magic to back everything up. Just 2 partitions with it. BTW, fantastic live distro. Thanks for the tip!! Reinstalling windows right now but I think I’m gonna go back to ubuntu for my Linux distro til I’m more comfortable with unix based OS’s. Anyways, thank you for your help! I’m gettin really sick of typing on my iPhone so I’ll clearly explain what happened when I have my network controllers installed on my of lol

Good luck and you are welcome;)