Deleted default desktop

I usually use the default KDE desktop with a few changes. I deleted the bar the bottom of screen. I can’t get those setting right. There’s no undo function. I was able to recreate some things. I can’t get the icons into right position. Also, I can’t get the display for all programs or get the right wigits running . I need someone to walk me through it. Else, I’ll just reinstall suse(11.3). Thanks.

To get the bottom bar back in KDE4 this is what I do:

Press control+alt+f1 and log in as root

/etc/init.d/xdm stop
rm -r /home/YOUR_USERNAME_HERE/.kde4
/etc/init.d/xdm start

This will reset all KDE4 config to default settings

Removing ~/.kde4 does reset everything on next login. But it is not needed to stop the whole graphical part of the system (including annoying others that may be loged in). Thus it is not needed to do this as root!

Simple, as normal user, in a terminal do

rm -rf .kde4

This will remove ALL the settings of KDE and it’s applications. A logout and login will recreate the defaults.

I found that if I was logged into KDE and removed my .kde4 directory then logged out and logged back in my bottom panel would just disappear. Thats why I always stop X11 first before removing it.

Then again, X has nothing to do with this, it is your running KDE session. Thus:
. log out of the GUI;
. use Ctrl-Alt-F1 to go to the console and login with your normal username and password;
. delete .kde4 as shown earlier;
. type exit to log out from the CLI;
. use Ctrl-Alt-F7 to get back to the graphical login screen;
. login.
It is and stays important not to use root when not needed. This includes cases where it seems easier for the lazy ones to do contrary. And even when individuals think this rule is not applicable for them, this should still not be propagated to others on these Forums.

OK Thanks for info I’ll do this next time when I stuff up my KDE :slight_smile:

You are welcome.

BTW a good way to stop all X on a system is change the runlevel to 3 (and back to 5 when finished). This must be done as root of course rotfl! :

init 3

hcvv wrote:
> BTW a good way

btw2: it is also possible that you might find there was some part of
the kde4 you were happy with…but, by deleting .kde4 you blew away
ALL of the existing configuration…

so, instead of “rm -rf .kde4” comtemplate KEEPING it for a while, just
in case, thusly as yourself, a simple user:

mv  ~/.kde4 .kde4old

then, if in a few days you are happy with what you have, you
can…again, as yourself:

rm -Ir ~/.kde4old

ymmv! (anyway, since i don’t have a /.kde4 i can’t see if there is any
potential ‘good stuff’ being thrown out!)

CAVEAT: [posted via NNTP w/openSUSE 10.3]
When it comes to chocolate, resistance is futile.

You are correct. Moving it away (I would not let the new name start with a . so I can better see I still have it) gives you a change to restore e.g.* .kde4/share/config/digicamrc* to restore your precious digicam parameters.

I did that and rebooted. It was quick to setup everything again. :slight_smile:

Now though, the clock font is too big. It was smaller last time. There is no way to change the font size from the bar.

Its in Settings->Locale->Country/Region & Language->Time & Dates
Then change time format to:


Then log out and log back in

Everything is back to the normal settings. Need to try the comics wigit. :slight_smile: Thanks.