Default sound card

Hi all, am new to the OpenSuse forum but I have used this distribution in the past and the truth is that except for some minor things like I’m going to ask this distribution is my favorite.

My question is about sound cards. I personally listen to the audio I have two sound cards, and ubuntu with the configurator could predetermine one of the two easily, but in OpenSuse I have not found how to do it and hes me very uncomfortable because one of my audio devices unusable … …
My question is simple, as I can predetermine again and sound card to the audio sound that I want?
Thank you very much before and greetings.

Yast > Hardware > Sound

You can set it there

You may need to make sure the mixer settings in the panel are correct also

It is hidden down-right under a button saying Others or More or something IIRC.

In addition to using YaST in YaST > Hardware > Sound, in the KDE desktop it can be necessary to go to Kmenu > Configure Desktop > Multimedia > phonon and ensure one’s order of sound devices there is consistent with YaST.

I have also found in openSUSE-11.4 to install the application “pavucontrol” makes it easier for me, and the very first time I run any multimedia application, I also run the application “pavucontrol” to configure pulse audio for the application. Pulse audio then remembers the settings.

Something worth considering, if it’s an onboard card that’s unusable then you should be able to disable it in bios, then it woudn’t be recognised by the OS, it would only be seeing your ‘good’ card

If the unsable card is a plugin one it can just be taken out

In the icon below right, I double click the sound icon and select the “Select Master Channel” and I get my two sound cards (Logitech G35 - Audio Internal) But while the camera so the sound card Internal Audio speakers are …

Anyone have any suggestions on how to change? Because from Yast I can not

What desktop (KDE ? Gnome ? Xfce ? LXDE ) ? What openSUSE version ? 11.2 ? 11.3 ? 11.4 ?

I suggested ‘pavucontrol’ in a post above (using that to configure your audio devices).

Also for KDE, on that Phonon panel (also from Audio Setup in KMix’s Settings), you should at the same time check on the Speaker Setup tab that the right Profile is selected for your hardware. The selected profile will affect which sound device is “enabled” on Phonon’s main tab. That may be all you need to do for PulseAudio settings.

Thank you very much, and I can select it with pavucontrol well: D
And works as I wanted

And if its openSUSE 11.4 Gnome, you can do all the same setup and more, using the Sound preferences/settings available from the desktop’s system tray. If you want to install a non-resident app to do it, that’s up to you :D.