Default is not active.

My virtual machine does not start, it tells me default is not active.

Through google I found a topic on this forum and tried something.

-- Journal begins at Wed 2021-09-29 11:47:03 CEST, ends at Mon 2021-10-18 14:36:40 CEST. -- 
okt 18 13:21:41 localhost systemd[1]: Starting Virtualization daemon... 
okt 18 13:21:41 localhost libvirtd[1047]: libvirt version: 7.8.0 
okt 18 13:21:41 localhost libvirtd[1047]: hostname: localhost 
okt 18 13:21:41 localhost libvirtd[1047]: **Failed to initialize libnetcontrol.  Management of interface devices is disabled** 
okt 18 13:21:41 localhost systemd[1]: Started Virtualization daemon.

Did I find the problem, and how to fix it permanently ?

I already found I can get it working until the next reboot with

sudo virsh net-start default


virsh net-autostart default


Thank you, that fixed it. :slight_smile:

Can I have qemu stop running when I quit kvm virtual machine manager ?

I already tried to stop qemu-system-x86_64 ( ctrl +esp) but it refuses to stop.

You have to stop/shutdown the virtual machine, then exit virtual-manager?

Now I finally understand, how this works.

When I choose in virtual manager, shutdown, with win 10 selected, I see windows shutdown, and then vm reports guest not running.

After this nothing qemu under running processes. :slight_smile:

If I choose quit from the top left menu, I only stop the virtual manager, not the virtual machine. (so qemu keeps running)

Correct, you can always use virsh from the command line to start/stop as well…