default browser

I keep having to set my default browser over and over. It won’t keep the information. Every time I load Google Chrome I have to set it as a default browser. Why is this? Any help would be greatly appreciated.

You can set your default browser in KDE’s ‘Systemsettings’ > ‘Default applications’.

If Chrome still nags you about any default browser setting, then check Chrome’s settings, and see if you can turn it off. (There is a similar setting in Firefox under ‘Edit’ > ‘Preferences’ > ‘Advanced’ > ‘General’.)

Amusingly, I’ve had the opposite experience. Though my default browser is Konqueror and chromium has stopped complaining about this, when KPDF comes across a url in a PDF, it loads chromium rather than Konqueror.