Default boot option is wrong

In openSUSE 12.2 (KDE), while the machine is booting up, the green screen with Linux kernals appears. One called “openSUSE” and another called “desktop openSUSE” but both have identical numbers attached. Then there are 2 failsafe options.

If I leave my PC, then it will select the third option, which isn’t a failsafe option, but the “dekstop” one and ends up in a Terminal screen.

What do I do to get the machine to default to the obvious default one that I want?

First: there should be just two: openSUSE and Failsafe. You can modify the bootloader’s preferences through Yast - System - Bootloader, and change the default choice there.

This may be caused by installing both kernel-default and kernel-desktop. And that would explain your problems with the NVIDIA driver. If you install that whilst running kernel-default, it will not work properly when running kernel-desktop since some symlinks will point to the wrong place.
I get the impression that you perform actions first, then, when trouble arises, ask for solutions. Maybe you’d better do the asking before the actions, it would make things easier for you and your system. Not meant as criticism, or a way to make you feel dumb or whatever, we’ve all been where you are now, and this beautiful community can actually help you to enjoy your linux experience even more than you do now.

On Thu, 02 Feb 2012 21:26:03 +0530, Forkjulle
<Forkjulle@no-mx.forums.opensuse.org> wrote:

>
> In openSUSE 12.2 (KDE), while the machine is booting up, the green
> screen with Linux kernals appears. One called “openSUSE” and another
> called “desktop openSUSE” but both have identical numbers attached. Then
> there are 2 failsafe options.
>
> If I leave my PC, then it will select the third option, which isn’t a
> failsafe option, but the “dekstop” one and ends up in a Terminal
> screen.
>
> What do I do to get the machine to default to the obvious default one
> that I want?
>
>

“desktop” is the default option, but it shouldn’t end up in a terminal
screen, unless you specifically configured it to boot into runlevel 3,
i.e., not into the graphical environment, in your case KDE. what happens
if you log in to that terminal session as your normal user and type
“startx” ?


phani.

On Thu, 02 Feb 2012 21:36:03 +0530, Knurpht
<Knurpht@no-mx.forums.opensuse.org> wrote:

>
> First: there should be just two: openSUSE and Failsafe. You can modify
> the bootloader’s preferences through Yast - System - Bootloader, and
> change the default choice there.
>

looks like he’s got kernel-default & kernel desktop installed. that would
lead to these four entries into menu.lst. and he isn’t using the desktop
kernel, which might lead to performance issues, particularly with this
high resolution. (don’t know, never had that high resolution myself.)

and that the desktop option doesn’t boot into runlevel 5 menas there’s
something wrong.

apart from that, having to video cards for one monitor doesn’t make sense
to me…


phani

On Thu, 02 Feb 2012 21:48:02 +0530, phanisvara das
<listmail@phanisvara.com> wrote:

> On Thu, 02 Feb 2012 21:36:03 +0530, Knurpht
> <Knurpht@no-mx.forums.opensuse.org> wrote:
>
>>
>> First: there should be just two: openSUSE and Failsafe. You can modify
>> the bootloader’s preferences through Yast - System - Bootloader, and
>> change the default choice there.
>>
>
> looks like he’s got kernel-default & kernel desktop installed. that
> would lead to these four entries into menu.lst. and he isn’t using the
> desktop kernel, which might lead to performance issues, particularly
> with this high resolution. (don’t know, never had that high resolution
> myself.)
>
> and that the desktop option doesn’t boot into runlevel 5 menas there’s
> something wrong.
>
> apart from that, having to video cards for one monitor doesn’t make
> sense to me…
>

got an idea, but before you act on that, wait for confirmation or
correction from others, please:

to me it looks as if you have both, kernel-desktop and kernel-default
installed on your system. kernel-desktop is optimized for ‘normal’ desktop
use, while kernel-default gives different priorities to processes, like in
a server environment.

when you boot the default (kernel-desktop), you end up in a terminal
session, while dernel-default boots into graphic environment. this means
that you installed the nvidia driver for the default, but not the
desktop kernel.

to use the nvidia driver for the other kernel variant (desktop), you’ll
need to compile it for that kernel, too (cross-compiling).

just let the system boot into the kernel-desktop option which lands you in
a terminal. log in as root, then type “init 3”; probably you’ll have to
press <enter> to get back to the command prompt.

after that go into the directory with your nvidia driver, then type “sh
NVIDIA-Linux-x86_64-290.10.run -K” in order to compile the driver for the
desktop kernel, too. after that finished successfully, type “init 5”, and
you should end up in a graphical (KDE) session using the desktop kernel,
which just might work better…


phani.

This explains a puzzle for NON-Technical when self experienced similar problem with GRUB options using Gnome.

Admit not sure if problems from when start trying learn to set up and use SAMBA to access home files from other computers when away, or an install then uninstall of some Nvidia drivers.

#Q (a) Do we just leave one whilst uninstall the others ?

#Q (b) Is one better to retain than others ?

linux-xfp4:~ # zypper se -i kernel
Loading repository data...
Reading installed packages...

S | Name            | Summary                             | Type   
--+-----------------+-------------------------------------+--------
i | kernel          | kernel: security and bugfix update. | patch  
i | kernel-default  | The Standard Kernel                 | package
i | kernel-desktop  | Kernel optimized for the desktop    | package
i | kernel-firmware | Linux kernel firmware files         | package
linux-xfp4:~ # 

I’d remove kernel-default unless you have a good reason for it.

If you plane to install the NVIDIA driver the hard way (really not hard) you would also need the kernel source.

When start up at OS choice prompt need to add to command line: x11failsafe in order to open Gnome desktop.

As differing from original question should this be in a new thread ?

BTW searching for solutions when found this thread.

On 2012-02-05 06:06, paulparker wrote:
> As differing from original question should this be in a new thread ?

Yep. Post with an appropriate title, give details in text.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)