default boot and failsafe boot mode login probem

hiiiii
i m very excited for using suse …but after installing i got some problems…i m using wwindows 7 dual boot with open suse 11.4
1.after booting through default mode…screen just hangs up…so i have to restart and then again in booting i have to type “acpi=off”…what it meant…i got this idea through my friend…so i dont know much about it…
2.also after booting through fail safe mode…login screen comes like terminal mode…then i type the username and password then press enter…it log in and give some type of msg like “have lot of fun…” something like that…but from this screen i can’t able to go to desktop…please help me out how to go directly to desktop through any boot options…
3.after shutdown the screeen just hangs up it logged out and doesnt turned off properly…every time…
so i have to power off the system every yime i got this problem to restart…

It sounds like you have a right mess to me.

Try telling us about your machine: Make, model, graphics etc…

system is hp pavilion dv6 3120 tx…
windows 7 operating system
ATI Radeon 512 MB…
320 GB hard disk

Google shows it to a made for India machine?
And your IP address is India.
Not that I know if that is important but there we are.

That you can’t boot even in Failsafe is not good
I suggest you look at this
openSUSE Forums - ATI driver with atiupgrade

There is more info here too
openSUSE Graphic Card Practical Theory Guide for Users

I’m wondering if you installed using a Live CD or a DVD?