Default applications not switching

While using Firefox browser and needing to send an “email link”, Leap 15.3 will not use Thunderbird as the default email application after switching from Kmail to Thunderbird. Keeps using Kmail as the default email application.

I’m still on 15.2 but I’d say that’s not a Leap or KDE issue. If you want to send from Firefox you need to do that setting in Firefox:
about: preferences => General => Application choose the application for e-mail message.

Yes, thank you. My error. However, shouldn’t Firefox use the default program if Thunderbird is chosen?

Maybe - especially, as the standard setting in FF is “always ask”, right? But I don’t know if that’s rather a Leap or FF issue, sorry. I can’t even reproduce, as kmail is my only mail program and messing around with the FF settings didn’t help here. FWIW, I’m on FF 89.0.

I’m using Firefox 78.10esr. Haven’t yet learned how to add multimedia extensions to 89.0.