Default application to open PDF in firefox


Firefox Quantum 62.0 64 bits. Opensuse leap 42.3. I have crossover codeweavers installed an in one of the bottles I installed acrobat reader and the installation set it as my default PDF application. but I changed it to okular in All settings-applications-default applications and dolphin use okular to open PDF files. I also changed in firefox preferences-applications and I have all options for PDF as “previsualize in firefox” “ask” or “open with okular” and it works for most except for the button “show downloads progress”. When I download a file and the arrow icons turns blue if i click on the icon and then on the file name firefox launch adobe acrobat to open it.
I can’t find where I can change this behavior.

any help?


I’m not sure where you are clicking on an icon. However, I would guess that what you are seeing depends on a desktop setting rather than a firefox setting. I’m also not sure what desktop you are using, though I suppose that your mention of “okular” hints at KDE.

I’m guessing Firefox cached some mime info and is using old information about file associations
not really sure if this would help but you could try running

update-mime-database $HOME/.local/share/mime
update-desktop-database $HOME/.local/share/applications

this should set the preferred applications per mime type user wide

Had some similar trouble related to Firefox and finally arrived with:

karl@hofkirchen:~> grep firefox ./.config/mimeapps.list
karl@hofkirchen:~> grep pdf ./.config/mimeapps.list

I’m waiting for a response from the OP before making any suggestions.

It would be nice if people who ask for help, when they get replies, would at least acknowledge the replies. Something new we invented, called Courtesy.