Deepin Music Player on 13.2

I’ve installed Deepin Music Player but it refuses to run. I Googled Deepin installs and found one post that said it needed to install some numpy* packages which I did but it still refuses to run. When I click on the Deepin icon it makes an attempt to load but nothing happens. Anyone else had this problem or know how to get it to run?? Thanks!!

I assume that you installed it from YAST from the basic repositories.

If so, fire it up by opening any terminal window and type;


deepin-music-player

If it encounters any errors or lacks libraries etc. it will output them in the terminal window.

Thanks, Miuku…will try that when I get home from the night shift…

Here is the output from when I ran the command:

valentinousn@linux-ln38:~> deepin-music-player
Traceback (most recent call last):
File “/usr/bin/deepin-music-player”, line 25, in <module>
from cover_download import SimpleFetchManager
File “/usr/share/deepin-music-player/src/cover_download.py”, line 32, in <module>
from library import DBQuery, MediaDB
File “/usr/share/deepin-music-player/src/library.py”, line 28, in <module>
from song import Song, TAG_KEYS
File “/usr/share/deepin-music-player/src/song.py”, line 25, in <module>
import gst
ImportError: No module named gst

See here:
https://forums.opensuse.org/showthread.php/496081-Deepin-music-player-issue-gst-import-error

Apparently you have to install the package “python-gstreamer” to fix it.

PS: there is no python-gstreamer, it should be python-gstreamer-0_10. But that’s required by the deepin-music-player package anyway, so it should be installed:

# zypper info --requires deepin-music-player
Loading repository data...
Reading installed packages...

Information for package deepin-music-player:
--------------------------------------------
Repository: openSUSE-13.2-1.28
Name: deepin-music-player
Version: 2.0git20140505-3.1.4
Arch: noarch
Vendor: openSUSE
Installed: No
Status: not installed
Installed Size: 13.0 MiB
Summary: Deepin Music Playe
Description: 
  Deepin Music Player with brilliant and tweakful UI Deepin-UI based,
  gstreamer front-end, with features likes search music by pinyin,
  quanpin, colorful lyrics supports, and more powerful functions
  you will found.
Requires:
  /usr/bin/env
  python-gtk
  python-gstreamer-0_10
  python-imaging
  python-scipy
  python-xlib
  python-mutagen
  python-keybinder
  deepin-gsettings
  python-CDDB
  python-chardet
  python-pyquery
  rpmlib(CompressedFileNames) <= 3.0.4-1
  rpmlib(PayloadFilesHavePrefix) <= 4.0-1
  rpmlib(PayloadIsLzma) <= 4.4.6-1
  rpmlib(PartialHardlinkSets) <= 4.0.4-1
  deepin-ui >= 2.0git20130724
  python == 2.7

Did you choose to “break xxx by ignoring some of its requirements” at some point when installing some package?

Anyway, (re-)install python-gstreamer-0_10 and it should (hopefully) work:

sudo zypper in -f python-gstreamer-0_10

Now I get the following:

** Message: pygobject_register_sinkfunc is deprecated (GstObject)
INFO Loading settings…
Traceback (most recent call last):
File “/usr/bin/deepin-music-player”, line 266, in <module>
DeepinMusicApp()
File “/usr/bin/deepin-music-player”, line 65, in init
self.__init()
File “/usr/bin/deepin-music-player”, line 192, in __init
self.__show_splash()
File “/usr/bin/deepin-music-player”, line 261, in __show_splash
import widget
File “/usr/share/deepin-music-player/src/widget/init.py”, line 24, in <module>
from widget.skin import app_theme
File “/usr/share/deepin-music-player/src/widget/skin.py”, line 1, in <module>
from dtk.ui.theme import Theme, ui_theme
File “/usr/lib/python2.7/site-packages/dtk/ui/theme.py”, line 23, in <module>
from skin_config import skin_config
File “/usr/lib/python2.7/site-packages/dtk/ui/skin_config.py”, line 23, in <module>
from dominant_color import get_dominant_color
File “/usr/lib/python2.7/site-packages/dtk/ui/dominant_color.py”, line 25, in <module>
from draw import draw_pixbuf, draw_vlinear, draw_hlinear
File “/usr/lib/python2.7/site-packages/dtk/ui/draw.py”, line 31, in <module>
from utils import (cairo_state, cairo_disable_antialias, color_hex_to_cairo,
File “/usr/lib/python2.7/site-packages/dtk/ui/utils.py”, line 25, in <module>
from deepin_utils.core import merge_list
ImportError: cannot import name merge_list

I didn’t break the installation in the beginning. I installed it via YAsT. So not sure what happened. Appreciate your help. Thanks!!

But you seem to be missing basic requirements of deepin-music-player that YaST should have installed automatically.
Now it seems to be deepin-utils, try to install that.

But maybe also post your repo list, and what deepin-music-player packages you actually have installed:

zypper lr -d
rpm -qa deepin*

Btw, I just installed deepin-music-player with zypper (“zypper in deepin-music-player”) on my 13.2 system, it installed 14 additional packages and works fine without me having to install anything else manually…

output for zypper lr -d:

valentinousn@linux-ln38:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

—±-------------------------------±------------------------------------±--------±--------±---------±-------±-----------------------------------------------------------------------------------±-------
1 | download.opensuse.org-non-oss | Main Repository (NON-OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.1/repo/non-oss/ |
2 | download.opensuse.org-oss | Main Repository (OSS) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distribution/13.1/repo/oss/ |
3 | download.opensuse.org-oss_1 | Main Repository (Sources) | Yes | Yes | 99 | yast2 | http://download.opensuse.org/source/distribution/13.1/repo/oss/ |
4 | download.opensuse.org-update | Update Repository (DEBUG) | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/update/13.1/ |
5 | download.opensuse.org-update_1 | Main Update Repository | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
6 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386 |
7 | home_Reki | Reki’s Home Project (openSUSE_13.2) | Yes | No | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Reki/openSUSE_13.2/ |
8 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
9 | openSUSE-13.1-1.10 | openSUSE-13.1-1.10 | Yes | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GSA-4082N_FEB0ADBA384C,/dev/sr0 |
10 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/ |
11 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/distribution/13.1/repo/oss/ |
12 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
13 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/ |

output for rpm -qa deepin*:

valentinousn@linux-ln38:~> rpm -aq deepin*
deepin-utils-0.0.1git20130724-2.1.3.i586
deepin-media-player-lang-2.0git20140428-2.1.noarch
deepin-gsettings-0.1git20130318-2.1.1.i586
deepin-music-player-2.0git20130802-1.2.noarch
deepin-ui-2.0git20140507-1.1.noarch
deepin-music-player-lang-2.0git20130802-1.2.noarch
deepin-media-player-2.0git20140428-2.1.noarch

Thanks again!!

I also ran zypper in deepin-music-player and got the below output:

valentinousn@linux-ln38:~> sudo zypper in deepin-music-player
root’s password:
Retrieving repository ‘packman’ metadata …[done]
Building repository ‘packman’ cache …[done]
Loading repository data…
Reading installed packages…
‘deepin-music-player’ is already installed.
No update candidate for ‘deepin-music-player-2.0git20130802-1.2.noarch’. The highest available version is already installed.
Resolving package dependencies…

Nothing to do.

Why this repo for 13.2?
This contains python stuff that’s incompatible with your system.
Change the URL from openSUSE_13.2 to openSUSE_13.1 or remove it completely (in YaST->Software Repositories e.g.), and probably enable “Auto-Refresh” as well if you keep it.
I guess you only added that repo for installing deepin-media-player, right?

And why are you saying “13.2” in the subject? You’re obviously using 13.1.

output for rpm -qa deepin*:

valentinousn@linux-ln38:~> rpm -aq deepin*
deepin-utils-0.0.1git20130724-2.1.3.i586
deepin-media-player-lang-2.0git20140428-2.1.noarch
deepin-gsettings-0.1git20130318-2.1.1.i586
deepin-music-player-2.0git20130802-1.2.noarch
deepin-ui-2.0git20140507-1.1.noarch
deepin-music-player-lang-2.0git20130802-1.2.noarch
deepin-media-player-2.0git20140428-2.1.noarch

Thanks again!!

You have a mixture here.
You have deepin-music-player installed, and deepin-media-player (where did you get that from? I see it in that home:Reki repo, but that’s an older version) but in different versions.
In particular you have deepin-ui in version 2.0git20140507 (matching deepin-media-player), whereas deepin-music-player is version 2.0git20130802, that’s why deepin-music-player doesn’t work I suppose.
“sudo zypper in -f --from 2 deepin-ui” should fix that.
And you should uninstall that version of deepin-media-player, as it probably won’t work afterwards anyway.

You could install again that version from home:Reki (for 13.1!). It might work, especially if you also switch the other deepin-* packages to that repo.
(“sudo zypper dup --from 7”)

And why are you saying “13.2” in the subject? You’re obviously using 13.1. = No I’m actually using 13.2 because I installed it from via an ISO image that I burned onto a DVD…

sudo zypper in -f --from 2 deepin-ui = ran this and now Deepin runs…

sudo zypper dup --from 7 = ran this command and got the following output:

valentinousn@linux-ln38:~> sudo zypper dup --from 7
Loading repository data…
Reading installed packages…
Computing distribution upgrade…
4 Problems:
Problem: nothing provides libsystemd.so.0 needed by openvpn-2.3.6-104.1.i586
Problem: deepin-music-player-lang-2.0git20130802-1.2.noarch requires deepin-music-player = 2.0git20130802, but this requirement cannot be provided
Problem: deepin-media-player-lang-2.0git20140428-2.1.noarch requires deepin-media-player = 2.0git20140428, but this requirement cannot be provided
Problem: deepin-music-player-2.0git20130802-1.2.noarch requires deepin-ui >= 2.0git20130724, but this requirement cannot be provided

Problem: nothing provides libsystemd.so.0 needed by openvpn-2.3.6-104.1.i586

Solution 1: Following actions will be done:
deinstallation of openvpn-2.3.2-3.4.1.i586
deinstallation of NetworkManager-openvpn-0.9.8.4-1.3.i586
deinstallation of NetworkManager-openvpn-gnome-0.9.8.4-1.3.i586

Solution 2: keep obsolete openvpn-2.3.2-3.4.1.i586

Solution 3: break openvpn-2.3.6-104.1.i586 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): c

so I canceled out of it since I didn’t want NetworkManager or openvpn to be affected in any way since it’s not related to the problem…Deepin now loads from the command line so I guess I’m good to go now…thanks for your assistance!! Greatly appreciated!!

???
But you only have repos for 13.1 configured. If you installed from a 13.2 DVD, you should have the 13.2 repos.
If you really installed 13.2 and use the 13.1 repos, it’s clear that you get problems.

Please post the output of “cat /etc/os-release”, to verify whether you use 13.1 or 13.2 now.

If you are in fact using 13.2 (or want to use it), replace all occurences of “openSUSE_13.1” with “openSUSE_13.2” in your repos’ URLs, and run “zypper dup” afterwards to make sure your system is fully updated.
A simple way to change all URLs at once is to run this:

sudo sed -i 's/13\.1/13.2/g' /etc/zypp/repos.d/*

sudo zypper in -f --from 2 deepin-ui = ran this and now Deepin runs…

Good. You are using the version included in openSUSE 13.1 now.

sudo zypper dup --from 7 = ran this command and got the following output:

valentinousn@linux-ln38:~> sudo zypper dup --from 7
Loading repository data…
Reading installed packages…
Computing distribution upgrade…
4 Problems:
Problem: nothing provides libsystemd.so.0 needed by openvpn-2.3.6-104.1.i586
Problem: deepin-music-player-lang-2.0git20130802-1.2.noarch requires deepin-music-player = 2.0git20130802, but this requirement cannot be provided
Problem: deepin-media-player-lang-2.0git20140428-2.1.noarch requires deepin-media-player = 2.0git20140428, but this requirement cannot be provided
Problem: deepin-music-player-2.0git20130802-1.2.noarch requires deepin-ui >= 2.0git20130724, but this requirement cannot be provided

Problem: nothing provides libsystemd.so.0 needed by openvpn-2.3.6-104.1.i586

This is probably caused by the fact that you now try to install an openvpn (from home:Reki) built for 13.2 on your 13.1 system.
I told you to modify the repo’s URL to 13.1 before… :wink:

Anyway, if you change all your repos to 13.2, the 13.2 home:Reki repo should be fine as well. But if you only added it for deepin-music-player, I’d rather recommend to remove it again (before running “zypper dup”).