Debugging flatpak crashes whole graphical session

Hi, it’s me again.
Last time I posted a message asking for help after updating/installing the whole KDE Pattern to change from using Gnome to KDE Plasma and that it somehow broke DRI/Mesa on my Intel Arc system.

I come to you because VLC Flatpak crashes after 5 seconds of opening no matter what. Packman VLC works fine but I can’t make it open a Bluray disc. Before changing to Gnome, VLC Flatpak worked fine with the makemkv integration on Flatpak when opening Blurays. When I run a Plasma session, VLC crashes both in Wayland and X11. But the strangest part is that when I followed the instructions to debug the flatpak, my system crashed spectacularly.

First I tried running a shell inside a sandbox as instructed by the Flatpak debugging documentation. That failed because apparently I was missing the runtime SDK, so I installed that runtime SDK and tried again and the shell opened and then konsole stopped echoing my kestrokes. Then when I tried finding the route to the VLC flatpak to invoke it with gdb, konsole froze and after a minute or so, the whole user interface turned grey and froze itself. I tried then changing into TTY1 but I got no response for about a minute and suddenly it went into it, but I couldn’t get into TTY7 to reload the graphical session so I tried logging into my account on TTY1 but it took a very long time for keystrokes to register, like 2 minutes from inputting my username and another 2 minutes to input my password. Then it took about 5 minutes for the virtual terminal to respond and execute a systemctl reboot.

I don’t know if I did the correct steps, I’m not an experienced linux user, but that’s how I got back.
After that I opened a Gnome session and VLC doesn’t crash there. I couldn’t load the Bluray either but it appears to be an aacs issue witht he disc, but on the Plasma session I can’t even get VLC to output a loading error, it crashes before it gets to trying to load a disc.

Thank you for your time.