deb crash

I downloaded a deb package and made, “alien -r -c xxxx.deb” to make a rpm package. Then I tried to install it, but the installation hanged, and now my opensuse 13.1 doesn’t starts. It begins loading but after a while, X dont load and it returns a system prompt, but I can not make login whit any user.

Sorry for my poor english, and thank you

What kind of package was this?

Do you get a graphical system when booting to “Recovery Mode”? (in “Advanced Options” in the boot menu)

Can you login in text mode? (try as root if your user does not work)

On 2014-07-17 23:46, indibil201 wrote:
>
> I downloaded a deb package

which one, exactly?


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

It was google-chrome the deb package. When I enter in rescue option fron dvd, I dont get graphical interface. I can make login with root user

On 2014-07-18 00:26, indibil201 wrote:
>
> It was google-chrome the deb package. When I enter in rescue option fron
> dvd, I dont get graphical interface. I can make login with root user

Use the google-chrome rpm instead. Why are you using a deb package, when google makes an rpm? And there is a repo.


zypper ar --refresh -f "http://dl.google.com/linux/chrome/rpm/stable/x86_64" "google-chrome"


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

I used a deb package because google chrome rpm is version 35 and it does not java support. I tried to downgrade to version 34, wich has java support, but I did not find an rpm package with this version

Can you login as user or not?

What happens when you login as root and run “startx”, do you get a graphical session then?
If not, please post the error messages you get.

The thing is, installing a package can do anything to your system, so it’s hard to guess what your problem is now.

Regarding chrome, you could use chromium instead.
Version 34 is still available in the update repo. Unfortunately Packman doesn’t provide chromium-ffmpeg v34 anymore though.

If I boot from hard disk I can not make login with any user, including failsafe mode. If I boot from rescue mode from dvd, i make login with root, and I can mount my partitions but I dont know how to fix my problem

Not even root?
But you said you could login as root.

If I boot from rescue mode from dvd, i make login with root, and I can mount my partitions but I dont know how to fix my problem

Of course you can login when booting from the DVD, but you’re not logging in to your installed system then.
And the DVD doesn’t allow to boot to a graphical system, only the LiveCD would. But that won’t help you either.

I don’t know (yet) how to fix your problem either, because I don’t know what’s wrong.
And your answers just confused me up to now.

So when you boot from your hard disk, do you get a login prompt in text mode?
Can you login there? Either as user or root? (apparently not if I understand you correctly)
Do you get any error messages?

If you do not even get a text mode login prompt, please press ESC and see if there are any messages.

And try to press Ctrl+Alt+F2. Do you get a login prompt then? Can you login there?

The easiest way to fix your system might be a reinstall though.
You could of course boot from the Installation DVD and choose “Choose to upgrade an existing system”, that might fix it already, and should leave your system as it is otherwise.

Sorry if I confused you with my answers, but it is hard to me to write in english. When I boot from hard disk I get a prompt in text mode, but no login from here, neither as root nor any user.

If I boot from dvd I can mount partitions and I see /etc/passsword file. It seems to be ok, but I can not login in my system, when I boot from hard disk

And what error message do you get when you try to login?

If I boot from dvd I can mount partitions and I see /etc/passsword file. It seems to be ok, but I can not login in my system, when I boot from hard disk

The actual passwords are stored in /etc/shadow.

Well, try this:
Press ‘e’ at the boot menu, search for a line starting with “linux” and append “init=/bin/sh” at the end. Then press ‘F10’ to boot.
(note that this only applies to grub2, if you are using grub1 just enter “init=/bin/sh” at the options line in the boot menu)

You should get into a minimal text mode system then without having to enter a password.
Try to change root’s password by running “passwd”.
Then reboot, and try to login as root again. Does it work then?

And please, if you get any error messages, post them.

The error message is password “login incorrect”.

I made what you said. I entered minimal system. I changed the root password, an I got the message “pasword updated successfully”. I rebooted but I still have the same problem, no login with any user, “login incorrect”.

So the files themselves seem to be ok.
Maybe a file permission issue then?

Try to boot to the minimal text system as before, and run “chkstat --system”.

There hopefully should be messages that files permissions were successfully changed.
If there are errors, you should post them.
I know this will prove to be difficult, but maybe take a picture with a digital camera and post that.

I made “chkstat --system”, and I got “setting / to root:root 0755. (wrong permissions 0700)”

It worked!!! I reboot and now I entered the graphical interface with my user.

Thanks a lot, really. I would invite you to some beers, but I think there are a lot of miles between us. Thank you very very much

So non-root users were not allowed to access / at all, probably your package has changed that.

Good to here it’s fixed now though! :slight_smile: