Deadbeef

Have you got a DAC capable of 24bit playback then I couldn’t recommend this app enough! I was searching for such a beast recently and came across it in, of all places, an Ubuntu forum and had to investigate further. I noticed it was in the repositories so initially tried that (I have openSUSE Tumbleweed) but it would play. So I bit the bullet and downloaded the tar file from Deadbeef.

I must stress it is really important to read the README file before doing anything. Also when you first run ./configure check that the pluggins that you need will be installed will be (explained in the README). There were many I needed including flac (my library is almost entirely flac!) so you will need to install those including any appropriate libs and devs. Rerun ./configure until all is good to go.

The sound through my M-audio 24/96 Audiophile card is so much improved! The app allows you to upsample 8 to 16bit and 16 to 32bit. Okay it isn’t as fancy as Amarok (I’m a KDE fan) but the sound more than makes up for it. :wink:

I used it for a while, while on Xfce. It was great, no gnome or kde deps, worked great, pleasure to use :slight_smile:

There is a packaged version of Deadbeef: http://software.opensuse.org/package/deadbeef

I used this to begin with but it didn’t work for me. Maybe because I’m using Tumbleweed?? Just checked that link and Tumbleweed version is unstable :frowning:

Yes I’m really enjoying it :slight_smile:

On Fri, 28 Mar 2014 19:06:01 +0000, Penguinclaw wrote:

> Subject: Deadbeef

Completely unrelated (but this is general-chit-chat, so thread drift
happens :wink: ) - but this reminds me a lot of my days running NetWare
servers.

A popular internal IPX network address for servers (though only once per
network) was DEADBEEF - 8 digit base 16 numbers were used for IPX network
addresses.

Turned up a lot in books and training materials I saw, too. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

A colleague installed a packaged Deadbeef from that link on their openSUSE-12.3 openSUSE (possibly a different repos thou) and it worked ok.

That doesn’t mean much, although in your case it failed. The only “stable” versions are usually those built for official openSUSE releases and therefore spent time in Factory and Milestone testing. “Unstable” i.e. newer versions of those and other packages built on OBS for official releases, may also get built for other project releases such as Tumbleweed, in all cases having received little or no user testing there.

A clean build (no errors) on OBS doesn’t mean the application has been tested by the packager or any user on a particular release, so it may fail even on start up.

BTW newer versions actually from the Tumbleweed maintained repo are for packages that must have been available in Factory.

Tumbleweed here, installed the package from software.opensuse.org (the catch repo), works flawlessly.

What is a “catch repo” - the outcome of a fishing trip or a hidden agenda maybe? Not seen that term before. :slight_smile:

Well that’s odd! Oh well I got it working anyway but thanks for the info.