Dead network card? How do you tell?

I have an integrated Realtek network card which I use to connect with a crossover cable to another computer. It has worked fine, I got it to work in OpenSuse 11.4 and was going through the steps to configure Samba in 12.1 when I couldn’t connect. I don’t connect very often, and I noticed that the back of the network cable had a slowly blinking orange light. Normally it has a green light on. I connected a laptop to the windows computer and it’s lights appeared normal, but when I connected it back to the 12.1 computer, it’s either completely off or slowly blinking orange.

I have multiple partitions and when I boot back to 11.2 or 11.4, it still only slowly blinks orange and no longer connects. The windows computer says a network cable is unplugged. I would guess something’s wrong with the card, but is there some way to confirm these suspicions? If it’s bad, is it possible something I did with setting up the software or just a coincidence?

The system looks like to me it sees the card.

hwinfo --netcard
32: PCI 200.0: 0200 Ethernet controller                         
  [Created at pci.319]
  Unique ID: rBUF.7jPWmoeCYd4
  Parent ID: bSAa.VBWPJFOQrE4
  SysFS ID: /devices/pci0000:00/0000:00:0a.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller"
  Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
  Device: pci 0x8168 "RTL8111/8168B PCI Express Gigabit Ethernet controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x83a3 
  Revision: 0x03
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  I/O Ports: 0xd800-0xd8ff (rw)
  Memory Range: 0xfdfff000-0xfdffffff (ro,non-prefetchable)
  Memory Range: 0xfdff8000-0xfdffbfff (ro,non-prefetchable)
  Memory Range: 0xfeaf0000-0xfeafffff (ro,non-prefetchable,disabled)
  IRQ: 42 (no events)
  HW Address: 00:26:18:d7:5a:fb
  Link detected: no
  Module Alias: "pci:v000010ECd00008168sv00001043sd000083A3bc02sc00i00"
  Driver Info #0:
    Driver Status: r8169 is active
    Driver Activation Cmd: "modprobe r8169"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

and part of /sbin/lspci -nnkv

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
        Subsystem: ASUSTeK Computer Inc. M4A785TD Motherboard [1043:83a3]
        Flags: bus master, fast devsel, latency 0, IRQ 42
        I/O ports at d800 [size=256]
        Memory at fdfff000 (64-bit, prefetchable) [size=4]
        Memory at fdff8000 (64-bit, prefetchable) [size=16]
        Expansion ROM at feaf0000 [disabled] [size=64]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Endpoint, MSI 01
        Capabilities: [ac] MSI-X: Enable- Count=4 Masked-
        Capabilities: [cc] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
        Kernel driver in use: r8169


Link detected: no

You’ve ruled out the cable I suppose? Looks dead. Give it a decent burial.

On 2011-12-29 01:26, dt30 wrote:
> I would guess something’s
> wrong with the card, but is there some way to confirm these suspicions?

Try another cable that is known to work.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I just had an onboard realtek nic go… they just go, but…
You could download a LiveCD/DVD of either openSuSE or one that is small and has found Every NIC i’ve tried it on is Linux-Mint. Burn ISO to DVD and boot. If it sees, detects your network, it’s not the nic.
Also, if when you unplug the cable the light color and blink rate does not change, it’s the card.
One more, At boot what is the color and blink rate of the nic?


Link detected: no

I ran that when the other computer was not turned on, but it may have been the same.

The cable works as it works with the windows computer and the laptop and with the laptop and a printer.
It’s not my installation of 12.1 as I have not changed 11.2 and 11.4 and they were working but not now.
I seem to recall the blink rate was the same slow blinking whether connected or not.
I can’t test it now as there are no lights whatsoever on the card whether it’s connected to the other computer or not.

Guess it’s dead.

I hope this is limited to the card and not something that is progressing throughout my motherboard? Any thoughts as to whether it’s possible to ruin hardware by setting software up incorrectly using the system provided software?

In this case it appears the transceiver chip is dead even though the controller is functional. These things die of their own volition or get zapped by electrical spikes. I don’t think it’s anything you did.

Shut the machine down and physically disconnect it from the mains power for a minute or so. If it is a laptop, remove the battery. This is the only simple, foolproof way to reset the hardware.

You can always disable the ethernet in BIOS and use an add-in card or usb to ethernet device.

Thank you, thank you, thank you so much! I had put a little effort into looking for a network card, but was surprised that I had not yet found any for sale at local stores. I kept trying to remember to turn the power completely off, but didn’t want to reboot when I thought about it and never remembered when I shut the system down. Last night, I remembered and flipped the switch in the back which disconnects all power. Confirmed by my numlock light going off. Now, when I booted up, the network light came on and remained on steady, I turned the windows computer on and it said connected, and each one was able to see the other. Who knows, there might be other issues with it, but disconnecting did make a change for now.

I don’t believe I’ve ever seen anything like this. I’ve had problems with my internal modem getting locked up and found rebooting didn’t not always cure it but had to power the system down and back up. That little bit of vampire power must maintain the network state of the card even though I’ve powered down my system every day. A complete disconnect must be required. I learn something every day! Something I will remember for the future.