Dead keys on LibreOffice

I’m having an issue on LibreOffice 4.1.5.3 OpenSuse 13.1 x86_64.
Whe i create a new document I can use dead keys in a normal way, for instance:


   Áéíóúñü

Then If i save the doceument, open it again and continue writing, deadkeys donn’t work (second line, typing the same as first line)


   Áéíóúñü

 aeiouñu
 

I’ve read It might be something about locales but I cna’t find what.

In any other app, deadkeys work fine (for instance thunderbird, firefox, kwrite, konsole, etc.)

any help?

regards

You do not describe what you use to get “dead keys”.

I use Shift-RightCtl as compose key and then e.g. " e to get ë.
That works everywhere IMHO, thus also in LibreOffice Writer. And when I save such a LO document and reopen it, it still works.

I’m using ’ (acute) and then a to write á or " (diaeresis) and then u to write ü.
Ii has been working well for me ever since but LO stopped working (It crashed on opening) then I reinstalled it and now It works but with this strange behaviour.

You then have different keyboard settings from what I have (English/US if I am correct, in mine there are no “dead keys” by definition, they only become "dead on the “Compose” combination). Sorry, but I can not recreate your problem.

As you are using some KDE programs, I assume you are using the KDE desktop which, under System Settings>Input methods>Keyboard>Layouts, enables you to select different keyboard layouts, some of which use dead keys and others of which do not.

The LibreOffice help, under ‘Compose key,’ says:

Linux / NetBSD: Using the dead-keys. In an xterm windowfirst press the (´) or (`) key. The character should not appear onthe screen. Now press a letter, such as “e”. The e is givenan accent, é or è. If not, then check in the XF86Config file if a"nodeadkeys" XkbdVariant has been loaded there and replaceit. You may also have set the environment variable SAL_NO_DEADKEYS,which deactivates the dead-keys.

All Unix systems: (Alt Graph) as additional compose key.The (Alt Graph) key can work in LibreOffice like the Compose key, ifyou set the environment variable SAL_ALTGR_COMPOSE. The (Alt Graph)key must trigger a mode_switch, so, for example, xmodmap -e “keysymAlt_R = Mode_switch” must be set. First press (Alt Graph), thenthe first modifier, then the second modifier. The characters arecombined as described on a Solaris system in the file/usr/openwin/include/X11/Suncompose.h.

Yes, I’m using spanish layout.
I think I’ve found the problem (or the solution). Tools-Settings-Save/load-HTML-Character set is set to ISO8859-15. I thought this setting was only for HTML saving but it seems it isn’t. If I change it to UTF-8 and I save the doc and I open it again I can type áéíóúü again.

regards

On 2014-05-05 00:46, fperal wrote:

> Yes, I’m using spanish layout.

Like me.

> I think I’ve found the problem (or the solution).
> Tools-Settings-Save/load-HTML-Character set is set to ISO8859-15. I
> thought this setting was only for HTML saving but it seems it isn’t. If
> I change it to UTF-8 and I save the doc and I open it again I can type
> áéíóúü again.

openSUSE has been using UTF-8 for several years. It is possible that if
you choose ISO8859-15 things fail.

But then, html settings should not affect other type of documents…


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Like Carlos, I do not completely understand the connection, but when it works, that is fine. In any case, I would never encourage using anything other then UTF-8 encoded Unicode.

Neither did I and I’ve just found It has nothing to do with the HTML settings, It was just coincidence.
Now I have UTF-8 set in HTML settings and still having the same problem, but I’ve found that If a close the document and open It again, dead keys work… for a while, then stop working, then I close the doc and open it again and dead keys working again :dont-know:

That is strange indeed. I am afraid the only thing I can advise is trying to understand what happened shortly before it changes. Maybe after some time you get some feeling of a pattern.

Hm. not the nicest kinds of problem :frowning:

I’ve continue testing, I’ve been measuring time to see if it might be the time of auto-save or something similar and I’ve found that It’s not a matter of time either.
If I’m working in the LO document It works fine, but if then I click (just click) into any other application I have opened (Kwrite, konsole, the message edditing window of this forum on firefox…) and then return to the LO document, dead keys have stopped working. (until I save the document, close it and open it again)

On 2014-05-06 11:16, fperal wrote:
>
> I’ve continue testing, I’ve been measuring time to see if it might be
> the time of auto-save or something similar and I’ve found that It’s not
> a matter of time either.
> If I’m working in the LO document It works fine, but if then I click
> (just click) into any other application I have opened (Kwrite, konsole,
> the message edditing window of this forum on firefox…) and then
> return to the LO document, dead keys have stopped working. (until I
> save the document, close it and open it again)

Did you configure the keyboard globally, in YaST, or on your desktop?

I’d recommend to configure the keyboard in YaST, and leave KDE to use
the system keyboard, unchanged.

Then you might be using SCIM, if I got the name right. I think you get a
applet in the panel - huh, I’m not that familiar with KDE, so I don’t
know where exactly. There were some compatibility problems between
LibreOffice KDE customization and SCIM, and one of then had to be
removed during installation. This should have been solved by an update,
IIRC.

On the other hand, SCIM is not needed for Spanish, only for some (all?)
non Latin alphabet languages: perhaps Arabic, Chinese, etc. I simply
removed it.

If none of that helps, I would try creating a new user and try
reproducing the problem there, without doing any KDE configuration
changes at all.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

In yast

http://susepaste.org/62971638

And in KDE settings locales: Country=System country(Spain)

Then you might be using SCIM, if I got the name right. I think you get a
applet in the panel - huh, I’m not that familiar with KDE, so I don’t
know where exactly. There were some compatibility problems between
LibreOffice KDE customization and SCIM, and one of then had to be
removed during installation. This should have been solved by an update,
IIRC.

On the other hand, SCIM is not needed for Spanish, only for some (all?)
non Latin alphabet languages: perhaps Arabic, Chinese, etc. I simply
removed it.

I don’t have any SCIM package installed

If none of that helps, I would try creating a new user and try
reproducing the problem there, without doing any KDE configuration
changes at all.

Brand new user created. Same problem: new LO document, I can’t write àèìòù (it writes aeiou), I save the doc, I open it again, I can write now áéíóú. I click on an konsole windows I’ have previously openend, then I return to the document, i cant write áéíóú.
I open it with Apache OpenOffice 4.0.1… It works fine.

On 2014-05-06 16:36, fperal wrote:
>
> robin_listas;2641527 Wrote:
>> On 2014-05-06 11:16, fperal wrote:
>>
>>
>> Did you configure the keyboard globally, in YaST, or on your desktop?
>>
>> I’d recommend to configure the keyboard in YaST, and leave KDE to use
>> the system keyboard, unchanged.

> In yast
>
> [image: http://susepaste.org/62971638]
>
> And in KDE settings locales: Country=System country(Spain)

No, that’s language, not keyboard. I mean here:

YaST → Hardware → System Keyboard Layout

or

YaST → Hardware → Disposición del teclado del sistema

> I don’t have any SCIM package installed

Are you sure? It is installed by default. The actual package name is
lowercase “scim”.

>> If none of that helps, I would try creating a new user and try
>> reproducing the problem there, without doing any KDE configuration
>> changes at all.
>>
>
>
> Brand new user created. Same problem: new LO document, I can’t write
> àèìòù (it writes aeiou), I save the doc, I open it again, I can
> write now áéíóú. I click on an konsole windows I’ have previously
> openend, then I return to the document, i cant write áéíóú.
> I open it with Apache OpenOffice 4.0.1… It works fine.

You have both installed? I don’t know if they conflict. I assume that
the LO package is the official openSUSE one, via YaST?

Ok, another idea.

On that new user, change the KDE language to English. Then try again
with Libreoffice… the keyboard should still be the system one,
Spanish. That’s how I use it.

The idea is to test whether it is the Spanish customization of LO that
is bad. I don’t use it, so I don’t know.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

I’d also try removing the libreoffice-kde4 integration package.


fernando@andromeda:~> rpm -qa |grep scim
fernando@andromeda:~> 

> I open it with Apache OpenOffice 4.0.1… It works fine.

You have both installed? I don’t know if they conflict. I assume that
the LO package is the official openSUSE one, via YaST?

Apache Openoffice is installed from rpms but it installs in /opt and zypper didn’t complained when installing.
I have both because some weeks ago LO stop working (I tried to open it and it crashed) then I tested both the one from the suse repo and the one from the libreoffice repo, none of them worked and then I installed OO.

Ok, another idea.

On that new user, change the KDE language to English. Then try again
with Libreoffice… the keyboard should still be the system one,
Spanish. That’s how I use it.

The idea is to test whether it is the Spanish customization of LO that
is bad. I don’t use it, so I don’t know.

Didn’t work either.

regards

Didn’t work either.

regards

On 2014-05-07 11:06, fperal wrote:

>> Are you sure? It is installed by default. The actual package name is
>> lowercase “scim”.
>>

> Code:
> --------------------
>
> fernando@andromeda:~> rpm -qa |grep scim
> fernando@andromeda:~>
>
> --------------------

Curious :slight_smile:

>> You have both installed? I don’t know if they conflict. I assume that
>> the LO package is the official openSUSE one, via YaST?
>>
>
> Apache Openoffice is installed from rpms but it installs in /opt and
> zypper didn’t complained when installing.
> I have both because some weeks ago LO stop working (I tried to open it
> and it crashed) then I tested both the one from the suse repo and the
> one from the libreoffice repo, none of them worked and then I installed
> OO.

LO stopped working? Now that’s strange. You may have more issues than
dead keys, then.

You could post your “zypper lr --details” list… (in a code tags
section, please).

>> The idea is to test whether it is the Spanish customization of LO that
>> is bad. I don’t use it, so I don’t know.
>>
>
> Didn’t work either.

:frowning:

Can you try another desktop? Whichever you like. XFCE, LXDE, Gnome…
For testing. You may even have a failsafe one installed already, I
forget the name.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)


fernando@andromeda:~> LANG=C zypper lr --details
#  | Alias                             | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                                | Service
---+-----------------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
 1 | Application:Geo                   | Application:Geo                    | Yes     | Yes     |  103     | rpm-md | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_13.1/          |        
 2 | CrossToolchain:avr                | CrossToolchain:avr                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/CrossToolchain:/avr/openSUSE_13.1/       |        
 3 | GNOME:Apps                        | GNOME:Apps                         | Yes     | Yes     |  101     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_13.1/               |        
 4 | Google-Chrome                     | Google-Chrome                      | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                |        
 5 | Graphics                          | Graphics                           | Yes     | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_13.1/                  |        
 6 | LibreOffice                       | LibreOffice                        | No      | No      |   94     | rpm-md | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_13.1/       |        
 7 | Packman Repository                | Packman Repository                 | Yes     | Yes     |   95     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/                           |        
 8 | VLC                               | VLC                                | Yes     | Yes     |   97     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/13.1                                     |        
 9 | hamradio                          | hamradio                           | Yes     | Yes     |  101     | rpm-md | http://download.opensuse.org/repositories/hamradio/openSUSE_13.1/                  |        
10 | home:illuusio:gscan2pdf           | home:illuusio:gscan2pdf            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/illuusio:/gscan2pdf/openSUSE_13.1/ |        
11 | java                              | java                               | Yes     | Yes     |   97     | rpm-md | http://download.opensuse.org/repositories/Java:/packages/openSUSE_13.1/            |        
12 | libdvdcss repository              | libdvdcss repository               | Yes     | Yes     |   96     | rpm-md | http://opensuse-guide.org/repo/13.1/                                               |        
13 | multimedia                        | multimedia apps                    | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_13.1           |        
14 | multimedia_libs                   | multimedia libs                    | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_13.1/          |        
15 | nVidia Graphics Drivers           | nVidia Graphics Drivers            | Yes     | Yes     |   94     | rpm-md | http://download.nvidia.com/opensuse/13.1/                                          |        
16 | openSUSE BuildService - Education | openSUSE BuildService - Education  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_13.1/                 |        
17 | perl                              | perl                               | Yes     | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_13.1/    |        
18 | repo-debug                        | openSUSE-13.1-Debug                | No      | No      |  120     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/                     |        
19 | repo-debug-update                 | openSUSE-13.1-Update-Debug         | No      | No      |  120     | NONE   | http://download.opensuse.org/debug/update/13.1/                                    |        
20 | repo-debug-update-non-oss         | openSUSE-13.1-Update-Debug-Non-Oss | No      | No      |  120     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                            |        
21 | repo-non-oss                      | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                       |        
22 | repo-oss                          | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                           |        
23 | repo-source                       | openSUSE-13.1-Source               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/                    |        
24 | repo-update                       | openSUSE-13.1-Update               | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/update/13.1/                                          |        
25 | repo-update-non-oss               | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   98     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                                  |        
26 | science                           | science                            | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_13.1/                   |        
fernando@andromeda:~> 


Can you try another desktop? Whichever you like. XFCE, LXDE, Gnome…
For testing. You may even have a failsafe one installed already, I
forget the name.

With IceWM (with the new user)

Using LO: áéíóú
click on a Xterm window, then returning to LO -> aeiou
>:(

On 2014-05-07 23:46, fperal wrote:
>
> robin_listas;2641794 Wrote:

>> You could post your “zypper lr --details” list… (in a code tags
>> section, please).

You have at least one issue.

Let me see. You have both packman and videolan repos, and they conflict
easily. I would use one or the other, not both.

You may, for instance, install VLC from videolan, and say, mplayer, from
packman. But if you mix libraries from both sides, you get problems.

It may have nothing to do with your issue, but we don’t know what is the
cause of your issue, so lets try things.

Then I would at least disable some of the repos you have, where I
suppose you get recent versions from packages, and go back to the
original versions:

Leave only:

nvidia
oss, non-oss
repo-update
repo-update-non-os

Then do a “zypper dup” to replace everything. Then you can add again:

packman, libdvdcss

and add the multimedia packages following the guide here.

I know it is a brutal approach, but I can not think of anything else.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)