ddclient says it's failing

I enabled ddclient today, to update my ddns on freedns.afraid.org. I
have to use ddclient or some other application on my pc and cannot use
ddns on my router, because my router’s built in ddns is pre-set to
dynDNS.org or TZO, and it doesn’t allow any other hosting.

I was in a konsole later and it said I had new system mail, so I opened
it up. Here is what the contents of one of them was (sanitized):


From root@tribaltrekker.site  Tue Aug 27 19:57:55 2013
Return-Path: <root@tribaltrekker.site>
X-Original-To: root
Delivered-To: root@tribaltrekker.site
Received: by tribaltrekker.site (Postfix, from userid 0)
id 668E665F85; Tue, 27 Aug 2013 19:57:55 +0800 (PHT)
To: root@tribaltrekker.site
Subject: status report from ddclient@tribaltrekker.site
Message-Id: <20130827115755.668E665F85@tribaltrekker.site>
Date: Tue, 27 Aug 2013 19:57:55 +0800 (PHT)
From: root@tribaltrekker.site (root)


WARNING:  file /var/cache/ddclient/ddclient.cache, line 3: Invalid Value
for keyword 'ip' = ''
WARNING:  SENT:
https://freedns.afraid.org/dynamic/update.php?MmNWYUQ2eDhrTUU1cDdYOFd4Zkk6MTAwMzA3MDU=
WARNING:  REPLIED: HTTP/1.1 200 OK
WARNING:   Server: nginx
WARNING:   Date: Tue, 27 Aug 2013 11:58:10 GMT
WARNING:   Content-Type: text/plain
WARNING:   Content-Length: 47
WARNING:   Connection: close
WARNING:   Vary: Accept-Encoding
WARNING:
WARNING:   ERROR: Address xxx.xxx.xxx.61 has not changed.
FAILED:   updating xxxxxxxx.xxxxxxxx.com: Invalid reply.


regards,
ddclient@tribaltrekker.site (version 3.8.1)

I have been getting this system mail every 5 minutes because I have the
timer set in /etc/ddclient.conf to 5 minutes. However, when I did look
at my my IP address on my router, which did change, my subdomain that I
chose on freedns had also updated correctly. So it tells me it is not
updating, but apparently it is? Or is it telling me something else?

In any case, some googling pointed that this could be an error in a perl
library for SSL. So just to check I tried setting the ssl=no parameter
in /etc/ddclient.conf, but I am still getting the error. So I set it
back to ssl=yes. So I don’t know if this has anything to do with SSL.

I checked, and the version of the perl library that I have is:


# rpm -qa | grep perl | grep SSL
perl-IO-Socket-SSL-1.55-4.1.1.noarch

The file that supposedly has the error is as follows:


/var/cache/ddclient # cat ddclient.cache
## ddclient-3.8.1
## last updated at Tue Aug 27 20:23:06 2013 (1377606186)
atime=1377606186,host=xxxxxxxx.xxxxxxxx.com,ip=,mtime=0,status=failed,warned-min-error-interval=0,warned-min-interval=0,wtime=0
xxxxxxxx.xxxxxxxx.com

One other question - I saw that some people that had a similar error in
the past said it caused their hosting service to block them because it
was updating all the time. Isn’t ddclient supposed to be checking all
the time anyway? I have it set for every 5 minutes. Why would a hosting
service like dynDNS or freedns.afraid.org block someone if their pc had
some kind of internal error when it went to update the ip on their
subdomain?

What I am really wondering on that is if I should disable this service
altogether when I am not using it, so as not to cause problems for the
hosting company. I don’t know enough about how this works to know the
answers to that.

Any help would be great!


G.O.
Box #1: 12.3 | KDE 4.10 | AMD Phenom IIX4 | 64 | 16GB
Box #2: 12.2 | KDE 4.9.2 | AMD Athlon X3 | 64 | 4GB
Laptop: 12.3 | KDE 4.10 | Core i7-2620M | 64 | 8GB

So I also don’t know how ddclient works exactly but here are my thoughts :

-what I read from the log is that the update fails because the IP has not changed
-are you sure you’re getting this email every 5 minutes ? I would assume it was successful at least once and then it will fail every 5 minutes until the IP changes and will need to be updated
-the way I understand it is that if you disable the service than when the IP changes you’re router will not be notified and it will not do what I think you want to achieve
-I also don’t see a reason why would this be a problem for the ISP or why would freeDNS block those requests unless they are very frequent
-ddclient seems to be not to well integrated with systemd but I don’t think it should create any problems :

asus:~ # systemctl disable ddclient.service
ddclient.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig ddclient off

-it seems you can disable the emails by commenting the last line below :

######################################################################
# daemon: consider to use /etc/sysconfig/ddclient instead of modifying here
#
daemon=300                              # check every 300 seconds
#
######################################################################
syslog=yes                              # log update msgs to syslog
#mail=root                              # mail all msgs to root
mail-failure=root                       # mail failed update msgs to root

-it seems you might want to do the changes in “/etc/sysconfig/ddclient” as described in “/etc/ddclient.conf”

Thanks for that, I see your point there. I will disable the mail-failure command and see how it goes.

I am out of town at the moment and unable to make the changes, but when I get back into town at the end of next week I will try that and see how it goes.

I am glad you think it should not be a problem with freedns.afraid.org. I was concerned that might be a problem because I had seen similar posts on other forums with people that had experienced this problem with ddclient.

You’re most welcome. Please let me know how it goes. Also please keep in mind that I’m no expert on ddclient but there is still a chance that some ddclient expert will find this thread :slight_smile: