dbus errors kde 4.4.4

Updated to kde 4.4.4 last night and have dbus errors when knetworkmanager tries to start.

KNetworkManager cannot start because the installation is misconfigured.
System DBUS policy does not allow it to provide user settings;
contact your system administrator or distribution.
KNetworkManager will not start automatically in future.

I thought it was odd because I haven’t had issues with knetworkmanager in ages, so just to see if it was specific to my laptop I went ahead and upgraded my desktop.

I receive the same error on both machines now, and have had to switch to wicd until the problem is fixed.

Shame that “bugfix” release brings in…bugs. :’(

Anyways, I have googled it to death and haven’t found anything that resolves it, so if anyone has an idea or a fix please do say so.

I helped a friend setup a KDE install and after updating got the same message. Check out this link from the mailing list:

[opensuse-kde] KKFD NetworkManager-kde4 broken on 11.2](http://lists.opensuse.org/opensuse-kde/2010-04/msg00223.html)

Save the file as NetworkManager-frontend.conf and copy it as root to /etc/dbus-1/system.d

KNetworkManager should be fixed after a reboot.

A quick note: there’s a check-box in the KNetworkManager settings under the Other tab to show tray icon. My friend’s was unchecked after update, yours may be as well.

I had the same problem - that dbus related message is really scary. Anyway, I found the solution on ubuntu forum - place this file
drop.io knetworkmanager_opensuse11_2 (rename it toNetworkManager-kde4.conf) in /etc/dbus-1/system.d and start knetworkmanager

Thank You gentlemen. The file worked perfectly

Glad to hear it worked for you. :slight_smile:

Gentlemen - thank you very much :slight_smile:

No luck in my case :confused:
After copying one file, the other or both in /etc/dbus-1/system.d/ I’m able to “start” knetm but it just open that blue icon (is it an N & M) and not the signal status icon as always. In fact if I click on it, it says “network admin disabled” (actually mine is in spanish so just trying to translate it).

My network is working as I checked it by terminal.

The file is under root just like the others in there.

Sorry. I just forgot to set networkmanager instead of ifup back in yast.

Now it’s working like a charm :slight_smile:

It seems that the networkmanager update from this morning fixes this issue, and makes the file I posted obsolete.

Never applied the fix, file is there :). So it’s fixed in the repos.

Hi everybody, After upgrading to KDE4.4.4 using the KDE4 repositories, I had the same problem under openSuSE 11.1 64. I tried the solutions you provide and copied the NetworkManager-kde4.conf file to /etc/dbus-1/system.d/NetworkManager.conf (after backing up the original one).

Knetworkmanager started, but did nothing… just started with the NM blue icon in the tray. It says that there is no network… I checked in Yast to ensure that I didn’t misconfigure the use of networkmanager (I had to switch back to ifup to be able to send this post…)

Anyone has an idea ?

I just solved the case :

This is valid for openSuSE 11.1-64 :

I rolled back from the backup of NetworkManager.conf, and just created an additional config file named : NetworkManager-kde4.conf with the following content (This differs from the content of the link in the reply of dcengija)

<!DOCTYPE busconfig PUBLIC
“-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN”
<policy user=“root”>
<allow own=“org.freedesktop.NetworkManagerUserSettings”/>

            &lt;allow send_destination="org.freedesktop.NetworkManagerUserSettings"/&gt;
    &lt;policy at_console="true"&gt;                                                            
            &lt;allow own="org.freedesktop.NetworkManagerUserSettings"/&gt;                     
            &lt;allow send_destination="org.freedesktop.NetworkManagerUserSettings"/&gt;        
            &lt;!-- Only root can get secrets --&gt;                                            
            &lt;deny send_destination="org.freedesktop.NetworkManagerUserSettings"           
    &lt;policy context="default"&gt;                                                            
            &lt;deny send_destination="org.freedesktop.NetworkManagerUserSettings"/&gt;         
            &lt;allow send_destination="org.freedesktop.NetworkManagerUserSettings"          
    &lt;limit name="max_replies_per_connection"&gt;512&lt;/limit&gt;                                  


This content was provided by EricDavis in this post : knetwork cannot start…

After that just reboot your machine.


Your solution worked for me on openSuSE11.2-32.

On openSuSE11.2-64 it was not necessary. NetworkManger worked after a delete and re-install.

Thanks all. I just did the upgrade today via zypper, and it still broke. I got wireless back with ifup, but knetworkmanager is really simpler for my wife and kids, ao it was great to find this thread.

All the best.

  • T.

I had the same problem,
I switched back to D-Bus Message Bus Daemon 1.2.24 and everything works like a charm

On 01/04/2012 11:36 PM, dklovedoctor wrote:
> I had the same problem,

are you still using KDE 4.4.4 on openSUSE 11.2?

or, maybe you joined Evergreen once 11.2 went past end of life (and

openSUSE®, the “German Engineered Automobiles” of operating systems!