Dbus errors - DBus.Error.ServiceUnknown

I can’t run update.
yes I tried search, nothing seems to be my issues…

running yast update gives:

DBus error : Unable to get transaction id from packagekit.

trying to start /usr/sbin/PackageKit gives these errors:

libnm_glib_nm_state_cb: dbus returned an error.
(org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files
TI:16:23:39 TH:0x648bd0 FI:pk-main.c FN:main,292

  • cannot continue, backend invalid
    /usr/sbin/packagekitd(egg_error_real+0xc9) [0x40f0f9]
    /usr/sbin/packagekitd(main+0x6ab) [0x40e10b]
    /lib64/libc.so.6(__libc_start_main+0xe6) [0x7f95f97ae586]
    /usr/sbin/packagekitd [0x40d999]

using opensuse 11.1 #1 SMP x86_64
on quad-core Phenom processor

Looks like a Networkmanager problem. As the packagekit does not find the Networkmanager it does not know about an internet connection, therefore it thinks it cannot find the update repo, therefore it exits.
If you do have a working internet connection, try rebooting and starting the Software Installer, instead of using the updater. In the Software Installer menu Packages - All Packages - Update if a newer version is available. This installs all updates.

yeah I did that, but it doesn’t solve the issue of automatic updates.

is network manager fixable?

what version of packagekit do you have installed

i had this same error with version 0.3.11-2.1
downgraded to 0.3.11-1.14.1 from the update repo and problem solved

Got the same problem… but the solution in this post fixed it
cannot install anything anymore - openSUSE Forums