DBus error : Unable to get transaction id from packagekit.

Hello,

After an udate I get this error message:
DBus error : Unable to get transaction id from packagekit.

This error also shows when I click the yellow triangle.

When I start the manual update this shows:

Er is een fout opgetreden bij de initialisatie van de installatiebron.
‘repo-oss’: |] Failed to cache repo (129).
History:

  • ‘repo2solv.sh’ ‘-o’ ‘/var/cache/zypp/solv/repo-oss/solv’ ‘/var/cache/zypp/raw/repo-oss’
    Can’t exec ‘repo2solv.sh’ (Bestand of map bestaat niet).

It seems some shell is not there anymore.

What to do?

Kind regards,
Bertus

PS I use a dutch translation of the OpenSUSE 11.2

Hello Bertus,

Welcome to these forums (seeing this is your first post).
There are more dutch people here, so I hope you feel at home.

It is not a shell that is missing, but a script (repo2solv.sh). Maybe somebody else will come here with a more direct answer, but I can only ask you to explain a little bit more about the situation.

You say “After an update …”. What sort of update was that. Just the update applet, or updates from some repositories? Also the ouput of

zypper lr -d

may help people to get more insight in your situation.

And please put computer output between CODE tags (select the copy/pasted text and click the # button in the bar above).

Hello,

Thanks for the reply.
It was an update with the update applet that gave the error afterwards.

The zypper command you gave gives this as an answer:


linux-85pi:/home/bert # zypper lr -d
# | Alias                               | Naam                             | Ingeschakeld | Vernieuwen | Prioriteit | Type   | URI                                                                      | Service
--+-------------------------------------+----------------------------------+--------------+------------+------------+--------+--------------------------------------------------------------------------+--------
1 | 11.2                                | 11.2                             | Ja           | Ja         |   99       | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/11.2/                     |
2 | http-download.opensuse.org-d791dd09 | Bijwerkingen van openSUSE 11.2-0 | Ja           | Ja         |   99       | rpm-md | http://download.opensuse.org/update/11.2/                                |
3 | openSUSE 11.2-0                     | openSUSE 11.2-0                  | Ja           | Nee        |   99       | yast2  | cd:///                                                                   |
4 | openSUSE_11.2                       | openSUSE_11.2                    | Ja           | Ja         |   99       | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/ |
5 | openSUSE_11.2_1                     | openSUSE_11.2                    | Ja           | Ja         |   99       | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |
6 | repo-debug                          | openSUSE-11.2-Debug              | Nee          | Ja         |   99       | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/           |
7 | repo-non-oss                        | openSUSE-11.2-Non-Oss            | Ja           | Ja         |   99       | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/             |
8 | repo-oss                            | openSUSE-11.2-Oss                | Ja           | Ja         |   99       | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                 |
9 | repo-source                         | openSUSE-11.2-Source             | Nee          | Ja         |   99       | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/          |
linux-85pi:/home/bert #

Kind regards,
Bertus

Hm, I do not know if it is the origin of your problem, but #3 is the CD/DVD. That should be disabled once you start using the online repos. (use YaST > Software > Softwarebronnen, select the repos and uncheck “Ingeschakeld”. Then click OK).

Then you have two more repos then the four advised here. Again I do not know if these spoil what you have. But the general idea is that apart from OSS, Non-OSS, Update and Packman, one should disable other repos after the install. Only enable one when you want to install again from them (newer version or other packages) and thendisable them again.

May be try again to run the manual update (and please show what you do, we want to see the statement, not a story). But in fact I doubt if it is cured allready. But we should check after those Uitschakelen. :slight_smile:

Hello,

I have disabled the repositories and left the 4 basic ones.


linux-85pi:/home/bert # zypper lr -d
# | Alias                               | Naam                             | Ingeschakeld | Vernieuwen | Prioriteit | Type   | URI                                                                      | Service
--+-------------------------------------+----------------------------------+--------------+------------+------------+--------+--------------------------------------------------------------------------+--------
1 | 11.2                                | 11.2                             | Ja           | Ja         |   99       | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/11.2/                     |
2 | http-download.opensuse.org-d791dd09 | Bijwerkingen van openSUSE 11.2-0 | Ja           | Ja         |   99       | rpm-md | http://download.opensuse.org/update/11.2/                                |
3 | openSUSE 11.2-0                     | openSUSE 11.2-0                  | Nee          | Nee        |   99       | yast2  | cd:///                                                                   |
4 | openSUSE_11.2                       | openSUSE_11.2                    | Nee          | Ja         |   99       | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.2/ |
5 | openSUSE_11.2_1                     | openSUSE_11.2                    | Nee          | Ja         |   99       | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.2/         |
6 | repo-debug                          | openSUSE-11.2-Debug              | Nee          | Ja         |   99       | NONE   | http://download.opensuse.org/debug/distribution/11.2/repo/oss/           |
7 | repo-non-oss                        | openSUSE-11.2-Non-Oss            | Ja           | Ja         |   99       | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/             |
8 | repo-oss                            | openSUSE-11.2-Oss                | Ja           | Ja         |   99       | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                 |
9 | repo-source                         | openSUSE-11.2-Source             | Nee          | Ja         |   99       | NONE   | http://download.opensuse.org/source/distribution/11.2/repo/oss/          |
linux-85pi:/home/bert #

When I use yast in a shell I get this warning afther I give the update command:


Er is een fout opgetreden bij de initialisatie van de     │ │
                                                                  │  │installatiebron.                                          │ │
                                                                  │  │'repo-oss': |] Failed to cache repo (129).               │ │
                                                                  │  │History:                                                  │ │
                                                                  │  │- 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo-oss/solv'│ │
                                                                  │  │'/var/cache/zypp/raw/repo-oss'                            │ │
                                                                  │  │Can't exec 'repo2solv.sh' (Bestand of map bestaat niet)


When I continue I get the following window:


Er is nog geen bijwerkinstallatiebron                │
                                                                      │  geconfigureerd. De configuratie-workflow nu draaien? │
                                                                      │                                                       │
                                                                      │                      [Ja] [Nee]                       


Then I get the question if I want to use the auto-update.

I do not want to do this , because that gave me trouble before.

Kind regards,
Bertus

Hello,

Afther posting I tried to install some software and bumped into this error:


nothing provides requested glibc                                                                                                                                                               │
 ││Z                                                                                                                                                                                               │
 ││B┌Mogelijke oplossingen───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┐ │
 ││ │ ] ignore the warning of a broken system (requires:glibc)    

I hope this will give some clue.

Kind regards,
Bertus

Don’t try to install new software until your problem is solved.

Allthough your repos look good to me, we could try to remove and add anew the OSS repos (#8). Use YaST > Software > Software bronnen again to remove that repos, but save the URL somewhere. Click OK.
Start again and then Toevoegen. In the next screen: URL. In thh next add the URL and finish.

Then as root try

zypper dup

You will ost pobably loose the special versions of Wine and FF you installed from the extra repos, but that can be done later.

BTW. I am going to sleep now. Either see your post tomorrow, or other ppl will tune in here.

Hello,

I did have a look in the logfiles and found one of zypp.

In there you can see what the update has done:


2010-05-30 17:11:04|remove |libzypp|6.21.2-1.1.1|i586|
2010-05-30 17:11:05|remove |satsolver-tools|0.14.10-1.1.1|i586|
# 2010-05-30 17:11:10 zypper-1.3.4-0.1.3.i586.rpm installed ok
# Additional rpm output:
# Starting SuSEconfig, the SuSE Configuration Tool...
# Running module permissions only
# Reading /etc/sysconfig and updating the system...
# Executing /sbin/conf.d/SuSEconfig.permissions...
# Checking permissions and ownerships - using the permissions files
#       /etc/permissions
#       /etc/permissions.easy
#       /etc/permissions.d/mail-server
#       /etc/permissions.d/postfix
#       /etc/permissions.local
# setting /usr/sbin/zypp-refresh-wrapper to root:root 4755. (wrong permissions 0755)
# Finished.
#
2010-05-30 17:11:10|install|zypper|1.3.4-0.1.3|i586||http-download.opensuse.org-d791dd09|1d99fcbe66a8f32957a1fe1bc944c2cab02ef1f0
2010-05-30 17:11:12|install|yast2-ncurses-pkg|2.18.4-2.10.2|i586||http-download.opensuse.org-d791dd09|670f91a8eb80bc25fa969bafd10bedcf2af929d7
2010-05-30 17:11:15|install|yast2-qt-pkg|2.18.22-1.1.1|i586||http-download.opensuse.org-d791dd09|2af4cd8178d05cb54c3affa956dcfa0a19662f94
2010-05-30 17:11:17|install|libqdialogsolver1|1.3.0-2.12.1|i586||http-download.opensuse.org-d791dd09|10c953d7297fbf72f14d859076f9b88430b48915
2010-05-30 17:11:18|install|yast2-pkg-bindings|2.18.11-1.3.1|i586||http-download.opensuse.org-d791dd09|70dd956b91d4938f23d9886c8b5f5fdb55adfde6
2010-05-30 17:11:21|install|PackageKit|0.5.1-3.8.1|i586||http-download.opensuse.org-d791dd09|304c4bbe7ac4cac832b58372ac0cc453ca48586e
2010-05-30 17:11:22|install|kupdateapplet-packagekit|0.9.9-0.1.1|i586||http-download.opensuse.org-d791dd09|8f5bd0cb7400bab45059477b95cbaf04bcaf02a4
2010-05-30 17:11:26|install|kupdateapplet|0.9.9-0.1.1|i586||http-download.opensuse.org-d791dd09|806dea98605657d9e7724c3156cd17d152d0986c
                                                                                                                                                      

As you can see the libzypp and satsolver-tools are removed in the first lines.

I hope this will give some more info.

Kind regards,
Bertus

Hello,

When I use the “zypper dup” I get the following result:


linux-85pi:/var/log/zypp # zypper dup
Waarschuwing: U staat op het punt een distributieopwaardering te doen met alle installatiebronnen ingeschakeld. Verzeker u ervan dat alle installatiebronnen compatibel zijn met elkaar voordat u verder gaat. Zie 'man zypper' voor meer informatie over dit commando.
Doelinitialisatie is mislukt:
rpmdb2solv -r '/' -p '/etc/products.d'  > '/var/cache/zypp/solv/@System/solvdGXhxJ'
     /bin/sh: rpmdb2solv: opdracht niet gevonden

linux-85pi:/var/log/zypp #

Kind regards,
Bertus

Hello,

I also tried to remove and add the repositories again and got the following message from zypper dup :


linux-85pi:/home/bert # zypper dup
Waarschuwing: U staat op het punt een distributieopwaardering te doen met alle installatiebronnen ingeschakeld. Verzeker u ervan dat alle installatiebronnen compatibel zijn met elkaar voordat u verder gaat. Zie 'man zypper' voor meer informatie over dit commando.
Doelinitialisatie is mislukt:
rpmdb2solv -r '/' -p '/etc/products.d'  > '/var/cache/zypp/solv/@System/solvkMy2Xp'
     /bin/sh: rpmdb2solv: opdracht niet gevonden

linux-85pi:/home/bert #


Afther the removing and adding the repositories I still get an error like before in the yast post.
The changes are NOT saved.

Bertus

Hello,

As I have said in an earlier post the “satsolver” was removed.
This contains the “repo2solv.sh” script.
It seems there was a newer version installed.
I downloaded the satsolver from the repository and try to install it.


linux-85pi:/home/bert/Download/Linux/SUSEpaketten # rpm -ihv satsolver-tools-0.14.10-1.1.1.i586.rpm                                                                                                   
Preparing...                ########################################### [100%]                                                                                                                        
        package satsolver-tools-0.14.17-1.1.2.i586 (which is newer than satsolver-tools-0.14.10-1.1.1.i586) is already installed                                                                      
        file /usr/bin/deltainfoxml2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                        
        file /usr/bin/dumpsolv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                                 
        file /usr/bin/mergesolv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                                
        file /usr/bin/repo2solv.sh from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                             
        file /usr/bin/repomdxml2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                           
        file /usr/bin/rpmdb2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                               
        file /usr/bin/rpmmd2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                               
        file /usr/bin/rpms2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                                
        file /usr/bin/susetags2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                            
        file /usr/bin/updateinfoxml2solv from install of satsolver-tools-0.14.10-1.1.1.i586 conflicts with file from package satsolver-tools-0.14.17-1.1.2.i586                                       
linux-85pi:/home/bert/Download/Linux/SUSEpaketten #

It refused to install then I used the --force.

Now the repo2solv.sh shell is found.

The software installer works, but the updater still has problems.

This gives now the following error:


PackageKit Error internal-error: Failed to cache rpm database (127).

Could it be there is a mixup in the repositiries?

Bertus

The latest version is satsolver-tools-0.14.17, that’s the one you should be using.

When you fetch something manually from the repositories, you should look first in updates, then the main.

Hello,

Afther installing the satsolver it was possible to do an online update.
Now the system seems to be OK again.

Greetings,
Bertus

Nice you have sorted it out.

Enjoy openSUSE.