DBus error : Unable to get transaction id from packagekit.

Weird error on 11.1 x86_64 - I get it when I try to do autoupdate from the tray updater. I tried searching the forums for this error but didn’t find. I tried rpm --rebuilddb as su, but that didn’t fix. I start YaST and chose Software / Online Update and get: Accessing the Package Management Failed - the system management is locked by the application with pid 29603 (/usr/lib/YaST2/bin/y2base).

I tried killing the updater tray applet, but to no avail…

TYAN2-Linux:/home/patti # ps -al
0 S 1000 8100 8079 0 80 0 - 3401 rt_sig pts/1 00:00:00 csh
4 S 0 17287 17267 0 80 0 - 12921 wait pts/3 TYAN2-Linux:/home/patti # ps -a
8100 pts/1 00:00:00 csh
17287 pts/3 00:00:00 su
17290 pts/3 00:00:00 bash
17327 pts/5 00:00:00 kdesu_stub
17429 pts/3 00:00:00 ps
32445 pts/1 00:00:00 csh
TYAN2-Linux:/home/patti # 00:00:00 su
4 S 0 17290 17287 0 80 0 - 3503 wait pts/3 00:00:00 bash
4 S 0 17327 17324 0 80 0 - 1008 wait pts/5 00:00:00 kdesu_stub
4 R 0 17477 17290 99 80 0 - 1137 - pts/3 00:00:00 ps
0 S 1000 32445 8100 0 80 0 - 3213 - pts/1 00:00:00 csh
TYAN2-Linux:/home/patti #

This is an 8-quad-core (32 total cores) tyan Opteron machine with 64 GB memory and has run flawlessly for the last year. Also, I’m using YaST/Proxy to reach the repos.

From what you state it is not so weired. Apparently an application (maybe a former session of yast) has a problem. The script tells you that it cannot access the package kit because another application is not freeing the resource.
pid 29603 should be this application.
Try to do the following:
open terminal (konsole) and type: top
this will show you all running processes. Search for 29603. If you see it is yast but you didn’t open it, try to kill it.
You do this with kill numberofthread
For commodity you can open a second tab to type the command. So top remains open and you can control that the process is gone.
The update applet should now reach the package kit.

**Disregard, **I read your post more sorrowful. With all evidence you do not need this advice. However this error is somehow familiar to me from the past. Maybe 2 years ago I had the same on a 64 bit machine. Will try to recall.

Seems like there’s an instance of Yast’s sofrware manager already running. It’s locking the communication with packagekit. So both the updater applet and the software installer are blocked by this running instance of y2base.

If you’re not sure, reboot the system and see of that helps, otherwise kill the mentioned y2base process 29603, check if it indeed is killed, and try again.

Hey, Stakanov, I read this one first :wink:

@Kurpht :stuck_out_tongue: Naaaaaaaa, first!
But seriously, she seems to have a quite professional background. So I do not think it did not come to her mind. Anyway yast2base is to all extend a session of yast, not the updater.
I recall this error from some years ago but this bl… Alzheimer does not help at all.

At home right now - will try tomorrow…

Revisit this a few days later (after a system reboot) and all works normally. I guess it was some YaST/rpm process run wild that was locking the database, but I didn’t know how to figure out which process it was, and I didn’t want to start killing things willy-nilly… Thanks!

Hey Patti. You do not need to kill things “willy-nilly” (love the expression). If it is a rpm/yast process it is like in Highlander the immortal: there can be only one. Yast2base processes for what I know cannot be running if not intentionally to set up things (that is hardware or to install software). If the top command will give you only one yast2base running…it is the right one.

I have had the same sequence of failure notices on two different installations, but since everything works just fine i don’t bother trying to fix it. Maybe the next update is going to run smooth?

Greetings from wonderful, smalltown Liederbach, Germany
PS: Liederbach literally translates to “Songscreek”:slight_smile: