Day 1 with Linux. Error 25 GRUB stage 1.5

Hello everyone. A few days ago I decided to ditch Windows for good. I read for hours about a Linux distro and settled on OpenSUSE.

I just need to say one thing. Linux is not for the feint of heart, and everywhere I turn (forums), I see computers riddled with error messages, frustrated people, and the list goes on.

I’m willing to work through this though since I feel that the benefits will outweigh anything that Microsoft can offer, so here goes.

Upon installing the new build of OpenSUSE, I encountered an error message that was fixed by hitting retry (I forgot the name, but I remember it being something like Etk3 or something of the sort).

My issue now is not being able to boot into the OS. I’m getting Error 25 from GRUB on stage 1.5

Thank you for reading,
Michael

Clarification: I’ve installed 11.1 over my Windows XP partition. I want XP no more. Additionally, I read the sticky and followed all the instructions. I also selected the KDE desktop (I still don’t know the difference between that and GNOME despite Googling it several times).

Upon installing the new build of OpenSUSE, I encountered an error message stating the following: “Error Detected. The Ext3 file system of the partition /dev/sda2 is corrupted. To repair the file system, press repair.” Repairing did not work since it said there was an “Error reading block 175 (Attempt to read block from filesystem resulted in short read). /dev/sda2: UNEXPECTED INCONSISTENCY: RUN fsck MANUALLY. (i.e., without -a or -p options)” which I have no clue about, so I decided to hit skip.

My issue now is not being able to boot into the OS. I’m getting Error 25 from GRUB on stage 1.5

I’ve committed to becoming a nerd, and one day I hope to be one of the gurus answering all of these questions about OpenSUSE that so many people seem to have. I’m going to be as patient as I can for now since I really don’t want to give up on this.

Apparently, I’ve another error from /sda3 as well as /sda2

I don’t even know what /sda is.

Additionally, it’s telling me now (I swear it didn’t tell me this before) that I have no mountable partitions or valid root partitions.

forget /sda, it’s time for /sigh

sda is a hard drive and sda1, sda2, etc are partitions on it.

As far as the errors go, have you simply tried reinstalling to see if it fixes itself?

Hey, thanks for replying! Yes, I’ve tried several reinstalls.

Hi,

The error you are getting from grub is literally this:

**25 : Disk read error
This error is returned if there is a disk read error when trying to probe or read data from a particular disk. **

That is usually a very bad sympton, and could be reporting some physical disk fault. This seems to be confirmed by the corrupt errors you got also.
Under these circumstances, taking also into account that you don´t seem to be very familiar with linux disk basic management, I would suggest to try again with a healthy disk.

By the way, /dev/sdx (x being a,b,c… and so on so forth) is what is called a disk device file.
To make it short, it is the linux way of handling and refering to disk devices, something similar to Windows C:, D:, etc.

Please take a look to the chapter 10 of this excelent article to know more about disk naming convention and management:

Concepts - openSUSE

In your current situation, it is a must.

Enjoy it!

Hope this help.

Regards.

It does sound like the hard drive may have something wrong with it, or if your lucky, it could be the media your installing from is faulty.

When installing you can do a media check, if you haven’t done this try it next.

Here’s some install info Installation Help - openSUSE

Thank you all very much for the responses.

The media check did pass, but I read on another forum that some guy has been having the exact same problem and fixed it by doing the following:

“All you have to do is go into your CMOS setting in your bios. Make sure all of your hard drives are set to manual (or user) and to LBA mode.”

No idea how to do this. I smashed F8 to get into BIOS, but couldn’t find any CMOS settings anywhere for changing my hard drive settings.

Hi,

The media check installation task will only verify that the dvd installation sources are healthy but won´t test every physical block state in every disk in your system.

Regarding the LBA thing in BIOS, it used to be a problem in old machines. New ones, featuring disks with storage capacity above 10 GB have this mode enabled by default. Anyway, to be on the safe side, double check it is so by entering into your BIOS setting utility. If unsure about what this is and how to manage it, read the manual for your BIOS.

The grub version that is shipped with Open Suse, grub-0.97-156.3, is the GNU one, which supports LBA.
So, if enabled in BIOS, it won´t give you any trouble.

If after that you are still getting grub errors like the one at the very beginning, they are likely caused by a faulty disk.

Regards.

I don’t think this is the problem! If your computer was manufactured in the last decade and has a drive detected as larger than 8.4GB, the BIOS settings should be OK.

If the install media is OK then your hard drive probably has some bad sectors.

One last thing I forgot to mention:

Some computer BIOSes have diagnostic tools for the hardware. For example, my Lenovo T60 has a dianostic tool that performs a very basic hard disk verification.
Check if your BIOS has something like that, it could help to spot physical faults.

The LBA option is usually found in the Hard Disk section.

Regards.

Thank you all much! I’m going to get on this and keep you all updated.

The thing that baffles me is that my machine ran Windows just fine, so I don’t see how or why it could be a problem with my disk.

Also, lots of other people converting from Windows are getting this Error 25 message. Maybe we aren’t wiping correctly? Do you recommend any programs that can thoroughly wipe a drive to prepare it, possibly?

Hi,

There is no need to prepare the disk as long as yast is told at installation time what partition(s) it should use to create the linux disk hierarchy into and blank space where to create them, since it will take care of every detail.

There is one thing you can try to find out if your disk is healthy or not, if you don´t care anymore about what the disk currently stores:
a. Using the the Open Suse 11.1 DVD, boot in rescue mode. Once there, use fdisk to repartition your disk. Depending on the size of the disk, you might want to create a few of them having similar sizes.

Then, use the following command to write zeros to to every one:

dd if=/dev/zero of=/dev/<put-here-the-file-device-name>

Monitor if the above command gives you error messages, for in that case you´ll probably have found out what partition may contain bad sectors.

If you repeat the above for every partition, then you will be able to repartition again, but this time you know which one has the physical problems, so you can focus on it and leave the others alone.

If you repeat this process a few times more, you´ll have probably reduced where the problem is and can tag that partition to not be used for the installation process.

Finally, repartition on more time, but this one keeping the one having problem to the smallest possible size. This one will be the one you have to tell yast not to use for linux.

It is a tricky process, but it will allow you to spot the place that is faulty (if it is this really the problem)

Note: That above will destroy every bit of valuable data in your disk, so think twice before running any command.

Regards.

Disk manufactures generally have utilities you can download to check a disk for faults. So if you know the brand of your disk, I’d do this first, before worrying about trying to clean any data on it.

Awesome, thanks to everyone’s help I’ve gotten past Error 25!

Onto bigger and better things: I’m getting a “Could not start D-Bus. Check your installation.” I’m seeing the splash screen and am able to log on, but this problem is hindering me.

I did an auto repair already.

At the login screen
See the session button, lower left
Click it and select icewm
try logging in with that (it’s kind of basic) but let’s just see if it works

what have you done to get past error 25 ?