Date format is reversed (2021-12-22 vs 22-12-2021)

As subject says, the date format is reversed (2021-12-22 vs 22-12-2021).
How can I fix this??
Region is Australia (wbp_au)
There appears to be no manual settings for date? (There is for Numbers/Time/Currency/Measurement/Collation…) And I probably wouldn’t know if there was - ie correct country…

Thanks.

Did you check in System Settings >> Regional Settings >> Formats?

Where? There are myriads of places in an operating system as well as in applications (specially an application bunch Desktop Environment) where the date is shown.

BTW, while 2021-12-22 is the reversed from 22-12-2021, it is also that 22-12-2021 is the reversed from 2021-12-22. And 2021-12-22 (which happens to be the ISO way of writing the date in numbers) is the un-reversed of 2021-12-22.
So yes, your statement is correct. :slight_smile:

https://drive.google.com/file/d/15EhEh4vFhmslXTH-HHNReGFX-M-5NKB2/view?usp=sharing

Settings > System Settings > Regional Settings > Formats (I presume, where the regional settings, are set…???) (See pic. Don’t think it attached…)
https://drive.google.com/file/d/15EhEh4vFhmslXTH-HHNReGFX-M-5NKB2/view?usp=sharing

https://drive.google.com/file/d/15EhEh4vFhmslXTH-HHNReGFX-M-5NKB2/view?usp=sharing

It looks as if you are doing something in a Desktop configuration/setting, but we still do not know which DE :frowning:

And you can upload images to paste.opensuse.org
Post the link to the page here, not the link to the image.

Running KDE/Plasma. Must admit, don’t understand why this is so difficult? I would have thought that System Settings, is just that. Where else would I configure the regional settings? I am not a developer, so would not go looking in the heart of the system…
Would also like to get you a KDE/Plasma version, but again, go to System Settings > Help > About KDE, and… nothing. No hint to as what version you are actually running?
Link to screenshot: https://paste.opensuse.org/67030845

Anyway, thanks.

From the screenshot I presume you get what you asked for. Open a shell and run:

karl@i3-4130:~> locale 
LANG=de_DE.UTF-8 
LC_CTYPE="de_DE.UTF-8" 
LC_NUMERIC="de_DE.UTF-8" 
LC_TIME="de_DE.UTF-8" 
LC_COLLATE="de_DE.UTF-8" 
LC_MONETARY="de_DE.UTF-8" 
LC_MESSAGES="de_DE.UTF-8" 
LC_PAPER="de_DE.UTF-8" 
LC_NAME="de_DE.UTF-8" 
LC_ADDRESS="de_DE.UTF-8" 
LC_TELEPHONE="de_DE.UTF-8" 
LC_MEASUREMENT="de_DE.UTF-8" 
LC_IDENTIFICATION="de_DE.UTF-8" 
LC_ALL= 
karl@i3-4130:~> 

Thanks.

johno@boss:~> locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=wbp_AU.UTF-8
LC_CTYPE="wbp_AU.UTF-8"
LC_NUMERIC="wbp_AU.UTF-8"
LC_TIME="wbp_AU.UTF-8"
LC_COLLATE="wbp_AU.UTF-8"
LC_MONETARY="wbp_AU.UTF-8"
LC_MESSAGES="wbp_AU.UTF-8"
LC_PAPER="wbp_AU.UTF-8"
LC_NAME="wbp_AU.UTF-8"
LC_ADDRESS="wbp_AU.UTF-8"
LC_TELEPHONE="wbp_AU.UTF-8"
LC_MEASUREMENT="wbp_AU.UTF-8"
LC_IDENTIFICATION="wbp_AU.UTF-8"
LC_ALL=

Looks like somethings missing…

OK. Can you please next time start with telling what you are using (KDE/PLasma this case) and where you are looking. That would spare many people a lot of time doing guessing and assuming.

Since already sometime KDE has coupled the date/time format to the region and thus it can not be set at will by the user (as this was the case in earlier incarnations of KDE, that is what they call “improvement”).

So, you now depends on what KDE thinks is the date/time format is normal for your region. Apparently they think that ISO is the correct format for Australia. I have no idea why you think otherwise.

I can assure you that many people living in other regions will be envy of you. They live in regions where KDE decided (correct or incorrect) that the region does not use the ISO format. Nevertheless these users prefer the ISO format. And they (that is me included) are protesting already sometime to the KDE burocracy and/or using constructed locales (like danish or swedish with changed parts) to get an ISO date in their KDE desktop. >:)

The locale is broken. Run the command and select one from the displayed list:

karl@erlangen:~> locale -a |grep AU 
en_**AU**
en_**AU**.utf8 
karl@erlangen:~> 

Nothing is missing. KDE is using different locale management than glibc, it is impossible to export KDE locale settings as standard POSIX locale string (except in trivial cases). The problem is known for years, but nothing happened so far.

P.S. You still did not describe or show where you see incorrect date format

P.P.S. the question has nothing to do with Install/Boot/Login and should have been asked in Applications with clear subject that includes KDE to draw attention of users familiar with KDE. I do not know how exactly KDE locale settings are exported and whether it is possible to override them for “normal”, non-KDE, programs.

karl@erlangen:~> grep -r de_DE.UTF-8 .config/ 
.config/plasma-localerc:LANG=**de_DE.UTF-8**
karl@erlangen:~> 


Moved to Applications, it being a KDE question/problem.

IMO, blame doesn’t belong directly on KDE. KDE is built on QT. Last time I checked, which has been a while, KDE bugs about locale and date formats were still waiting on necessary fixes from upstream QT. If that remains true, KDE users ought to be pressuring QT devs. This QT bug search returns several open bugs related to iso 8601, which IMO provides the only date format that should ever be used outside local-only communications, but is not available in recent versions of the email program I use. :disapointed:

BTW, nowhere in this thread do I see it made clear which format is the one OP wants.

IMHO, I am a KDE user. When something is wanted, praised, wrong, I tell so to KDE. I am not going to find out if the products they use to make their own product (yes, making computer programs is very much not re-inventing the wheel, but using what is already there as long as it is a good and trusted) and making the detour to go to some sub-sub-sub-product provider (of which I probably know nothing. KDE is the end product delivered to me as end user. so that is where the bug reporst go (and they are there). When KDE is unable to convince their “sub-contracter”, KDE still has a problem.

Indeed. I also only read that 2021-12-21 is the reverse of 21-12-2021 when interpreted as a date. Which is obvious.

BTW, I am also curious what the locale wbp_AU is (take care , the OP first mentions it is wbp_au, but his later computer output shows it as wbp_AU). If my understanding is correct, wbp should be a language and AU the Australian version of it. That makes me understand en_AU as the Australian version of the English language. But what is the language wbp?

Reviewing this thread I believe it is about screenshot of system settings. It shows (short) date format as 2021-12-21 while OP apparently wants it to be 21-12-2021.

wbp is Warlpiri.

The whole is rather complicated.

As already mentioned, KDE is using Qt locale management. Qt supports full definitions found in Unicode Common Locale Data Repository. Not every combination of language_territory has explicit information; for that matter not even every language has explicit information. CLDR supports notion of inheritance - if no definition for language_territory exists, it tries plain language and if it does not exist either it tries defaults. No definitions for wbp_AU or wbp exist, so Qt falls back to default settings which are - guess - yyyy-MM-dd, at least when using Gregorian calendar. Some information is also set based on territory (e.g. wbp_AU locale defines AUD as currency).

To summarize - information comes from CLDR, if someone believes information is wrong for particular combination of language/script/territory/…, one needs to contact CLDR maintainers and present valid reasons why it should be added/changed.

Now back to KDE. There are two problems

  1. KDE does not allow you to independently set format elements. You can only chose one of predefined CLDR locales that control how specific element is formatted. I.e. the only way to change date format is to override Time category and chose different locale. Of course, you do not really know how date/time are formatted in every part of the world so you are left to poke at every possible choice. And it may change also long date format, and time format and this may not be wanted. And locale where everything suites you may not even exist :slight_smile: And I also do not know how calendar system is set in KDE. I would assume Japan or China certainly have own calendars and prefer to use them.
  2. As I already mentioned there are much more locales in CLDR (at least much more locales that are generated by Qt from CLDR data) than are present in glibc locale database. Meaning that when KDE exports this information as POSIX locale string, it results in errors from programs trying to set non-existing locale.

Sure.

Walpiris may create their own locale, “man localedef”. This discussion is lengthy, but the solution is straight forward: https://forums.opensuse.org/showthread.php/526766-How-do-I-set-locale?p=2837041#post2837041