Data recovery

I have a problem in recovering my data from a disk with opensuse installed.
I have the drive connected via USB, but I can not find the data that was supposed to be in the home folder, but this folder is empty.
I have already used a program in windows (UFS Explorer), and in this program I can visualize all the data that I want to recover, so it means that the data is present.
when I try to access the same data through another computer with opensuse Leap 42.3 installed, I can access the disk perfectly, but I can not access the data.
I need help urgently.
thank you

You are probably looking at the mounted root partition but the disk has a separate partition for home. You need to open/mount the home partition. The /home directory on the root partition is just a mountpoint and usually empty.

Plug the disk to usb and show us the output of lsblk. If the output is inconclusive, post it anyway and describe how the system on that disk was set up, ie partioning, filesystems, lvm, encrytion, etc.

Also, many filemanagers can mount partitions. Dolphin can and whatever Gnome provides as filemanager can probably too. So check the side panels for “disks” appearing after you plug in the disk.

This is the result of lsblk

linux-1q5f:~ # lsblk
sda 8:0 0 232.9G 0 disk
├─sda1 8:1 0 1K 0 part
├─sda5 8:5 0 2G 0 part [SWAP]
├─sda6 8:6 0 40G 0 part /var/crash
└─sda7 8:7 0 73.9G 0 part /home
sdb 8:16 0 698.7G 0 disk
├─sdb1 8:17 0 156M 0 part
├─sdb2 8:18 0 650G 0 part /media
└─sdb3 8:19 0 48.5G 0 part
sr0 11:0 1 1024M 0 rom

The disk have the following characteristics

/dev/sbd1 | Size: 156.00MiB | Type: EFI boot | Fs Type: FAT
/dev/sbd2 | Size: 650.01GiB | Type: Linus Native | Fs Type: BtrFS | Mount Point: /run/media/Leds/System
/dev/sbd3 | Size: 48.47GiB | Type: Linux Swap | Fs Type: Swap


If you have access to another computer you might want to try to recover the data.

I tried it, and I did not succeed either, I really want someone to help me with a how to mount the partition / home, which is where my data is


Can you boot from a rescue CD? If so, you can use the provided disks application to mount your /home partition, and then access it from your file manager of choice.

I use gnome rather than KDE, and I’ve been able to do this with applications “disks” and “nautilus” both from the rescue disk.
I hope it helps.

Since the target filesystem is btrfs you need to mount as a subvolume;

So your sdb2 is the volume (top level), home is a subvolume of sdb2…

After you’ve mounted the volume,
If you still can’t see the data on the partition,

  1. Your next step should be to clone the drive so that you can attempt recovery while still having a copy in case things go wrong.
  2. You can try to recover the files using the methods described in two references I provided in the following Forum post

Good Luck,

We do not know what is wrong with the drive. It could be a hardware failure. My practice has been to make two copies of the needed partitions with dd-rescue and work with one of the copies.

Malcolm already posted the only thing possible: /home is a subvolume of sdb2 …

My comment was referenced to TSU’s contingency for the data still being inaccessible after trying to mount the sub-volume.

If the only problem was not knowing how to mount a sub-volume, why did CodeBreaker not just boot from the drive and access the data in the same manner that it was written? I, perhaps erroneously, supposed that their must be some other problem. If the drive is failing it is preferable to make a copy before subjecting it to further risk.


I’ve tried everything, already tried to use the yast partitioner to try to mount the subvolume, already tried with several cd rescue (parted magic, rescatux, hirens bootcd, system rescue cd, redobackup, etc), always without success.
I do not know what to do, I really need help :(:(:frowning:


On your OpenSUSE PC, run ‘mount’, or ‘df -h’, look for an entry for /home. My guess is you have a new partition mounted to /home.

‘umount /home’ and then see if your data is in /home, hidden by the new mounted filesystem.

If the data is there, you can temporarily mount whatever is mounted to /home, to another directory, maybe /media. Then copy the data from the root filesystem /home to the new partition and remount it.

Otherwise, you could discard the mounted /home, but you’ll need to make sure you don’t have user id mismatches.